Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/График смен. Текущая смена, на сегодня. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » График смен. Текущая смена, на сегодня. (Формулы/Formulas)
График смен. Текущая смена, на сегодня.
UpFRONT Дата: Четверг, 22.11.2018, 01:50 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте. ПОмогите пожалуйста советом или делом. Необходимо создать формулами решение по поиску текущей смены.
есть смены А,Б,В,Г,Д есть временной интервал смен 1 - с 23-00, 2 -с 7-00, 3 -с15-00. Необходимо найти текущую смену согласно текущей даты и времени (с обращением к ячейки с текущей сменой).
К сообщению приложен файл: __.xlsx(9.7 Kb)
 
Ответить
СообщениеЗдравствуйте. ПОмогите пожалуйста советом или делом. Необходимо создать формулами решение по поиску текущей смены.
есть смены А,Б,В,Г,Д есть временной интервал смен 1 - с 23-00, 2 -с 7-00, 3 -с15-00. Необходимо найти текущую смену согласно текущей даты и времени (с обращением к ячейки с текущей сменой).

Автор - UpFRONT
Дата добавления - 22.11.2018 в 01:50
krosav4ig Дата: Четверг, 22.11.2018, 03:43 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1729
Репутация: 728 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Здравствуйте.
Код
=ИНДЕКС(A:A;ПОИСКПОЗ(ПРОСМОТР(ОСТАТ(ОТБР(A1*24);24);{0:7:15:23};{1:2:3:1});ИНДЕКС(1:10;;ПОИСКПОЗ(ОТБР(A1);2:2));))

но это не точно
ибо данных за предыдущий день нету, а оно надо


(_)Õvõ(_)

Сообщение отредактировал krosav4ig - Четверг, 22.11.2018, 03:44
 
Ответить
СообщениеЗдравствуйте.
Код
=ИНДЕКС(A:A;ПОИСКПОЗ(ПРОСМОТР(ОСТАТ(ОТБР(A1*24);24);{0:7:15:23};{1:2:3:1});ИНДЕКС(1:10;;ПОИСКПОЗ(ОТБР(A1);2:2));))

но это не точно
ибо данных за предыдущий день нету, а оно надо

Автор - krosav4ig
Дата добавления - 22.11.2018 в 03:43
UpFRONT Дата: Четверг, 22.11.2018, 12:33 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Вроде работает , спасибо krosav4ig. А что необходимо чтобы еще и подсветить (цветом) текущую ячейку-смену в календаре. Условное форматирование? какое условие?


Сообщение отредактировал UpFRONT - Четверг, 22.11.2018, 12:34
 
Ответить
СообщениеВроде работает , спасибо krosav4ig. А что необходимо чтобы еще и подсветить (цветом) текущую ячейку-смену в календаре. Условное форматирование? какое условие?

Автор - UpFRONT
Дата добавления - 22.11.2018 в 12:33
_Boroda_ Дата: Четверг, 22.11.2018, 13:21 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13660
Репутация: 5574 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=ПРОСМОТР(;-1/(ПОИСКПОЗ(ЧАС(A1+"1:");{0:8:16})=ИНДЕКС(3:7;;ПОИСКПОЗ(A1;2:2)));A3:A7)

Для УФ формула
Код
=($A3=$H$13)*(B$2=ОТБР($A$1))
К сообщению приложен файл: -38-1.xlsx(11.4 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=ПРОСМОТР(;-1/(ПОИСКПОЗ(ЧАС(A1+"1:");{0:8:16})=ИНДЕКС(3:7;;ПОИСКПОЗ(A1;2:2)));A3:A7)

Для УФ формула
Код
=($A3=$H$13)*(B$2=ОТБР($A$1))

Автор - _Boroda_
Дата добавления - 22.11.2018 в 13:21
krosav4ig Дата: Четверг, 22.11.2018, 17:42 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1729
Репутация: 728 ±
Замечаний: 0% ±

Excel 2007,2010,2013
[offtop]
ЧАС
чет меня прет ... гыыы :D [/offtop]


(_)Õvõ(_)
 
Ответить
Сообщение[offtop]
ЧАС
чет меня прет ... гыыы :D [/offtop]

Автор - krosav4ig
Дата добавления - 22.11.2018 в 17:42
Dronocop Дата: Четверг, 29.11.2018, 12:45 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте, подскажите пожалуйста как сделать так, чтобы возможно было подсчитать дневные и ночные смены
К сообщению приложен файл: 2777010.xlsx(19.0 Kb)


Сообщение отредактировал Dronocop - Четверг, 29.11.2018, 12:46
 
Ответить
СообщениеЗдравствуйте, подскажите пожалуйста как сделать так, чтобы возможно было подсчитать дневные и ночные смены

Автор - Dronocop
Дата добавления - 29.11.2018 в 12:45
_Boroda_ Дата: Четверг, 29.11.2018, 12:47 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13660
Репутация: 5574 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
- Прочитайте Правила форума
- Создайте свою тему согласно п.5q Правил форума

В файле вручную в нужном месте нарисуйте нужный результат


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение- Прочитайте Правила форума
- Создайте свою тему согласно п.5q Правил форума

В файле вручную в нужном месте нарисуйте нужный результат

Автор - _Boroda_
Дата добавления - 29.11.2018 в 12:47
UpFRONT Дата: Вторник, 04.12.2018, 23:32 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Излишнее цитирование удалено администрацией

Спасибо за варианты исполнения. Есть одно НО!
Смена 1 это смена с 23-00 сегодня до 07.00 завтра. При проходе по сменам формула выбирает во время например 4-00, смену соответствующую на завтра , а должна сохранить выбранную смену на сегодня.

Тоесть 06.12.18 в 4:00 должна быть смена за 05.12.2018 - СМЕНА Д, а не смена А
К сообщению приложен файл: 7714976.jpg(35.7 Kb)


Сообщение отредактировал UpFRONT - Вторник, 04.12.2018, 23:32
 
Ответить
СообщениеИзлишнее цитирование удалено администрацией

Спасибо за варианты исполнения. Есть одно НО!
Смена 1 это смена с 23-00 сегодня до 07.00 завтра. При проходе по сменам формула выбирает во время например 4-00, смену соответствующую на завтра , а должна сохранить выбранную смену на сегодня.

Тоесть 06.12.18 в 4:00 должна быть смена за 05.12.2018 - СМЕНА Д, а не смена А

Автор - UpFRONT
Дата добавления - 04.12.2018 в 23:32
UpFRONT Дата: Среда, 05.12.2018, 00:32 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Код
=ЕСЛИ(ЕСЛИ((A1-ЦЕЛОЕ(A1)>=0)*(A1-ЦЕЛОЕ(A1)<0,291666667);1;0)=0;ИНДЕКС(A:A;ПОИСКПОЗ(ПРОСМОТР(ОСТАТ(ОТБР(A1*24);24);{0:7:15:23};{1:2:3:1});ИНДЕКС(1:10;;ПОИСКПОЗ(ОТБР(A1);2:2));));ИНДЕКС(A:A;ПОИСКПОЗ(ПРОСМОТР(ОСТАТ(ОТБР(A1*24);24);{0:7:15:23};{1:2:3:1});ИНДЕКС(1:10;;ПОИСКПОЗ(ОТБР(A1-1);2:2));)))

Думаю что я подобрал нужную формулу. Кто может оптимизировать?
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕСЛИ((A1-ЦЕЛОЕ(A1)>=0)*(A1-ЦЕЛОЕ(A1)<0,291666667);1;0)=0;ИНДЕКС(A:A;ПОИСКПОЗ(ПРОСМОТР(ОСТАТ(ОТБР(A1*24);24);{0:7:15:23};{1:2:3:1});ИНДЕКС(1:10;;ПОИСКПОЗ(ОТБР(A1);2:2));));ИНДЕКС(A:A;ПОИСКПОЗ(ПРОСМОТР(ОСТАТ(ОТБР(A1*24);24);{0:7:15:23};{1:2:3:1});ИНДЕКС(1:10;;ПОИСКПОЗ(ОТБР(A1-1);2:2));)))

Думаю что я подобрал нужную формулу. Кто может оптимизировать?

Автор - UpFRONT
Дата добавления - 05.12.2018 в 00:32
_Boroda_ Дата: Среда, 05.12.2018, 00:34 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13660
Репутация: 5574 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Смена 1 это смена с 23-00 сегодня до 07.00 завтра
Дык кто ж знал-то?
Тогда вроде так
Код
=ПРОСМОТР(;-1/(ПОИСКПОЗ(ЧАС(A1+"1:")-8;{-8:0:8})=ИНДЕКС(3:7;;ПОИСКПОЗ(ОТБР(A1-"7:");2:2)));A3:A7)

В файле часы можно прибавлять/отнимать в оранжевой ячейке
К сообщению приложен файл: -38-1_1.xlsx(11.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Смена 1 это смена с 23-00 сегодня до 07.00 завтра
Дык кто ж знал-то?
Тогда вроде так
Код
=ПРОСМОТР(;-1/(ПОИСКПОЗ(ЧАС(A1+"1:")-8;{-8:0:8})=ИНДЕКС(3:7;;ПОИСКПОЗ(ОТБР(A1-"7:");2:2)));A3:A7)

В файле часы можно прибавлять/отнимать в оранжевой ячейке

Автор - _Boroda_
Дата добавления - 05.12.2018 в 00:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » График смен. Текущая смена, на сегодня. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!