Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос/отправка ячеек на др. лист при наступлении даты - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос/отправка ячеек на др. лист при наступлении даты (Формулы/Formulas)
Перенос/отправка ячеек на др. лист при наступлении даты
cors26 Дата: Четверг, 22.11.2018, 14:16 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго времени суток. Поставили задачу со *. Прошу помощи.
При открытии файла - копировать на Лист 2 данные в которых только ячейки из столбцов B, С и N соответствующие условию: "Дата готовности" (столбец N) = "Текущая дата +3 раб.дня" и отправлять в сообщении. ps/ заранее спасибо. :'(
К сообщению приложен файл: tests01.xlsx(23.1 Kb)


Сообщение отредактировал cors26 - Пятница, 23.11.2018, 14:12
 
Ответить
СообщениеДоброго времени суток. Поставили задачу со *. Прошу помощи.
При открытии файла - копировать на Лист 2 данные в которых только ячейки из столбцов B, С и N соответствующие условию: "Дата готовности" (столбец N) = "Текущая дата +3 раб.дня" и отправлять в сообщении. ps/ заранее спасибо. :'(

Автор - cors26
Дата добавления - 22.11.2018 в 14:16
cors26 Дата: Пятница, 23.11.2018, 14:13 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Подскажите хотя бы формулу переноса, с отправкой сообщения разобрался.
 
Ответить
СообщениеПодскажите хотя бы формулу переноса, с отправкой сообщения разобрался.

Автор - cors26
Дата добавления - 23.11.2018 в 14:13
Pelena Дата: Пятница, 23.11.2018, 23:07 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 13311
Репутация: 2931 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B$17:$B$85;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(Лист1!$N$17:$N$85);ЕСЛИ(Лист1!$N$17:$N$85=$E$2+3;СТРОКА(Лист1!$B$17:$B$85)-16);"");СТРОКА(A1)));"")
К сообщению приложен файл: 6429832.xlsx(23.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФормула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B$17:$B$85;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(Лист1!$N$17:$N$85);ЕСЛИ(Лист1!$N$17:$N$85=$E$2+3;СТРОКА(Лист1!$B$17:$B$85)-16);"");СТРОКА(A1)));"")

Автор - Pelena
Дата добавления - 23.11.2018 в 23:07
cors26 Дата: Понедельник, 26.11.2018, 09:48 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
СПАСИБО!!!! то что нужно.
ps/ похоже пытался сделать, но не взлетело - после ЕСЛИ я не ставил ЕЧИСЛО.
 
Ответить
СообщениеСПАСИБО!!!! то что нужно.
ps/ похоже пытался сделать, но не взлетело - после ЕСЛИ я не ставил ЕЧИСЛО.

Автор - cors26
Дата добавления - 26.11.2018 в 09:48
cors26 Дата: Понедельник, 26.11.2018, 12:43 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
вторая часть: добавил макрос отправки (отправляет только активный лист при открытии файла),- как отправить только лист2, в независимости от того какой лист активный... пробовал через ThisWorkbook(Лист2).Copy - не хочет так работать.
К сообщению приложен файл: test03.xlsm(30.1 Kb)
 
Ответить
Сообщениевторая часть: добавил макрос отправки (отправляет только активный лист при открытии файла),- как отправить только лист2, в независимости от того какой лист активный... пробовал через ThisWorkbook(Лист2).Copy - не хочет так работать.

Автор - cors26
Дата добавления - 26.11.2018 в 12:43
Pelena Дата: Понедельник, 26.11.2018, 13:12 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 13311
Репутация: 2931 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Вместо ActiveSheet напишите Sheets("Лист2")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВместо ActiveSheet напишите Sheets("Лист2")

Автор - Pelena
Дата добавления - 26.11.2018 в 13:12
cors26 Дата: Понедельник, 26.11.2018, 14:38 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо. Сработало.
пытаюсь сделать без аутглюка, через CDO.
письмо отправляется, но без вложения, не подскажите что надо добавить в макросе, чтобы отправлялся лист2?
К сообщению приложен файл: 7996815.xlsm(34.1 Kb)
 
Ответить
СообщениеСпасибо. Сработало.
пытаюсь сделать без аутглюка, через CDO.
письмо отправляется, но без вложения, не подскажите что надо добавить в макросе, чтобы отправлялся лист2?

Автор - cors26
Дата добавления - 26.11.2018 в 14:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос/отправка ячеек на др. лист при наступлении даты (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!