Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Нахождение среднего значения суммы из диапазона значений?? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нахождение среднего значения суммы из диапазона значений?? (Формулы/Formulas)
Нахождение среднего значения суммы из диапазона значений??
MAXIMUS_GREEK Дата: Вторник, 27.11.2018, 14:37 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Господа здравствуйте, нужна ваша экспертная помощь, суть проблемы в том что нужно сделать формулу которая могла бы выбирать только числовые значения из определенного диапазона значений, в котором могут быть текстовые значения, суммировать их или выбирать среднее, помогите пожалуйста, файл прилагаю, сейчас там ошибки в суммах так как не понимаю как сделать формулу. Заранее спасибо.
К сообщению приложен файл: ____27.11.18.xlsx(22.8 Kb)
 
Ответить
СообщениеГоспода здравствуйте, нужна ваша экспертная помощь, суть проблемы в том что нужно сделать формулу которая могла бы выбирать только числовые значения из определенного диапазона значений, в котором могут быть текстовые значения, суммировать их или выбирать среднее, помогите пожалуйста, файл прилагаю, сейчас там ошибки в суммах так как не понимаю как сделать формулу. Заранее спасибо.

Автор - MAXIMUS_GREEK
Дата добавления - 27.11.2018 в 14:37
lebensvoll Дата: Вторник, 27.11.2018, 15:01 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 889
Репутация: 24 ±
Замечаний: 0% ±

Excel 2010
MAXIMUS_GREEK, а в какой ячейке Вы пытаетесь "Найти среднее значение суммы из диапазона".
Где этот диапазон, что нужно просуммировать!?
%)
Да и еще в Вашем файле "Приложенном" имеется колонка с расчетом
Код
СРЗНАЧ(E6:E22)

Согласно вашей просьбе она справляется на ура hands
Цитата
которая могла бы выбирать только числовые значения из определенного диапазона значений, в котором могут быть текстовые значения, суммировать их или выбирать среднее

В чем суть вашего вопроса!?
И я бы на вашем месте вместо этой формулы применил бы эту и тогда ИТОГ ваш выглядел бы более лучше:
Код
=ЕСЛИОШИБКА(СРЗНАЧ(E24:E30);)

Тогда возможно в этом и был Ваш вопрос. После чего будет вот так вот все выглядеть
[img][/img]


Кто бы ты ни был, мир в твоих руках

Сообщение отредактировал lebensvoll - Вторник, 27.11.2018, 15:11
 
Ответить
СообщениеMAXIMUS_GREEK, а в какой ячейке Вы пытаетесь "Найти среднее значение суммы из диапазона".
Где этот диапазон, что нужно просуммировать!?
%)
Да и еще в Вашем файле "Приложенном" имеется колонка с расчетом
Код
СРЗНАЧ(E6:E22)

Согласно вашей просьбе она справляется на ура hands
Цитата
которая могла бы выбирать только числовые значения из определенного диапазона значений, в котором могут быть текстовые значения, суммировать их или выбирать среднее

В чем суть вашего вопроса!?
И я бы на вашем месте вместо этой формулы применил бы эту и тогда ИТОГ ваш выглядел бы более лучше:
Код
=ЕСЛИОШИБКА(СРЗНАЧ(E24:E30);)

Тогда возможно в этом и был Ваш вопрос. После чего будет вот так вот все выглядеть
[img][/img]

Автор - lebensvoll
Дата добавления - 27.11.2018 в 15:01
sboy Дата: Вторник, 27.11.2018, 15:19 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2493
Репутация: 699 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Используйте функцию АГРЕГАТ(), со вторым параметром 6, первый параметр выбирайте сами, что надо, суммировать или среднее считать


Яндекс: 410016850021169
 
Ответить
СообщениеДобрый день.
Используйте функцию АГРЕГАТ(), со вторым параметром 6, первый параметр выбирайте сами, что надо, суммировать или среднее считать

Автор - sboy
Дата добавления - 27.11.2018 в 15:19
krosav4ig Дата: Вторник, 27.11.2018, 17:06 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2052
Репутация: 853 ±
Замечаний: 0% ±

Excel 2007,2010,2013
для E5 формула
Код
=ЕСЛИОШИБКА(СРЗНАЧ(E6:ИНДЕКС(E:E;СТРОКА(E4)+ПОИСКПОЗ(A5+1;A6:A999;)));"Н/Д")
для E110
Код
=СУММПРОИЗВ(СУММЕСЛИ($A$5:$A109;A110+1-СТРОКА(A$1:ИНДЕКС(A:A;A110));E$5:E109))
К сообщению приложен файл: _27.11.18-1-.xlsx(23.9 Kb)


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
Сообщениедля E5 формула
Код
=ЕСЛИОШИБКА(СРЗНАЧ(E6:ИНДЕКС(E:E;СТРОКА(E4)+ПОИСКПОЗ(A5+1;A6:A999;)));"Н/Д")
для E110
Код
=СУММПРОИЗВ(СУММЕСЛИ($A$5:$A109;A110+1-СТРОКА(A$1:ИНДЕКС(A:A;A110));E$5:E109))

Автор - krosav4ig
Дата добавления - 27.11.2018 в 17:06
MAXIMUS_GREEK Дата: Среда, 28.11.2018, 12:10 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
для E5 формула

=ЕСЛИОШИБКА(СРЗНАЧ(E6:ИНДЕКС(E:E;СТРОКА(E4)+ПОИСКПОЗ(A5+1;A6:A999;)));"Н/Д")
для E110

=СУММПРОИЗВ(СУММЕСЛИ($A$5:$A109;A110+1-СТРОКА(A$1:ИНДЕКС(A:A;A110));E$5:E109))

спасибо за практический пример, я не сильно силен в формулах, но вот вопрос, в строке ИТОГО ПО ГОРОДУ среднее значение вычисляется некорректно, среднее не должно быть больше 100%, как это можно пофиксить? Да и среднее значение нужно считать из итоговых сумм процентов по каждому разделу


Сообщение отредактировал MAXIMUS_GREEK - Среда, 28.11.2018, 13:03
 
Ответить
Сообщение
для E5 формула

=ЕСЛИОШИБКА(СРЗНАЧ(E6:ИНДЕКС(E:E;СТРОКА(E4)+ПОИСКПОЗ(A5+1;A6:A999;)));"Н/Д")
для E110

=СУММПРОИЗВ(СУММЕСЛИ($A$5:$A109;A110+1-СТРОКА(A$1:ИНДЕКС(A:A;A110));E$5:E109))

спасибо за практический пример, я не сильно силен в формулах, но вот вопрос, в строке ИТОГО ПО ГОРОДУ среднее значение вычисляется некорректно, среднее не должно быть больше 100%, как это можно пофиксить? Да и среднее значение нужно считать из итоговых сумм процентов по каждому разделу

Автор - MAXIMUS_GREEK
Дата добавления - 28.11.2018 в 12:10
MAXIMUS_GREEK Дата: Среда, 28.11.2018, 12:14 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
MAXIMUS_GREEK, а в какой ячейке Вы пытаетесь "Найти среднее значение суммы из диапазона".
Где этот диапазон, что нужно просуммировать!?
Тогда возможно в этом и был Ваш вопрос. После чего будет вот так вот все выглядеть
[img][/img]

смысл в том чтобы корректно складывались итоговые суммы процентов по разделам с учетом того что суммируются не только проценты где то может попасть н/д, ну и соответственно среднее по городу выбирала из итоговых сумм процентов только числовые значения, вот как то так


Сообщение отредактировал MAXIMUS_GREEK - Среда, 28.11.2018, 13:02
 
Ответить
Сообщение
MAXIMUS_GREEK, а в какой ячейке Вы пытаетесь "Найти среднее значение суммы из диапазона".
Где этот диапазон, что нужно просуммировать!?
Тогда возможно в этом и был Ваш вопрос. После чего будет вот так вот все выглядеть
[img][/img]

смысл в том чтобы корректно складывались итоговые суммы процентов по разделам с учетом того что суммируются не только проценты где то может попасть н/д, ну и соответственно среднее по городу выбирала из итоговых сумм процентов только числовые значения, вот как то так

Автор - MAXIMUS_GREEK
Дата добавления - 28.11.2018 в 12:14
MAXIMUS_GREEK Дата: Среда, 28.11.2018, 12:31 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
в итоге я понял что мне нужно благодаря вам друзья, нужно чтобы выводилось среднее по каждому разделу но не выдавалась ошибка а было просто 0%, если по разделу будут все н/д, и в ИТОГЕ ПО ГОРОДУ чтобы соответсвенно тоже было среднее, но это уже просто если в подитогах не будет ошибок. Вот как то так, простите что изначально немного ввел в заблуждение сам не понимал толком что нужно


Сообщение отредактировал MAXIMUS_GREEK - Среда, 28.11.2018, 12:33
 
Ответить
Сообщениев итоге я понял что мне нужно благодаря вам друзья, нужно чтобы выводилось среднее по каждому разделу но не выдавалась ошибка а было просто 0%, если по разделу будут все н/д, и в ИТОГЕ ПО ГОРОДУ чтобы соответсвенно тоже было среднее, но это уже просто если в подитогах не будет ошибок. Вот как то так, простите что изначально немного ввел в заблуждение сам не понимал толком что нужно

Автор - MAXIMUS_GREEK
Дата добавления - 28.11.2018 в 12:31
krosav4ig Дата: Среда, 28.11.2018, 17:49 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2052
Репутация: 853 ±
Замечаний: 0% ±

Excel 2007,2010,2013
MAXIMUS_GREEK, допустим, имеем 4 ячейки, в одной ячейке 100%, в остальных трех н/д. В вашем понимании срелнее по этим ячейкам должно быть 100% или 25%? Если все три ячейки = н/д, то среднее должно быть 0 или н/д?


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
СообщениеMAXIMUS_GREEK, допустим, имеем 4 ячейки, в одной ячейке 100%, в остальных трех н/д. В вашем понимании срелнее по этим ячейкам должно быть 100% или 25%? Если все три ячейки = н/д, то среднее должно быть 0 или н/д?

Автор - krosav4ig
Дата добавления - 28.11.2018 в 17:49
MAXIMUS_GREEK Дата: Четверг, 29.11.2018, 10:43 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
MAXIMUS_GREEK, допустим, имеем 4 ячейки, в одной ячейке 100%, в остальных трех н/д. В вашем понимании срелнее по этим ячейкам должно быть 100% или 25%? Если все три ячейки = н/д, то среднее должно быть 0 или н/д?

думаю что в первом варианте логично будет 25% и во втором варианте 0, вот ломаю голову но знаний не хватает по excel к сожалению как это сделать
 
Ответить
Сообщение
MAXIMUS_GREEK, допустим, имеем 4 ячейки, в одной ячейке 100%, в остальных трех н/д. В вашем понимании срелнее по этим ячейкам должно быть 100% или 25%? Если все три ячейки = н/д, то среднее должно быть 0 или н/д?

думаю что в первом варианте логично будет 25% и во втором варианте 0, вот ломаю голову но знаний не хватает по excel к сожалению как это сделать

Автор - MAXIMUS_GREEK
Дата добавления - 29.11.2018 в 10:43
StoTisteg Дата: Четверг, 29.11.2018, 14:02 | Сообщение № 10
Группа: Авторы
Ранг: Старожил
Сообщений: 1157
Репутация: 103 ±
Замечаний: 0% ±

Excel 2010
Код
=I3*НЕ(ЕНД(I3))
вернёт значение 0, если в I3 Н/Д и значение I3, если там число.


Интуитивно понятный код - это когда интуитивно понятно, что это код.
 
Ответить
Сообщение
Код
=I3*НЕ(ЕНД(I3))
вернёт значение 0, если в I3 Н/Д и значение I3, если там число.

Автор - StoTisteg
Дата добавления - 29.11.2018 в 14:02
krosav4ig Дата: Четверг, 29.11.2018, 15:06 | Сообщение № 11
Группа: Друзья
Ранг: Старожил
Сообщений: 2052
Репутация: 853 ±
Замечаний: 0% ±

Excel 2007,2010,2013
для E5 формула
Код
=СРЗНАЧA(E6:ИНДЕКС(E:E;СТРОКА(E4)+ПОИСКПОЗ(A5+1;A6:A999;)))
для E110 массивная формула
Код
=СУММПРОИЗВ(СУММЕСЛИ($A$5:$A109;A110+1-СТРОКА(A$1:ИНДЕКС(A:A;A110));E$5:E109))

Должны (вроде) работать везде, но андроиде по непонятным причинам обе формулы ругаются на цикличность, на одной машине (если можно это так назвать :D - Xin XP SP3, Excel 2007) намертво вешают Excel
вот так работают и на андроиде и на той машине
для E5
Код
=СРЗНАЧА(E6:ИНДЕКС(E$1:ИНДЕКС(E:E;ПОИСКПОЗ(МАКС(A:A);A:A;)-1);СТРОКА(E4)+ПОИСКПОЗ(A5+1;A6:ИНДЕКС(A:A;ПОИСКПОЗ(МАКС(A:A);A:A;)-1);)))
для E110 с немассивным вводом
Код
=СУММПРОИЗВ(($A$5:$A109=A109+1-СТОЛБЕЦ($A1:ИНДЕКС(1:1;A109)))*Ч(+E$5:E109))/A109
К сообщению приложен файл: 9973296.xlsx(24.0 Kb)


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460

Сообщение отредактировал krosav4ig - Четверг, 29.11.2018, 15:13
 
Ответить
Сообщениедля E5 формула
Код
=СРЗНАЧA(E6:ИНДЕКС(E:E;СТРОКА(E4)+ПОИСКПОЗ(A5+1;A6:A999;)))
для E110 массивная формула
Код
=СУММПРОИЗВ(СУММЕСЛИ($A$5:$A109;A110+1-СТРОКА(A$1:ИНДЕКС(A:A;A110));E$5:E109))

Должны (вроде) работать везде, но андроиде по непонятным причинам обе формулы ругаются на цикличность, на одной машине (если можно это так назвать :D - Xin XP SP3, Excel 2007) намертво вешают Excel
вот так работают и на андроиде и на той машине
для E5
Код
=СРЗНАЧА(E6:ИНДЕКС(E$1:ИНДЕКС(E:E;ПОИСКПОЗ(МАКС(A:A);A:A;)-1);СТРОКА(E4)+ПОИСКПОЗ(A5+1;A6:ИНДЕКС(A:A;ПОИСКПОЗ(МАКС(A:A);A:A;)-1);)))
для E110 с немассивным вводом
Код
=СУММПРОИЗВ(($A$5:$A109=A109+1-СТОЛБЕЦ($A1:ИНДЕКС(1:1;A109)))*Ч(+E$5:E109))/A109

Автор - krosav4ig
Дата добавления - 29.11.2018 в 15:06
_Boroda_ Дата: Четверг, 29.11.2018, 16:12 | Сообщение № 12
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14993
Репутация: 5922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
MAXIMUS_GREEK, у п.10 так и должно быть, что нет подпунктов? Если да, то в Е109 тогда формулу не нужно писать?

У меня тогда такой вариант
Для промежуточных итогов
Код
=ЕСЛИОШИБКА(СРЗНАЧЕСЛИ(A6:A999;"<"&A5+1;E6:E999);"н/д")

Для общего итога (там тоже не больше 100%)
Код
=ЕСЛИОШИБКА(СРЗНАЧЕСЛИ(C5:C109;"<>";E5:E109);"н/д")
К сообщению приложен файл: _27.11.18-1-1.xlsx(23.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеMAXIMUS_GREEK, у п.10 так и должно быть, что нет подпунктов? Если да, то в Е109 тогда формулу не нужно писать?

У меня тогда такой вариант
Для промежуточных итогов
Код
=ЕСЛИОШИБКА(СРЗНАЧЕСЛИ(A6:A999;"<"&A5+1;E6:E999);"н/д")

Для общего итога (там тоже не больше 100%)
Код
=ЕСЛИОШИБКА(СРЗНАЧЕСЛИ(C5:C109;"<>";E5:E109);"н/д")

Автор - _Boroda_
Дата добавления - 29.11.2018 в 16:12
MAXIMUS_GREEK Дата: Понедельник, 03.12.2018, 11:43 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Ребята большое спасибо за помощь! Выручили! respect :up:
 
Ответить
СообщениеРебята большое спасибо за помощь! Выручили! respect :up:

Автор - MAXIMUS_GREEK
Дата добавления - 03.12.2018 в 11:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нахождение среднего значения суммы из диапазона значений?? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!