Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/таблица расчета премии сотрудников - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » таблица расчета премии сотрудников (Формулы/Formulas)
таблица расчета премии сотрудников
Fireglow Дата: Пятница, 21.12.2018, 13:07 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
пояснение к таблице.
1. есть клиенты от которых поступают деньги (столбец А)
2. в столбце В сумма поступлений
3. В столбце С процент вознаграждения сотруднику (он динамичный и меняется в зависимости от суммы поступлений). меняется каким образом: берется приход денег от одного клиента за месяц, далее суммируется и от этой суммы высчитывается размер %. есть градация до 499 000 руб процент 1,55. Далее от 500 000 до 1 600 000 процент уменьшается на определенную сумму которая высчитывается по формуле 1,55-(B2*0,00000005) (B2 - сумма поступления денег от клиента)
например 10 января поступили деньги от Иры 100 000 руб. и 16 января поступили деньги от Иры в размере 400 000 руб. Суммируем приход денег за месяц. получаем 500 000 руб. по формуле (1,55-(B2*0,00000005) получаем процент 1,525

Вопрос, как сделать чтобы процент автоматически считался, а то приходится все время вручную подбивать сумму поступления денег от клиента за месяц и пересчитывать процент. в таблице каждый лист - это месяц
К сообщению приложен файл: 8348993.xls(30.5 Kb)
 
Ответить
Сообщениепояснение к таблице.
1. есть клиенты от которых поступают деньги (столбец А)
2. в столбце В сумма поступлений
3. В столбце С процент вознаграждения сотруднику (он динамичный и меняется в зависимости от суммы поступлений). меняется каким образом: берется приход денег от одного клиента за месяц, далее суммируется и от этой суммы высчитывается размер %. есть градация до 499 000 руб процент 1,55. Далее от 500 000 до 1 600 000 процент уменьшается на определенную сумму которая высчитывается по формуле 1,55-(B2*0,00000005) (B2 - сумма поступления денег от клиента)
например 10 января поступили деньги от Иры 100 000 руб. и 16 января поступили деньги от Иры в размере 400 000 руб. Суммируем приход денег за месяц. получаем 500 000 руб. по формуле (1,55-(B2*0,00000005) получаем процент 1,525

Вопрос, как сделать чтобы процент автоматически считался, а то приходится все время вручную подбивать сумму поступления денег от клиента за месяц и пересчитывать процент. в таблице каждый лист - это месяц

Автор - Fireglow
Дата добавления - 21.12.2018 в 13:07
sboy Дата: Пятница, 21.12.2018, 13:39 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2448
Репутация: 689 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Формула сразу для премии
Код
=C2*ЕСЛИОШИБКА(1/(1/ПРОСМОТР(СУММЕСЛИ($B$2:$B$10;B2;$C$2:$C$10)%%;{0;50;160};{1,55;0;0,75}));1,55-C2*5%%%%)%
К сообщению приложен файл: 1012343.xls(41.5 Kb)


Яндекс: 410016850021169
 
Ответить
СообщениеДобрый день.
Формула сразу для премии
Код
=C2*ЕСЛИОШИБКА(1/(1/ПРОСМОТР(СУММЕСЛИ($B$2:$B$10;B2;$C$2:$C$10)%%;{0;50;160};{1,55;0;0,75}));1,55-C2*5%%%%)%

Автор - sboy
Дата добавления - 21.12.2018 в 13:39
_Boroda_ Дата: Пятница, 21.12.2018, 13:44 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14886
Репутация: 5882 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
У меня другой вариант
Код
=ЕСЛИ(C2;1,55-ЕСЛИ(СУММЕСЛИМН(C:C;B:B;B2;A:A;">"&КОНМЕСЯЦА(A2;-1);A:A;"<="&КОНМЕСЯЦА(A2;0))>=500000;СУММЕСЛИМН(C:C;B:B;B2;A:A;">"&КОНМЕСЯЦА(A2;-1);A:A;"<="&КОНМЕСЯЦА(A2;0)))*0,00000005;)

Или то же самое покороче
Код
=ЕСЛИ(C2;1,55-ТЕКСТ(СУММЕСЛИМН(C:C;B:B;B2;A:A;">"&КОНМЕСЯЦА(A2;-1);A:A;"<="&КОНМЕСЯЦА(A2;0));"[>=500000]0;\0")*0,00000005;)


Fireglow,
от 500 000 до 1 600 000
А дальше, после 1600000? Сделал все по одному алгоритму

А вот это
Код
=ПРОИЗВЕД(C2;D2/100)
можно написать так
Код
=C2*D2%
К сообщению приложен файл: 8348993_1.xls(42.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеУ меня другой вариант
Код
=ЕСЛИ(C2;1,55-ЕСЛИ(СУММЕСЛИМН(C:C;B:B;B2;A:A;">"&КОНМЕСЯЦА(A2;-1);A:A;"<="&КОНМЕСЯЦА(A2;0))>=500000;СУММЕСЛИМН(C:C;B:B;B2;A:A;">"&КОНМЕСЯЦА(A2;-1);A:A;"<="&КОНМЕСЯЦА(A2;0)))*0,00000005;)

Или то же самое покороче
Код
=ЕСЛИ(C2;1,55-ТЕКСТ(СУММЕСЛИМН(C:C;B:B;B2;A:A;">"&КОНМЕСЯЦА(A2;-1);A:A;"<="&КОНМЕСЯЦА(A2;0));"[>=500000]0;\0")*0,00000005;)


Fireglow,
от 500 000 до 1 600 000
А дальше, после 1600000? Сделал все по одному алгоритму

А вот это
Код
=ПРОИЗВЕД(C2;D2/100)
можно написать так
Код
=C2*D2%

Автор - _Boroda_
Дата добавления - 21.12.2018 в 13:44
Fireglow Дата: Пятница, 21.12.2018, 14:11 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
смысл в том что за месяц от одного клиент может поступить несколько оплат, так вот процент считается так берется общая сумма поступлений, от нее берется процент и уже вписывается напротив каждой даты именно этот процент который получился от всей суммы

после 1 600 000 все время процент 0,75

за февраль у васи получилось суммарно 1 286 993,80. по формуле процент будет 1,48565031
 
Ответить
Сообщениесмысл в том что за месяц от одного клиент может поступить несколько оплат, так вот процент считается так берется общая сумма поступлений, от нее берется процент и уже вписывается напротив каждой даты именно этот процент который получился от всей суммы

после 1 600 000 все время процент 0,75

за февраль у васи получилось суммарно 1 286 993,80. по формуле процент будет 1,48565031

Автор - Fireglow
Дата добавления - 21.12.2018 в 14:11
_Boroda_ Дата: Пятница, 21.12.2018, 14:27 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14886
Репутация: 5882 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
после 1 600 000 все время процент 0,75

Тогда так
Код
=ЕСЛИ(C2;1,55-ТЕКСТ(СУММЕСЛИМН(C:C;B:B;B2;A:A;">"&КОНМЕСЯЦА(A2;-1);A:A;"<="&КОНМЕСЯЦА(A2;0));"[>=1600000]""16000000"";[>=500000]0;\0")*0,00000005;)


* Одного Васю для проверки отправил в март месяц
К сообщению приложен файл: 8348993_2.xls(43.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
после 1 600 000 все время процент 0,75

Тогда так
Код
=ЕСЛИ(C2;1,55-ТЕКСТ(СУММЕСЛИМН(C:C;B:B;B2;A:A;">"&КОНМЕСЯЦА(A2;-1);A:A;"<="&КОНМЕСЯЦА(A2;0));"[>=1600000]""16000000"";[>=500000]0;\0")*0,00000005;)


* Одного Васю для проверки отправил в март месяц

Автор - _Boroda_
Дата добавления - 21.12.2018 в 14:27
Fireglow Дата: Пятница, 21.12.2018, 14:39 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
по моей формуле у васи другой процент получается. и после 1 600 000 процент все время 0,75 должен оставаться

а в вашей таблице у пети при 1 700 000 больше 1 процент. чет формула не то считает

Код
=ЕСЛИ(C2>0;ЕСЛИ(C2<500000;1,55;ЕСЛИ(C2>16000000;0,75;(1,55-(C2*0,00000005))));0)
вот моя формула расчета, но она дает расчет только на конкретную строку, а сумму всех выплат одного клиента не учитывает


Сообщение отредактировал Fireglow - Пятница, 21.12.2018, 14:53
 
Ответить
Сообщениепо моей формуле у васи другой процент получается. и после 1 600 000 процент все время 0,75 должен оставаться

а в вашей таблице у пети при 1 700 000 больше 1 процент. чет формула не то считает

Код
=ЕСЛИ(C2>0;ЕСЛИ(C2<500000;1,55;ЕСЛИ(C2>16000000;0,75;(1,55-(C2*0,00000005))));0)
вот моя формула расчета, но она дает расчет только на конкретную строку, а сумму всех выплат одного клиента не учитывает

Автор - Fireglow
Дата добавления - 21.12.2018 в 14:39
_Boroda_ Дата: Пятница, 21.12.2018, 14:47 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14886
Репутация: 5882 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вы другой столбец смотрИте
Сделал в столбце D
А у Васи еще раз повторяю - одна операция в марте. Специально для проверки
Какой у Вас процент у него получается? И почему?
К сообщению приложен файл: 8348993_4.xls(41.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВы другой столбец смотрИте
Сделал в столбце D
А у Васи еще раз повторяю - одна операция в марте. Специально для проверки
Какой у Вас процент у него получается? И почему?

Автор - _Boroda_
Дата добавления - 21.12.2018 в 14:47
sboy Дата: Пятница, 21.12.2018, 15:05 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2448
Репутация: 689 ±
Замечаний: 0% ±

Excel 2010
по формуле процент будет 1,48565031

тогда моя изменится так
Код
=C2*ЕСЛИОШИБКА(1/(1/ПРОСМОТР(СУММЕСЛИ($B$2:$B$10;B2;$C$2:$C$10)%%;{0;50;160};{1,55;0;0,75}));1,55-(СУММЕСЛИ($B$2:$B$10;B2;$C$2:$C$10))*5%%%%)%
К сообщению приложен файл: 0835856.xls(43.0 Kb)


Яндекс: 410016850021169
 
Ответить
Сообщение
по формуле процент будет 1,48565031

тогда моя изменится так
Код
=C2*ЕСЛИОШИБКА(1/(1/ПРОСМОТР(СУММЕСЛИ($B$2:$B$10;B2;$C$2:$C$10)%%;{0;50;160};{1,55;0;0,75}));1,55-(СУММЕСЛИ($B$2:$B$10;B2;$C$2:$C$10))*5%%%%)%

Автор - sboy
Дата добавления - 21.12.2018 в 15:05
Fireglow Дата: Пятница, 21.12.2018, 15:09 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
спасибо большое, разобрался. помогло ))))
 
Ответить
Сообщениеспасибо большое, разобрался. помогло ))))

Автор - Fireglow
Дата добавления - 21.12.2018 в 15:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » таблица расчета премии сотрудников (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!