Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отсортировать строки на разные страницы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отсортировать строки на разные страницы (Формулы/Formulas)
Отсортировать строки на разные страницы
Panechka Дата: Суббота, 05.01.2019, 20:14 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Имеется список из шести колонок, требуется на отдельный лист вывести строки, в первой колонке которых указано EUR USD.
В колонке 'O' на страничке Active напротив таких строк стоит 1, напротив других 0.
Я сделала, но работает не так как надо.
Только формулы, без макросов.

Посмотрите, пожалуйста.
Пример в прикреплённом файле.
К сообщению приложен файл: options-2-.xlsx(12.9 Kb)


Сообщение отредактировал Panechka - Суббота, 05.01.2019, 20:20
 
Ответить
СообщениеИмеется список из шести колонок, требуется на отдельный лист вывести строки, в первой колонке которых указано EUR USD.
В колонке 'O' на страничке Active напротив таких строк стоит 1, напротив других 0.
Я сделала, но работает не так как надо.
Только формулы, без макросов.

Посмотрите, пожалуйста.
Пример в прикреплённом файле.

Автор - Panechka
Дата добавления - 05.01.2019 в 20:14
Nic70y Дата: Суббота, 05.01.2019, 20:29 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5502
Репутация: 1197 ±
Замечаний: 0% ±

ru13;10;03
Код
=ЕСЛИОШИБКА(ИНДЕКС(Active!A$1:A$30;ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(Active!$O$3:$O$30=1;Active!$B$3:$B$30*100+СТРОКА(Active!$B$3:$B$30)/10000);СТРОКА(B1));1)*10000;));"")
Лист Active, столбец O - важно чтоб было 1 или 0?
К сообщению приложен файл: 4098750.xlsx(21.1 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ИНДЕКС(Active!A$1:A$30;ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(Active!$O$3:$O$30=1;Active!$B$3:$B$30*100+СТРОКА(Active!$B$3:$B$30)/10000);СТРОКА(B1));1)*10000;));"")
Лист Active, столбец O - важно чтоб было 1 или 0?

Автор - Nic70y
Дата добавления - 05.01.2019 в 20:29
Panechka Дата: Суббота, 05.01.2019, 20:57 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
=ЕСЛИОШИБКА(ИНДЕКС(Active!A$1:A$30;ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(Active!$O$3:$O$30=1;Active!$B$3:$B$30*100+СТРОКА(Active!$B$3:$B$30)/10000);СТРОКА(B1));1)*10000;));"")


Столбец O не так важен, фактически он дублирует смысловую нагрузку столбца A. Небольшая помарка - теперь про добавлении на новую страничку строки меняются местами, можно как-то сохранить их порядок, как на первой странице?
Т.е. если сверху была сделка за 20 декабря, её нужно также оставить первой сверху. Исходные данные в эту табличку копируются извне и порядок очень важен.

Строк в таблице всего примерно 5000, после изменения $30 на $5000 всё перемешалось.


Сообщение отредактировал Panechka - Суббота, 05.01.2019, 21:10
 
Ответить
Сообщение
=ЕСЛИОШИБКА(ИНДЕКС(Active!A$1:A$30;ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(Active!$O$3:$O$30=1;Active!$B$3:$B$30*100+СТРОКА(Active!$B$3:$B$30)/10000);СТРОКА(B1));1)*10000;));"")


Столбец O не так важен, фактически он дублирует смысловую нагрузку столбца A. Небольшая помарка - теперь про добавлении на новую страничку строки меняются местами, можно как-то сохранить их порядок, как на первой странице?
Т.е. если сверху была сделка за 20 декабря, её нужно также оставить первой сверху. Исходные данные в эту табличку копируются извне и порядок очень важен.

Строк в таблице всего примерно 5000, после изменения $30 на $5000 всё перемешалось.

Автор - Panechka
Дата добавления - 05.01.2019 в 20:57
Nic70y Дата: Суббота, 05.01.2019, 21:08 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 5502
Репутация: 1197 ±
Замечаний: 0% ±

ru13;10;03
Столбец O не так важен
ну тогда держите, формула в O
Код
=ЕСЛИ(A3=O$1;ОКРУГЛ(B3*10000;0)+СТРОКА()/10000;"")
в P
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(O$3:O$30;СТРОКА(O1));"")
в таблице
Код
=ЕСЛИ(Active!$P3="";"";ИНДЕКС(Active!A:A;ПОИСКПОЗ(Active!$P3;Active!$O:$O;)))
все немассивные

апдэйт, переборщил - в файле 18 проще
К сообщению приложен файл: 4098750-1-.xlsx(20.5 Kb) · 18.xlsx(20.4 Kb)


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Суббота, 05.01.2019, 21:14
 
Ответить
Сообщение
Столбец O не так важен
ну тогда держите, формула в O
Код
=ЕСЛИ(A3=O$1;ОКРУГЛ(B3*10000;0)+СТРОКА()/10000;"")
в P
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(O$3:O$30;СТРОКА(O1));"")
в таблице
Код
=ЕСЛИ(Active!$P3="";"";ИНДЕКС(Active!A:A;ПОИСКПОЗ(Active!$P3;Active!$O:$O;)))
все немассивные

апдэйт, переборщил - в файле 18 проще

Автор - Nic70y
Дата добавления - 05.01.2019 в 21:08
Panechka Дата: Суббота, 05.01.2019, 21:25 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(O$3:O$30;СТРОКА(O1));"")


Опять эта же проблема. В примере всего 30 строчек, и значение он ищет только в 30 строчках, если мне надо поменять 30 строчек на 3000, я делаю это:
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(O$3:O$30;СТРОКА(O1));"")
- было
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(O$3:O$3000;СТРОКА(O1));"")
- стало

и выводит сначала 14 потом 13, где-то в середине 20 и в конце 10 число.


айдейт, 18 сейчас попробую. может, там не будет этой проблемы


Сообщение отредактировал Panechka - Суббота, 05.01.2019, 21:27
 
Ответить
Сообщение
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(O$3:O$30;СТРОКА(O1));"")


Опять эта же проблема. В примере всего 30 строчек, и значение он ищет только в 30 строчках, если мне надо поменять 30 строчек на 3000, я делаю это:
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(O$3:O$30;СТРОКА(O1));"")
- было
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(O$3:O$3000;СТРОКА(O1));"")
- стало

и выводит сначала 14 потом 13, где-то в середине 20 и в конце 10 число.


айдейт, 18 сейчас попробую. может, там не будет этой проблемы

Автор - Panechka
Дата добавления - 05.01.2019 в 21:25
Nic70y Дата: Суббота, 05.01.2019, 21:35 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 5502
Репутация: 1197 ±
Замечаний: 0% ±

ru13;10;03
ну так сортировка по % как у Вас в файле (по Вашей формуле)
да и по названию темы я так и понял.
Код
...НАИМЕНЬШИЙ(ЕСЛИ(Active!$O$3:$O$30=1;Active!$B$3:$B$30)...
а формулы нужно тЭгами оформлять, там флажок британский или российский (это же красивее)

апдэйт - если сортировка не нужна, тогда еще проще:
O
Код
=ЕСЛИ(A3=O$1;O2+1;O2)
таблица
Код
=ЕСЛИОШИБКА(ИНДЕКС(Active!A:A;ПОИСКПОЗ(СТРОКА(A1);Active!$O:$O;));"")
К сообщению приложен файл: options-2-1-.xlsx(19.3 Kb)


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Суббота, 05.01.2019, 21:40
 
Ответить
Сообщениену так сортировка по % как у Вас в файле (по Вашей формуле)
да и по названию темы я так и понял.
Код
...НАИМЕНЬШИЙ(ЕСЛИ(Active!$O$3:$O$30=1;Active!$B$3:$B$30)...
а формулы нужно тЭгами оформлять, там флажок британский или российский (это же красивее)

апдэйт - если сортировка не нужна, тогда еще проще:
O
Код
=ЕСЛИ(A3=O$1;O2+1;O2)
таблица
Код
=ЕСЛИОШИБКА(ИНДЕКС(Active!A:A;ПОИСКПОЗ(СТРОКА(A1);Active!$O:$O;));"")

Автор - Nic70y
Дата добавления - 05.01.2019 в 21:35
Panechka Дата: Суббота, 05.01.2019, 21:40 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Проблема сохранилась, при
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(НАИМЕНЬШИЙ(O$3:O$30;СТРОКА(O1));O:O;);"")

всё работает нормально
, при
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(НАИМЕНЬШИЙ(O$3:O$3000;СТРОКА(O1));O:O;);"")

становится всё вперемешку.
 
Ответить
СообщениеПроблема сохранилась, при
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(НАИМЕНЬШИЙ(O$3:O$30;СТРОКА(O1));O:O;);"")

всё работает нормально
, при
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(НАИМЕНЬШИЙ(O$3:O$3000;СТРОКА(O1));O:O;);"")

становится всё вперемешку.

Автор - Panechka
Дата добавления - 05.01.2019 в 21:40
Nic70y Дата: Суббота, 05.01.2019, 21:42 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 5502
Репутация: 1197 ±
Замечаний: 0% ±

ru13;10;03
см. файл, добавил в сообщении выше


ЯД(poison) 41001841029809
 
Ответить
Сообщениесм. файл, добавил в сообщении выше

Автор - Nic70y
Дата добавления - 05.01.2019 в 21:42
Panechka Дата: Суббота, 05.01.2019, 21:52 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
см. файл, добавил в сообщении выше


Идеально, всё работает. Вам спасибо. На poison отправила копеечку.
 
Ответить
Сообщение
см. файл, добавил в сообщении выше


Идеально, всё работает. Вам спасибо. На poison отправила копеечку.

Автор - Panechka
Дата добавления - 05.01.2019 в 21:52
Nic70y Дата: Суббота, 05.01.2019, 21:59 | Сообщение № 10
Группа: Друзья
Ранг: Экселист
Сообщений: 5502
Репутация: 1197 ±
Замечаний: 0% ±

ru13;10;03
poison
спасибо.
немного сбили меня столку некоторые обстоятельства.
перечитал:
строки на разные страницы
думаю правильнее будет так (в файле)
обратите внимания на разукрашенные ячейки - разный цвет - разные формулы.
К сообщению приложен файл: 19.xlsx(18.4 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
poison
спасибо.
немного сбили меня столку некоторые обстоятельства.
перечитал:
строки на разные страницы
думаю правильнее будет так (в файле)
обратите внимания на разукрашенные ячейки - разный цвет - разные формулы.

Автор - Nic70y
Дата добавления - 05.01.2019 в 21:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отсортировать строки на разные страницы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!