Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Посчитать ночные часы в ячейках вида Н/Я - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать ночные часы в ячейках вида Н/Я (Формулы/Formulas)
Посчитать ночные часы в ячейках вида Н/Я
ruslantigr Дата: Пятница, 18.01.2019, 08:47 | Сообщение № 1
Группа: Заблокированные
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Помогите пожалуйста. Как вот вывести отдельно ночь и явку чтоб в я чейке автоматически вытягивала именно ночные часы чтоб в столбике НОЧНЫЕ получилось 4
Я/Н Н/Я
5/2 2/3
К сообщению приложен файл: 6741289.xls(49.5 Kb)


Сообщение отредактировал ruslantigr - Пятница, 18.01.2019, 09:10
 
Ответить
СообщениеПомогите пожалуйста. Как вот вывести отдельно ночь и явку чтоб в я чейке автоматически вытягивала именно ночные часы чтоб в столбике НОЧНЫЕ получилось 4
Я/Н Н/Я
5/2 2/3

Автор - ruslantigr
Дата добавления - 18.01.2019 в 08:47
китин Дата: Пятница, 18.01.2019, 08:52 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5530
Репутация: 881 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ruslantigr, поменяйте название темы в соответствии с п2 Правил форума
в режиме редактирования поста исправьте название темы на более конкретное. к примеру : Посчитать ночные часы в ячейках вида Н/Я.
как то так. и напишите конкретно в каких ячейках надо считать и что конкретно вы хотите видеть в результате
[moder]исправлено[/moder]


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Пятница, 18.01.2019, 09:09
 
Ответить
Сообщениеruslantigr, поменяйте название темы в соответствии с п2 Правил форума
в режиме редактирования поста исправьте название темы на более конкретное. к примеру : Посчитать ночные часы в ячейках вида Н/Я.
как то так. и напишите конкретно в каких ячейках надо считать и что конкретно вы хотите видеть в результате
[moder]исправлено[/moder]

Автор - китин
Дата добавления - 18.01.2019 в 08:52
китин Дата: Пятница, 18.01.2019, 09:10 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 5530
Репутация: 881 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
напишите конкретно в каких ячейках надо считать и что конкретно вы хотите видеть в результате


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
напишите конкретно в каких ячейках надо считать и что конкретно вы хотите видеть в результате

Автор - китин
Дата добавления - 18.01.2019 в 09:10
ruslantigr Дата: Пятница, 18.01.2019, 09:14 | Сообщение № 4
Группа: Заблокированные
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Пытаюсь чтоб в табеле уччета рабочего времени в столбике Ночные формировались именно количество часов ночных
 
Ответить
СообщениеПытаюсь чтоб в табеле уччета рабочего времени в столбике Ночные формировались именно количество часов ночных

Автор - ruslantigr
Дата добавления - 18.01.2019 в 09:14
китин Дата: Пятница, 18.01.2019, 09:19 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 5530
Репутация: 881 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
я не вижу у вас в файле столбик Ночные
[p.s.] и не надо нажимать кнопку
Цитата
сообщить
. это кнопка для жалоб модератору на участника форума. вы мне на меня жалуетесь? :D


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениея не вижу у вас в файле столбик Ночные
[p.s.] и не надо нажимать кнопку
Цитата
сообщить
. это кнопка для жалоб модератору на участника форума. вы мне на меня жалуетесь? :D

Автор - китин
Дата добавления - 18.01.2019 в 09:19
ruslantigr Дата: Пятница, 18.01.2019, 09:21 | Сообщение № 6
Группа: Заблокированные
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Простите пожалуйста. Я немного не понял. Исправлюсь.
 
Ответить
СообщениеПростите пожалуйста. Я немного не понял. Исправлюсь.

Автор - ruslantigr
Дата добавления - 18.01.2019 в 09:21
китин Дата: Пятница, 18.01.2019, 09:41 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 5530
Репутация: 881 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Формула массива. вводится одновременным нажатием трех клавиш Ctrl+Shift+Enter
Код
=СУММ(ЕСЛИ(ЕСЛИОШИБКА(ПОИСК("н";$E1:$AI1);0)=1;ЕСЛИОШИБКА(--ЛЕВБ($E2:$AI2;1);0)))+СУММ(ЕСЛИ(ЕСЛИОШИБКА(ПОИСК("н";$E1:$AI1);0)=3;ЕСЛИОШИБКА(--ПСТР($E2:$AI2;ПОИСК("/";$E2:$AI2)+1;ДЛСТР($E2:$AI2));0)))

это для столбца AS. Снасала снимите объединение ячеек с ячейке AS1, вставьте формулу нажмите Ctrl+Shift+Enter потом снова объедените ячейки и протяните на нужный диапазон
К сообщению приложен файл: ruslantigr.xlsx(13.3 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеФормула массива. вводится одновременным нажатием трех клавиш Ctrl+Shift+Enter
Код
=СУММ(ЕСЛИ(ЕСЛИОШИБКА(ПОИСК("н";$E1:$AI1);0)=1;ЕСЛИОШИБКА(--ЛЕВБ($E2:$AI2;1);0)))+СУММ(ЕСЛИ(ЕСЛИОШИБКА(ПОИСК("н";$E1:$AI1);0)=3;ЕСЛИОШИБКА(--ПСТР($E2:$AI2;ПОИСК("/";$E2:$AI2)+1;ДЛСТР($E2:$AI2));0)))

это для столбца AS. Снасала снимите объединение ячеек с ячейке AS1, вставьте формулу нажмите Ctrl+Shift+Enter потом снова объедените ячейки и протяните на нужный диапазон

Автор - китин
Дата добавления - 18.01.2019 в 09:41
_Boroda_ Дата: Пятница, 18.01.2019, 09:48 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15009
Репутация: 5926 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР(E2:AI2;ПОИСК("н";E1:AI1);1);))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР(E2:AI2;ПОИСК("н";E1:AI1);1);))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - _Boroda_
Дата добавления - 18.01.2019 в 09:48
китин Дата: Пятница, 18.01.2019, 09:56 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 5530
Репутация: 881 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
[offtop]
Так нужно?

нет . больно уж коротко написал. лаконичный ты наш hands hands hands


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение[offtop]
Так нужно?

нет . больно уж коротко написал. лаконичный ты наш hands hands hands

Автор - китин
Дата добавления - 18.01.2019 в 09:56
ruslantigr Дата: Пятница, 18.01.2019, 10:08 | Сообщение № 10
Группа: Заблокированные
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
СПАСИБО ОГРОМНОЕ ТОВАРИЩИ! Я вам очень благодарен. Дай вам Бог здоровья!
 
Ответить
СообщениеСПАСИБО ОГРОМНОЕ ТОВАРИЩИ! Я вам очень благодарен. Дай вам Бог здоровья!

Автор - ruslantigr
Дата добавления - 18.01.2019 в 10:08
_Boroda_ Дата: Пятница, 18.01.2019, 10:08 | Сообщение № 11
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15009
Репутация: 5926 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
нет . больно уж коротко написал

Коротко, зато понятно. А как тебе вот так если? :D
Код
=СУММ(--ТЕКСТ(E2:AI2;"[<99]\0;"&СИМВОЛ(204-8*(ПРАВБ(E1:AI1)<>"н"))))

Код
=СУММ(--ТЕКСТ(E2:AI2-1461;СИМВОЛ(204-8*(ПРАВБ(E1:AI1)<>"н"))&";\0"))


Вторая мне больше нравится :D


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
нет . больно уж коротко написал

Коротко, зато понятно. А как тебе вот так если? :D
Код
=СУММ(--ТЕКСТ(E2:AI2;"[<99]\0;"&СИМВОЛ(204-8*(ПРАВБ(E1:AI1)<>"н"))))

Код
=СУММ(--ТЕКСТ(E2:AI2-1461;СИМВОЛ(204-8*(ПРАВБ(E1:AI1)<>"н"))&";\0"))


Вторая мне больше нравится :D

Автор - _Boroda_
Дата добавления - 18.01.2019 в 10:08
Nic70y Дата: Пятница, 18.01.2019, 10:28 | Сообщение № 12
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5274
Репутация: 1144 ±
Замечаний: 0% ±

Excel 2013
а вдруг, внезапно %)
Код
=СУММ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(ПСТР(E2:AI2;ЕСЛИ(ПОИСК("н";E1:AI1)=1;1;ПОИСК("/";E2:AI2)+1);2);"/";);))
К сообщению приложен файл: 1485827.xls(50.0 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениеа вдруг, внезапно %)
Код
=СУММ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(ПСТР(E2:AI2;ЕСЛИ(ПОИСК("н";E1:AI1)=1;1;ПОИСК("/";E2:AI2)+1);2);"/";);))

Автор - Nic70y
Дата добавления - 18.01.2019 в 10:28
_Boroda_ Дата: Пятница, 18.01.2019, 10:50 | Сообщение № 13
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15009
Репутация: 5926 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
а вдруг, внезапно

Внезапно что?
ТК РФ Статья 96
Цитата
Ночное время - время с 22 часов до 6 часов
- максимум 8 часов


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
а вдруг, внезапно

Внезапно что?
ТК РФ Статья 96
Цитата
Ночное время - время с 22 часов до 6 часов
- максимум 8 часов

Автор - _Boroda_
Дата добавления - 18.01.2019 в 10:50
Nic70y Дата: Пятница, 18.01.2019, 10:53 | Сообщение № 14
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5274
Репутация: 1144 ±
Замечаний: 0% ±

Excel 2013
ТК РФ Статья 96
точно, не подумал

апдэйт, все равно спротивничаю :) я/н = 10/1


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Пятница, 18.01.2019, 11:29
 
Ответить
Сообщение
ТК РФ Статья 96
точно, не подумал

апдэйт, все равно спротивничаю :) я/н = 10/1

Автор - Nic70y
Дата добавления - 18.01.2019 в 10:53
ruslantigr Дата: Пятница, 18.01.2019, 12:54 | Сообщение № 15
Группа: Заблокированные
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
помогите пожалуйста, у меня ошибку выдает.
К сообщению приложен файл: 2051467.xls(44.0 Kb)
 
Ответить
Сообщениепомогите пожалуйста, у меня ошибку выдает.

Автор - ruslantigr
Дата добавления - 18.01.2019 в 12:54
китин Дата: Пятница, 18.01.2019, 13:05 | Сообщение № 16
Группа: Модераторы
Ранг: Экселист
Сообщений: 5530
Репутация: 881 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
у меня ошибку выдает.

я же вам писал:
Снасала снимите объединение ячеек с ячейке AS1, вставьте формулу нажмите Ctrl+Shift+Enter потом снова объедените ячейки и протяните на нужный диапазон

ловите
К сообщению приложен файл: _2051467.xlsx(21.0 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
у меня ошибку выдает.

я же вам писал:
Снасала снимите объединение ячеек с ячейке AS1, вставьте формулу нажмите Ctrl+Shift+Enter потом снова объедените ячейки и протяните на нужный диапазон

ловите

Автор - китин
Дата добавления - 18.01.2019 в 13:05
ruslantigr Дата: Пятница, 18.01.2019, 13:13 | Сообщение № 17
Группа: Заблокированные
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
СПАСИБО ОГРОМНОЕ!!!!
 
Ответить
СообщениеСПАСИБО ОГРОМНОЕ!!!!

Автор - ruslantigr
Дата добавления - 18.01.2019 в 13:13
ruslantigr Дата: Вторник, 22.01.2019, 09:47 | Сообщение № 18
Группа: Заблокированные
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Помогите пожалуйста посчитать ОБЩЕЕ количество часов за первую половину. проблема в том что есть Я и Я/н. Заранее спасибо.
К сообщению приложен файл: 1468254.xlsx(19.8 Kb)


Сообщение отредактировал ruslantigr - Вторник, 22.01.2019, 09:50
 
Ответить
СообщениеПомогите пожалуйста посчитать ОБЩЕЕ количество часов за первую половину. проблема в том что есть Я и Я/н. Заранее спасибо.

Автор - ruslantigr
Дата добавления - 22.01.2019 в 09:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать ночные часы в ячейках вида Н/Я (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!