Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для переноса данных из одной таблицы в другую - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для переноса данных из одной таблицы в другую (Формулы/Formulas)
Формула для переноса данных из одной таблицы в другую
OYakshe Дата: Четверг, 24.01.2019, 15:16 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день! Есть список метеостанций с номерами, названиями и координатами каждой соответственно. Через некоторое время скачала список лишь некоторых метеостанций, но без координат. Как данные координат взять из первого списка и присвоить их второму?
Заранее спасибо!
К сообщению приложен файл: _1.xlsx(80.8 Kb)


Сообщение отредактировал OYakshe - Четверг, 24.01.2019, 15:19
 
Ответить
СообщениеДобрый день! Есть список метеостанций с номерами, названиями и координатами каждой соответственно. Через некоторое время скачала список лишь некоторых метеостанций, но без координат. Как данные координат взять из первого списка и присвоить их второму?
Заранее спасибо!

Автор - OYakshe
Дата добавления - 24.01.2019 в 15:16
_Boroda_ Дата: Четверг, 24.01.2019, 15:25 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14125
Репутация: 5696 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ВПР(J2;A$2:E$1125;3;)
лучше так
Код
=ВПР($J2;A$2:E$1125;СТОЛБЕЦ(C2);)

Еще вариант
Код
=ПРОСМОТР($J2;$A$2:$A$1125;E$2:E$1124)
К сообщению приложен файл: _1-15-1.xlsx(80.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ВПР(J2;A$2:E$1125;3;)
лучше так
Код
=ВПР($J2;A$2:E$1125;СТОЛБЕЦ(C2);)

Еще вариант
Код
=ПРОСМОТР($J2;$A$2:$A$1125;E$2:E$1124)

Автор - _Boroda_
Дата добавления - 24.01.2019 в 15:25
OYakshe Дата: Четверг, 24.01.2019, 15:33 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Похоже что да... Но я смогла заполнить столбец с широтой, а как заполнить долготу? Не соображу.
К сообщению приложен файл: _2.xlsx(81.0 Kb)
 
Ответить
СообщениеПохоже что да... Но я смогла заполнить столбец с широтой, а как заполнить долготу? Не соображу.

Автор - OYakshe
Дата добавления - 24.01.2019 в 15:33
OYakshe Дата: Четверг, 24.01.2019, 15:34 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
пока писала ответ другие варианты появились. Сейчас посмотрю)))))))
 
Ответить
Сообщениепока писала ответ другие варианты появились. Сейчас посмотрю)))))))

Автор - OYakshe
Дата добавления - 24.01.2019 в 15:34
_Boroda_ Дата: Четверг, 24.01.2019, 15:36 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14125
Репутация: 5696 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Справку по ВПР не читали? Зря. В исходной таблице долгота в каком столце находится? В пятом. А Вы просите показать третий. И ищете не станцию, а данные из столбца L
Вот так нужно
Код
=ВПР(J2;A$2:G$1125;5;)

А лучше было использовать те формулы, которые я в своем предыдущем посте ниже написал
Код
=ВПР($J2;$A$2:$F$1125;СТОЛБЕЦ(C2);)

Код
=ПРОСМОТР($J5;$A$2:$A$1125;C$2:C$1124)
К сообщению приложен файл: _2-13-1.xlsx(81.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСправку по ВПР не читали? Зря. В исходной таблице долгота в каком столце находится? В пятом. А Вы просите показать третий. И ищете не станцию, а данные из столбца L
Вот так нужно
Код
=ВПР(J2;A$2:G$1125;5;)

А лучше было использовать те формулы, которые я в своем предыдущем посте ниже написал
Код
=ВПР($J2;$A$2:$F$1125;СТОЛБЕЦ(C2);)

Код
=ПРОСМОТР($J5;$A$2:$A$1125;C$2:C$1124)

Автор - _Boroda_
Дата добавления - 24.01.2019 в 15:36
OYakshe Дата: Четверг, 24.01.2019, 15:51 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Второй вариант вроде бы работает, но почему-то в некоторых ячейках пишет - нет данных. Я скопировала вашу формулу, вставила и автоматом протянула. Что не так сделала?
К сообщению приложен файл: _3.xlsx(84.6 Kb)
 
Ответить
СообщениеВторой вариант вроде бы работает, но почему-то в некоторых ячейках пишет - нет данных. Я скопировала вашу формулу, вставила и автоматом протянула. Что не так сделала?

Автор - OYakshe
Дата добавления - 24.01.2019 в 15:51
_Boroda_ Дата: Четверг, 24.01.2019, 15:56 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14125
Репутация: 5696 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Откуда скопировали? Откройте мой файл и скопируйте оттуда
У Вас нет доллара перед J, A, E
Почитайте про абсолютные и относительные ссылки


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеОткуда скопировали? Откройте мой файл и скопируйте оттуда
У Вас нет доллара перед J, A, E
Почитайте про абсолютные и относительные ссылки

Автор - _Boroda_
Дата добавления - 24.01.2019 в 15:56
OYakshe Дата: Четверг, 24.01.2019, 15:59 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Простите, поторопилась и сразу не заметила ваш файл. Моя благодарность не имеет границ. Спасибо вам большое.
 
Ответить
СообщениеПростите, поторопилась и сразу не заметила ваш файл. Моя благодарность не имеет границ. Спасибо вам большое.

Автор - OYakshe
Дата добавления - 24.01.2019 в 15:59
OYakshe Дата: Четверг, 24.01.2019, 16:38 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Есть еще архиважная задача для меня, похожая на первую. В результате расчетов составлена сводная таблица данных. В шапке есть номера метеостанций. По каждой был расчет потери урожая за период 2011-2017 гг. В итоге требуется вычислить среднее значение потерь урожая за эти годы. Далее сделать табличку с номером метеостанции и среднем значением потери урожая. Кучу временя потратила на решение этой простой на первый взгляд проблемы. Помогите пожалуйста, из-за этого топчусь на одном месте.
К сообщению приложен файл: 9801729.xlsx(66.4 Kb)
 
Ответить
СообщениеЕсть еще архиважная задача для меня, похожая на первую. В результате расчетов составлена сводная таблица данных. В шапке есть номера метеостанций. По каждой был расчет потери урожая за период 2011-2017 гг. В итоге требуется вычислить среднее значение потерь урожая за эти годы. Далее сделать табличку с номером метеостанции и среднем значением потери урожая. Кучу временя потратила на решение этой простой на первый взгляд проблемы. Помогите пожалуйста, из-за этого топчусь на одном месте.

Автор - OYakshe
Дата добавления - 24.01.2019 в 16:38
_Boroda_ Дата: Четверг, 24.01.2019, 16:42 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14125
Репутация: 5696 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
- Прочитайте Правила форума
- п.4 Правил форума: один вопрос - одна тема


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение- Прочитайте Правила форума
- п.4 Правил форума: один вопрос - одна тема

Автор - _Boroda_
Дата добавления - 24.01.2019 в 16:42
OYakshe Дата: Четверг, 24.01.2019, 16:51 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо за замечание, прошу прощения. Исправлюсь.
 
Ответить
СообщениеСпасибо за замечание, прошу прощения. Исправлюсь.

Автор - OYakshe
Дата добавления - 24.01.2019 в 16:51
denis-tab Дата: Пятница, 25.01.2019, 09:34 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Задача: структурировать исходные данные в таблицу. Есть 4 условия в столбцах исходных данных, необходимо в определенную ячейку поместить число из крайнего правого сотлбца, которое по строке совпадает с четырьмя условиями.

=ИНДЕКС(Лист1!B2:H2000;ПОИСКПОЗ(M3;Лист1!B2:B2000;0);ПОИСКПОЗ(M1;Лист1!E2:E2000;0);ПОИСКПОЗ(M2;Лист1!F2:F2000;0);ПОИСКПОЗ(b4;Лист1!b2:b2000;0)) -> до чего я додумался, но это не работает( нужно что то подобное. Думаю ВПР, но не справляюсь((

Во вложении: Лист1 - исходные данные (необходимые критерии выделены цветом, в столбце Н - искомое число); Лист2 - Таблица, в которую необходимо поместить искомые числа в структурированном порядке
К сообщению приложен файл: 3945683.xlsx(66.7 Kb)
 
Ответить
СообщениеЗадача: структурировать исходные данные в таблицу. Есть 4 условия в столбцах исходных данных, необходимо в определенную ячейку поместить число из крайнего правого сотлбца, которое по строке совпадает с четырьмя условиями.

=ИНДЕКС(Лист1!B2:H2000;ПОИСКПОЗ(M3;Лист1!B2:B2000;0);ПОИСКПОЗ(M1;Лист1!E2:E2000;0);ПОИСКПОЗ(M2;Лист1!F2:F2000;0);ПОИСКПОЗ(b4;Лист1!b2:b2000;0)) -> до чего я додумался, но это не работает( нужно что то подобное. Думаю ВПР, но не справляюсь((

Во вложении: Лист1 - исходные данные (необходимые критерии выделены цветом, в столбце Н - искомое число); Лист2 - Таблица, в которую необходимо поместить искомые числа в структурированном порядке

Автор - denis-tab
Дата добавления - 25.01.2019 в 09:34
_Boroda_ Дата: Пятница, 25.01.2019, 09:46 | Сообщение № 13
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14125
Репутация: 5696 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
denis-tab,
- Прочитайте Правила форума
- Создайте свою тему согласно п.5q Правил форума
- В ней оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

И да, Вам не кажется, что начать свой пост со слов "Задача:" - не очень хорошая идея?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениеdenis-tab,
- Прочитайте Правила форума
- Создайте свою тему согласно п.5q Правил форума
- В ней оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

И да, Вам не кажется, что начать свой пост со слов "Задача:" - не очень хорошая идея?

Автор - _Boroda_
Дата добавления - 25.01.2019 в 09:46
denis-tab Дата: Пятница, 25.01.2019, 10:52 | Сообщение № 14
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, спасибо, извиняюсь, я впервой)

исправился. тему создал. не судите строго. если что, я поправлю. очень хочу найти у вас поддержки
 
Ответить
Сообщение_Boroda_, спасибо, извиняюсь, я впервой)

исправился. тему создал. не судите строго. если что, я поправлю. очень хочу найти у вас поддержки

Автор - denis-tab
Дата добавления - 25.01.2019 в 10:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для переноса данных из одной таблицы в другую (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!