Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как подтянуть разные данные к повторяющимся значениям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как подтянуть разные данные к повторяющимся значениям (Формулы/Formulas)
Как подтянуть разные данные к повторяющимся значениям
exe Дата: Пятница, 25.01.2019, 20:56 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте!
Помогите пож. с формулой
Необходимо подтянуть данные с Листа1, «В» на Лист2, «В»
При условии, что искомое значение в столбце «А» повторяется
К сообщению приложен файл: _____.xls(31.5 Kb)
 
Ответить
СообщениеЗдравствуйте!
Помогите пож. с формулой
Необходимо подтянуть данные с Листа1, «В» на Лист2, «В»
При условии, что искомое значение в столбце «А» повторяется

Автор - exe
Дата добавления - 25.01.2019 в 20:56
dude Дата: Пятница, 25.01.2019, 21:34 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 149
Репутация: 22 ±
Замечаний: 0% ±

2016
Код
=ИНДЕКС(ЛИСТ1!B:B;АГРЕГАТ(15;6;СТРОКА(ЛИСТ1!$A$2:$A$26)/(ЛИСТ1!$A$2:$A$26=$A2);СЧЁТЕСЛИ($A$2:$A2;$A2)))


Сообщение отредактировал dude - Пятница, 25.01.2019, 21:34
 
Ответить
Сообщение
Код
=ИНДЕКС(ЛИСТ1!B:B;АГРЕГАТ(15;6;СТРОКА(ЛИСТ1!$A$2:$A$26)/(ЛИСТ1!$A$2:$A$26=$A2);СЧЁТЕСЛИ($A$2:$A2;$A2)))

Автор - dude
Дата добавления - 25.01.2019 в 21:34
Nic70y Дата: Пятница, 25.01.2019, 21:34 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 5346
Репутация: 1158 ±
Замечаний: 0% ±

ru13;10;03
массивная
Код
=ИНДЕКС(ЛИСТ1!$B$1:$B$26;НАИМЕНЬШИЙ(ЕСЛИ(A2=ЛИСТ1!$A$2:A26;СТРОКА(ЛИСТ1!$A$2:A26));СЧЁТЕСЛИ(A$1:A2;A2)))
К сообщению приложен файл: 8472551.xls(35.5 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениемассивная
Код
=ИНДЕКС(ЛИСТ1!$B$1:$B$26;НАИМЕНЬШИЙ(ЕСЛИ(A2=ЛИСТ1!$A$2:A26;СТРОКА(ЛИСТ1!$A$2:A26));СЧЁТЕСЛИ(A$1:A2;A2)))

Автор - Nic70y
Дата добавления - 25.01.2019 в 21:34
gling Дата: Пятница, 25.01.2019, 21:47 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1939
Репутация: 481 ±
Замечаний: 0% ±

2010
Еще вариант
Код
=ИНДЕКС(ЛИСТ1!B:B;СУММПРОИЗВ(НАИБОЛЬШИЙ((ЛИСТ1!$A$1:$A$26=ЛИСТ2!A2)*СТРОКА(ЛИСТ2!$A$1:$A$26);СЧЁТЕСЛИ(ЛИСТ1!$A$2:$A$26;ЛИСТ2!A2)-СЧЁТЕСЛИ(ЛИСТ2!$A$1:A1;ЛИСТ2!A2))))


ЯД-41001506838083
 
Ответить
СообщениеЕще вариант
Код
=ИНДЕКС(ЛИСТ1!B:B;СУММПРОИЗВ(НАИБОЛЬШИЙ((ЛИСТ1!$A$1:$A$26=ЛИСТ2!A2)*СТРОКА(ЛИСТ2!$A$1:$A$26);СЧЁТЕСЛИ(ЛИСТ1!$A$2:$A$26;ЛИСТ2!A2)-СЧЁТЕСЛИ(ЛИСТ2!$A$1:A1;ЛИСТ2!A2))))

Автор - gling
Дата добавления - 25.01.2019 в 21:47
exe Дата: Пятница, 25.01.2019, 22:00 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Супер!
Спасибо Господа!!!
Оба варианта подходят! Уже внедрил!!!
 
Ответить
СообщениеСупер!
Спасибо Господа!!!
Оба варианта подходят! Уже внедрил!!!

Автор - exe
Дата добавления - 25.01.2019 в 22:00
exe Дата: Пятница, 25.01.2019, 22:08 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Ок. Спасибо, Ув.
И третий забрал.
 
Ответить
СообщениеОк. Спасибо, Ув.
И третий забрал.

Автор - exe
Дата добавления - 25.01.2019 в 22:08
vikttur Дата: Пятница, 25.01.2019, 22:41 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Есть еще четвертый (уверен - не последний), облегченный.
Допстолбец:
Код
=СЧЁТЕСЛИ(ЛИСТ1!$B$2:B2;B2)&B2

Результат:
Код
=ВПР(СЧЁТЕСЛИ($A$2:A2;A2)&A2;ЛИСТ1!$A$2:$C$26;3;)
К сообщению приложен файл: 0870604.xls(37.5 Kb)
 
Ответить
СообщениеЕсть еще четвертый (уверен - не последний), облегченный.
Допстолбец:
Код
=СЧЁТЕСЛИ(ЛИСТ1!$B$2:B2;B2)&B2

Результат:
Код
=ВПР(СЧЁТЕСЛИ($A$2:A2;A2)&A2;ЛИСТ1!$A$2:$C$26;3;)

Автор - vikttur
Дата добавления - 25.01.2019 в 22:41
exe Дата: Пятница, 25.01.2019, 23:47 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо Ув.
И этот вариант нашел себя, табличек много!!!
 
Ответить
СообщениеСпасибо Ув.
И этот вариант нашел себя, табличек много!!!

Автор - exe
Дата добавления - 25.01.2019 в 23:47
exe Дата: Суббота, 26.01.2019, 13:56 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Опять Здравствуйте!
В продолжение темы хотел бы попросить помочь дописать к формуле сортировку, если это возможно, в порядке на примере Лист2.
К сообщению приложен файл: _______.xls(32.5 Kb)
 
Ответить
СообщениеОпять Здравствуйте!
В продолжение темы хотел бы попросить помочь дописать к формуле сортировку, если это возможно, в порядке на примере Лист2.

Автор - exe
Дата добавления - 26.01.2019 в 13:56
Nic70y Дата: Суббота, 26.01.2019, 16:58 | Сообщение № 10
Группа: Друзья
Ранг: Экселист
Сообщений: 5346
Репутация: 1158 ±
Замечаний: 0% ±

ru13;10;03
строго по данным файла, с доп.столбцами.
К сообщению приложен файл: 42-56-3.xlsx(13.2 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениестрого по данным файла, с доп.столбцами.

Автор - Nic70y
Дата добавления - 26.01.2019 в 16:58
exe Дата: Суббота, 26.01.2019, 20:16 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо! Чётко стало, как раз то, что нужно!
 
Ответить
СообщениеСпасибо! Чётко стало, как раз то, что нужно!

Автор - exe
Дата добавления - 26.01.2019 в 20:16
krosav4ig Дата: Воскресенье, 27.01.2019, 23:09 | Сообщение № 12
Группа: Друзья
Ранг: Старожил
Сообщений: 2089
Репутация: 873 ±
Замечаний: 0% ±

Excel 2007,2010,2013
сделал вариант в Power Query, дабы освежить знания в памяти
На Листе2 ПКМ по ячейке таблицы -> Обновить
К сообщению приложен файл: PQ.xls(74.0 Kb)


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
Сообщениесделал вариант в Power Query, дабы освежить знания в памяти
На Листе2 ПКМ по ячейке таблицы -> Обновить

Автор - krosav4ig
Дата добавления - 27.01.2019 в 23:09
exe Дата: Понедельник, 28.01.2019, 18:00 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо! Тоже пригодится!
 
Ответить
СообщениеСпасибо! Тоже пригодится!

Автор - exe
Дата добавления - 28.01.2019 в 18:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как подтянуть разные данные к повторяющимся значениям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!