Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Разбивка ячейки с привязанными данными. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разбивка ячейки с привязанными данными. (Формулы/Formulas)
Разбивка ячейки с привязанными данными.
bindu Дата: Четверг, 31.01.2019, 21:48 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый вечер.
Буду признателен за помощь, или указание в какую сторону копать.

Есть три или больше колонок.
В одной из них ячейка где и идут данные через запятую или любой другой разделитеть.
Нужно эту ячейку разнести в ячейки ниже в этой же колонке, с учетом привязки данных которые были в исходной строке.
Надеюсь правильно изъяснился.

Прикрепляю пример
К сообщению приложен файл: 3793275.xlsx(9.4 Kb)


Сообщение отредактировал bindu - Четверг, 31.01.2019, 21:49
 
Ответить
СообщениеДобрый вечер.
Буду признателен за помощь, или указание в какую сторону копать.

Есть три или больше колонок.
В одной из них ячейка где и идут данные через запятую или любой другой разделитеть.
Нужно эту ячейку разнести в ячейки ниже в этой же колонке, с учетом привязки данных которые были в исходной строке.
Надеюсь правильно изъяснился.

Прикрепляю пример

Автор - bindu
Дата добавления - 31.01.2019 в 21:48
krosav4ig Дата: Пятница, 01.02.2019, 08:21 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2032
Репутация: 847 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Здравствуйте. Вариант с доп. столбцом
К сообщению приложен файл: 4498913.xlsx(15.2 Kb)


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
СообщениеЗдравствуйте. Вариант с доп. столбцом

Автор - krosav4ig
Дата добавления - 01.02.2019 в 08:21
bindu Дата: Пятница, 01.02.2019, 08:54 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
krosav4ig, Спасибо. работает.
Сейчас буду вникать в суть и разбирать формулу!
Еще раз огромное спасибо!
 
Ответить
Сообщениеkrosav4ig, Спасибо. работает.
Сейчас буду вникать в суть и разбирать формулу!
Еще раз огромное спасибо!

Автор - bindu
Дата добавления - 01.02.2019 в 08:54
Светлый Дата: Пятница, 01.02.2019, 10:18 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1009
Репутация: 259 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Для товара массивная формула:
Код
=ЕСЛИОШИБКА(ИНДЕКС(ИНДЕКС(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(C$8:C$12;", ";ПОВТОР(" ";99));СТОЛБЕЦ(A:I)*99-98;99));Ч(ИНДЕКС(СТРОКА($9:$53)/9;));Ч(ИНДЕКС(ОСТАТ(СТРОКА($9:$53);9)+1;)));НАИМЕНЬШИЙ(ЕСЛИ(ИНДЕКС(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(C$8:C$12;", ";ПОВТОР(" ";99));СТОЛБЕЦ(A:I)*99-98;99));Ч(ИНДЕКС(СТРОКА($9:$53)/9;));Ч(ИНДЕКС(ОСТАТ(СТРОКА($9:$53);9)+1;)))<>"";СТРОКА($1:$45));СТРОКА(G1)));"")
Для номера и типа:
Код
=ЕСЛИ($G8="";"";ПРОСМОТР(999;ПОИСК($G8;$C$8:$C$12);A$8:A$12))
К сообщению приложен файл: 3793275-1.xlsx(10.5 Kb)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДобрый день!
Для товара массивная формула:
Код
=ЕСЛИОШИБКА(ИНДЕКС(ИНДЕКС(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(C$8:C$12;", ";ПОВТОР(" ";99));СТОЛБЕЦ(A:I)*99-98;99));Ч(ИНДЕКС(СТРОКА($9:$53)/9;));Ч(ИНДЕКС(ОСТАТ(СТРОКА($9:$53);9)+1;)));НАИМЕНЬШИЙ(ЕСЛИ(ИНДЕКС(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(C$8:C$12;", ";ПОВТОР(" ";99));СТОЛБЕЦ(A:I)*99-98;99));Ч(ИНДЕКС(СТРОКА($9:$53)/9;));Ч(ИНДЕКС(ОСТАТ(СТРОКА($9:$53);9)+1;)))<>"";СТРОКА($1:$45));СТРОКА(G1)));"")
Для номера и типа:
Код
=ЕСЛИ($G8="";"";ПРОСМОТР(999;ПОИСК($G8;$C$8:$C$12);A$8:A$12))

Автор - Светлый
Дата добавления - 01.02.2019 в 10:18
Светлый Дата: Пятница, 01.02.2019, 11:24 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1009
Репутация: 259 ±
Замечаний: 0% ±

Excel 2010
Вариант с доп. столбцом
А если использовать для номера и товара формулы:
Код
=ПРОСМОТР(СТРОКА(H1);МУМНОЖ(Ч(СТРОКА($1:$6)>=СТОЛБЕЦ(A:F));ДЛСТР(C$7:C$12)-ДЛСТР(ПОДСТАВИТЬ(C$7:C$12;",";))+1);A$8:A$9)
Код
=СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(ВПР(E8;A$8:C$10;3);", ";ПОВТОР(" ";99));СЧЁТЕСЛИ(E$7:E7;E8)*99+1;99))
можно без дополнительного столбца.


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
Вариант с доп. столбцом
А если использовать для номера и товара формулы:
Код
=ПРОСМОТР(СТРОКА(H1);МУМНОЖ(Ч(СТРОКА($1:$6)>=СТОЛБЕЦ(A:F));ДЛСТР(C$7:C$12)-ДЛСТР(ПОДСТАВИТЬ(C$7:C$12;",";))+1);A$8:A$9)
Код
=СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(ВПР(E8;A$8:C$10;3);", ";ПОВТОР(" ";99));СЧЁТЕСЛИ(E$7:E7;E8)*99+1;99))
можно без дополнительного столбца.

Автор - Светлый
Дата добавления - 01.02.2019 в 11:24
Светлый Дата: Пятница, 01.02.2019, 13:37 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1009
Репутация: 259 ±
Замечаний: 0% ±

Excel 2010
Для номера можно ещё короче массивную формулу поставить:
Код
=НАИМЕНЬШИЙ(ЕСЛИ(ПСТР(C$8:C$10&",";СТОЛБЕЦ(A:BE);1)=",";A$8:A$10);СТРОКА(D1))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДля номера можно ещё короче массивную формулу поставить:
Код
=НАИМЕНЬШИЙ(ЕСЛИ(ПСТР(C$8:C$10&",";СТОЛБЕЦ(A:BE);1)=",";A$8:A$10);СТРОКА(D1))

Автор - Светлый
Дата добавления - 01.02.2019 в 13:37
bindu Дата: Пятница, 01.02.2019, 17:13 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Светлый, огромное вам спасибо!
 
Ответить
СообщениеСветлый, огромное вам спасибо!

Автор - bindu
Дата добавления - 01.02.2019 в 17:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разбивка ячейки с привязанными данными. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!