Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/посчитать список работников - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » посчитать список работников (Формулы/Formulas)
посчитать список работников
ГАЙВЕР Дата: Среда, 06.02.2019, 15:04 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день. В организации 1200 человек. Помогите пожалуйста прописать макрос или формулу для того чтоб посчитать каждого работника. и Чтоб каждый работник сформировался в СВОДАХ! КТО МОЖЕТ ПОМОГИТЕ ПОЖАЛУЙСТА!
К сообщению приложен файл: 0140198.xlsx(10.7 Kb)
 
Ответить
СообщениеДобрый день. В организации 1200 человек. Помогите пожалуйста прописать макрос или формулу для того чтоб посчитать каждого работника. и Чтоб каждый работник сформировался в СВОДАХ! КТО МОЖЕТ ПОМОГИТЕ ПОЖАЛУЙСТА!

Автор - ГАЙВЕР
Дата добавления - 06.02.2019 в 15:04
китин Дата: Четверг, 07.02.2019, 07:34 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5308
Репутация: 834 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Так надо? Как понял
Код
=ИНДЕКС(H3:$H$500;(СТРОКА(A1)-1)*14+1)

это при условии, что все таблички будут располагаться идентично примеру
К сообщению приложен файл: _0140198.xlsx(11.3 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеТак надо? Как понял
Код
=ИНДЕКС(H3:$H$500;(СТРОКА(A1)-1)*14+1)

это при условии, что все таблички будут располагаться идентично примеру

Автор - китин
Дата добавления - 07.02.2019 в 07:34
ГАЙВЕР Дата: Четверг, 07.02.2019, 08:12 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
китин, Спасибо вам! ну мне нужно каждого работника по месячно считать, то есть в каждом месяце разные часы, соотвественно и процент надбавки разные.


Сообщение отредактировал ГАЙВЕР - Четверг, 07.02.2019, 08:12
 
Ответить
Сообщениекитин, Спасибо вам! ну мне нужно каждого работника по месячно считать, то есть в каждом месяце разные часы, соотвественно и процент надбавки разные.

Автор - ГАЙВЕР
Дата добавления - 07.02.2019 в 08:12
китин Дата: Четверг, 07.02.2019, 08:18 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 5308
Репутация: 834 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
в каждом месяце разные часы, соотвественно и процент надбавки разные.

а где это в вашем файле?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
в каждом месяце разные часы, соотвественно и процент надбавки разные.

а где это в вашем файле?

Автор - китин
Дата добавления - 07.02.2019 в 08:18
ГАЙВЕР Дата: Четверг, 07.02.2019, 08:22 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
китин, Вот я поправил. Я прошу прощения за недостоверную информацию.
К сообщению приложен файл: 3404606.xlsx(11.2 Kb)
 
Ответить
Сообщениекитин, Вот я поправил. Я прошу прощения за недостоверную информацию.

Автор - ГАЙВЕР
Дата добавления - 07.02.2019 в 08:22
Светлый Дата: Четверг, 07.02.2019, 08:57 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 931
Репутация: 227 ±
Замечаний: 0% ±

Excel 2010
Для фамилии:
Код
=СМЕЩ(H$3;СТРОКА(B1)*15-15;)&""
Для надбавки:
Код
=ЕСЛИОШИБКА(СМЕЩ(J$4;СТРОКА(B1)*15-15+ПОИСКПОЗ(A$3;H$5:H$16;);)/СМЕЩ(I$4;СТРОКА(B1)*15-15+ПОИСКПОЗ(A$3;H$5:H$16;);)-1;"")
Формулы исправил.


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Четверг, 07.02.2019, 09:02
 
Ответить
СообщениеДля фамилии:
Код
=СМЕЩ(H$3;СТРОКА(B1)*15-15;)&""
Для надбавки:
Код
=ЕСЛИОШИБКА(СМЕЩ(J$4;СТРОКА(B1)*15-15+ПОИСКПОЗ(A$3;H$5:H$16;);)/СМЕЩ(I$4;СТРОКА(B1)*15-15+ПОИСКПОЗ(A$3;H$5:H$16;);)-1;"")
Формулы исправил.

Автор - Светлый
Дата добавления - 07.02.2019 в 08:57
ГАЙВЕР Дата: Четверг, 07.02.2019, 09:10 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
СПАСИБО ВСЕМ ОГРОМНОЕ!!!!!!!
 
Ответить
СообщениеСПАСИБО ВСЕМ ОГРОМНОЕ!!!!!!!

Автор - ГАЙВЕР
Дата добавления - 07.02.2019 в 09:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » посчитать список работников (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!