Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Разность времени и даты - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разность времени и даты (Формулы/Formulas)
Разность времени и даты
andron359 Дата: Четверг, 07.02.2019, 12:26 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 103
Репутация: 0 ±
Замечаний: 20% ±

2010
Помогите с формулой или форматом при вычислении когда разница больше месяца.Спасибо
К сообщению приложен файл: 7188610.xlsx(9.7 Kb)
 
Ответить
СообщениеПомогите с формулой или форматом при вычислении когда разница больше месяца.Спасибо

Автор - andron359
Дата добавления - 07.02.2019 в 12:26
_Boroda_ Дата: Четверг, 07.02.2019, 12:47 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14891
Репутация: 5885 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так подойдет?
Код
=ОТБР(E7+D7-B7-A7)&ТЕКСТ(E7+D7-B7-A7;".чч:мм")

Только это будет уже не число, а текст.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак подойдет?
Код
=ОТБР(E7+D7-B7-A7)&ТЕКСТ(E7+D7-B7-A7;".чч:мм")

Только это будет уже не число, а текст.

Автор - _Boroda_
Дата добавления - 07.02.2019 в 12:47
andron359 Дата: Четверг, 07.02.2019, 13:47 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 103
Репутация: 0 ±
Замечаний: 20% ±

2010
_Boroda_,
Спасибо , т.е. если в других ячейках будет числовой формат , то не подсчитает сумму.
 
Ответить
Сообщение_Boroda_,
Спасибо , т.е. если в других ячейках будет числовой формат , то не подсчитает сумму.

Автор - andron359
Дата добавления - 07.02.2019 в 13:47
_Boroda_ Дата: Четверг, 07.02.2019, 13:49 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14891
Репутация: 5885 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Смотря как подсчитывать


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСмотря как подсчитывать

Автор - _Boroda_
Дата добавления - 07.02.2019 в 13:49
andron359 Дата: Четверг, 07.02.2019, 16:02 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 103
Репутация: 0 ±
Замечаний: 20% ±

2010
_Boroda_,

Приложил файл,буду очень рад помощь.
К сообщению приложен файл: 7925907.xlsx(14.5 Kb)
 
Ответить
Сообщение_Boroda_,

Приложил файл,буду очень рад помощь.

Автор - andron359
Дата добавления - 07.02.2019 в 16:02
Pelena Дата: Четверг, 07.02.2019, 16:18 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 13879
Репутация: 3044 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Можно по исходным данным
Код
=ОТБР(СУММ(F3:F36;E3:E36)-СУММ(D3:D36;C3:C36))&ТЕКСТ(СУММ(F3:F36;E3:E36)-СУММ(D3:D36;C3:C36);".чч:мм")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеМожно по исходным данным
Код
=ОТБР(СУММ(F3:F36;E3:E36)-СУММ(D3:D36;C3:C36))&ТЕКСТ(СУММ(F3:F36;E3:E36)-СУММ(D3:D36;C3:C36);".чч:мм")

Автор - Pelena
Дата добавления - 07.02.2019 в 16:18
_Boroda_ Дата: Четверг, 07.02.2019, 16:31 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14891
Репутация: 5885 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Формулу для строк чуть поправить нужно, чтобы дни как Вам нужно отображались - с двумя цифрами
Код
=ТЕКСТ(ОТБР(F3+E3-D3-C3);"00")&ТЕКСТ(F3+E3-D3-C3;".чч:мм")

Сумма
Код
=ТЕКСТ(ОТБР(СУММПРОИЗВ(ЛЕВБ(L3:L36;ДЛСТР(L3:L36)-6)+ПРАВБ(L3:L36;5)));"00")&"."&ТЕКСТ(СУММПРОИЗВ(--ПРАВБ(L3:L36;5));"чч:мм")

А если по исходнику, то дату-время можно вместе
Код
=ОТБР(СУММ(E3:F36)-СУММ(C3:D36))&ТЕКСТ(СУММ(E3:F36)-СУММ(C3:D36);".чч:мм")

Но только ТЕКСТ 00 все равно добавить нужно
Код
=ТЕКСТ(ОТБР(СУММ(E3:F36)-СУММ(C3:D36));"00")&ТЕКСТ(СУММ(E3:F36)-СУММ(C3:D36);".чч:мм")

Или вообще все одним массивом
Код
=ТЕКСТ(ОТБР(СУММПРОИЗВ(C3:F36*{-1;-1;1;1}));"00")&ТЕКСТ(СУММПРОИЗВ(C3:F36*{-1;-1;1;1});".чч:мм")

Или массивка
Код
=ТЕКСТ(ОТБР(СУММ(C3:F36*{-1;-1;1;1}));"00")&ТЕКСТ(СУММ(C3:F36*{-1;-1;1;1});".чч:мм")
К сообщению приложен файл: 7925907_1.xlsx(14.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеФормулу для строк чуть поправить нужно, чтобы дни как Вам нужно отображались - с двумя цифрами
Код
=ТЕКСТ(ОТБР(F3+E3-D3-C3);"00")&ТЕКСТ(F3+E3-D3-C3;".чч:мм")

Сумма
Код
=ТЕКСТ(ОТБР(СУММПРОИЗВ(ЛЕВБ(L3:L36;ДЛСТР(L3:L36)-6)+ПРАВБ(L3:L36;5)));"00")&"."&ТЕКСТ(СУММПРОИЗВ(--ПРАВБ(L3:L36;5));"чч:мм")

А если по исходнику, то дату-время можно вместе
Код
=ОТБР(СУММ(E3:F36)-СУММ(C3:D36))&ТЕКСТ(СУММ(E3:F36)-СУММ(C3:D36);".чч:мм")

Но только ТЕКСТ 00 все равно добавить нужно
Код
=ТЕКСТ(ОТБР(СУММ(E3:F36)-СУММ(C3:D36));"00")&ТЕКСТ(СУММ(E3:F36)-СУММ(C3:D36);".чч:мм")

Или вообще все одним массивом
Код
=ТЕКСТ(ОТБР(СУММПРОИЗВ(C3:F36*{-1;-1;1;1}));"00")&ТЕКСТ(СУММПРОИЗВ(C3:F36*{-1;-1;1;1});".чч:мм")

Или массивка
Код
=ТЕКСТ(ОТБР(СУММ(C3:F36*{-1;-1;1;1}));"00")&ТЕКСТ(СУММ(C3:F36*{-1;-1;1;1});".чч:мм")

Автор - _Boroda_
Дата добавления - 07.02.2019 в 16:31
andron359 Дата: Пятница, 08.02.2019, 14:31 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 103
Репутация: 0 ±
Замечаний: 20% ±

2010
_Boroda_,

А никак нельзя сделать без текстовых форматов ?
 
Ответить
Сообщение_Boroda_,

А никак нельзя сделать без текстовых форматов ?

Автор - andron359
Дата добавления - 08.02.2019 в 14:31
_Boroda_ Дата: Пятница, 08.02.2019, 17:21 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14891
Репутация: 5885 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А никак нельзя сделать без текстовых форматов ?
И чтобы просто сумма считала, да? :D

Можно
К сообщению приложен файл: 7925907-1-1.xlsx(16.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
А никак нельзя сделать без текстовых форматов ?
И чтобы просто сумма считала, да? :D

Можно

Автор - _Boroda_
Дата добавления - 08.02.2019 в 17:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разность времени и даты (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!