Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как формулой прописать CTRL+F - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как формулой прописать CTRL+F (Формулы/Formulas)
Как формулой прописать CTRL+F
Senya_20 Дата: Пятница, 15.02.2019, 19:46 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Есть коды разблокировки и Imei на одном листе. Как на втором листе подставить нужный код разблокировки, но при этом вводить последние 6 цифр Imei?
К сообщению приложен файл: 2389569.xlsx(10.9 Kb)
 
Ответить
СообщениеЕсть коды разблокировки и Imei на одном листе. Как на втором листе подставить нужный код разблокировки, но при этом вводить последние 6 цифр Imei?

Автор - Senya_20
Дата добавления - 15.02.2019 в 19:46
Nic70y Дата: Пятница, 15.02.2019, 21:06 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5262
Репутация: 1143 ±
Замечаний: 0% ±

Excel 2013
вдруг правильно
массивная
Код
=ИНДЕКС(B:B;МАКС((ПРАВБ("00000"&G2;6)=ПРАВБ(A2:A16;6))*СТРОКА(A2:A16)))
К сообщению приложен файл: 7664221.xlsx(11.3 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениевдруг правильно
массивная
Код
=ИНДЕКС(B:B;МАКС((ПРАВБ("00000"&G2;6)=ПРАВБ(A2:A16;6))*СТРОКА(A2:A16)))

Автор - Nic70y
Дата добавления - 15.02.2019 в 21:06
Pelena Дата: Пятница, 15.02.2019, 21:15 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 14009
Репутация: 3065 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Как вариант, тоже массивная
Код
=ВПР("*"&G2;$A$2:$B$16&"";2;0)

А если перевести первый столбец тоже в текстовый формат, то обычная (см. второй лист)
Код
=ВПР("*"&G2;$A$2:$B$16;2;0)
К сообщению приложен файл: 9016621.xlsx(14.9 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеКак вариант, тоже массивная
Код
=ВПР("*"&G2;$A$2:$B$16&"";2;0)

А если перевести первый столбец тоже в текстовый формат, то обычная (см. второй лист)
Код
=ВПР("*"&G2;$A$2:$B$16;2;0)

Автор - Pelena
Дата добавления - 15.02.2019 в 21:15
_Boroda_ Дата: Суббота, 16.02.2019, 00:10 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14954
Репутация: 5916 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
В G2 нужно поставить текстовый формат, чтобы можно было нормально вводить 6 символов с ведущими нулями (типа 077181). Тогда немассивную формулу можно написать так
Код
=ПРОСМОТР(;-1/(ПРАВБ(A2:A99;6)=G2);B2:B99)

Если форматы менять нельзя и неизвестно где какой, то
Код
=ПРОСМОТР(;-1/(ПРАВБ(A2:A99;6)-G3=0);B3:B99)

Код
=ПРОСМОТР(;-1/НЕ(ПРАВБ(A2:A99;6)-G3);B3:B99)
К сообщению приложен файл: 2389569_1.xlsx(11.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВ G2 нужно поставить текстовый формат, чтобы можно было нормально вводить 6 символов с ведущими нулями (типа 077181). Тогда немассивную формулу можно написать так
Код
=ПРОСМОТР(;-1/(ПРАВБ(A2:A99;6)=G2);B2:B99)

Если форматы менять нельзя и неизвестно где какой, то
Код
=ПРОСМОТР(;-1/(ПРАВБ(A2:A99;6)-G3=0);B3:B99)

Код
=ПРОСМОТР(;-1/НЕ(ПРАВБ(A2:A99;6)-G3);B3:B99)

Автор - _Boroda_
Дата добавления - 16.02.2019 в 00:10
Senya_20 Дата: Суббота, 16.02.2019, 11:17 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
=ВПР("*"&G2;$A$2:$B$16;2;0)

Pelena, Круто все работает, до этого пользовался ВПР но не знал про "*", остальные варианты тоже работают, но для меня тяжело в них разобраться, чтобы потом прописать в другой книге. И не затруднит Вас объяснить для чего в первой формуле нажимать CTRL+SHIFT+ENTER, не могу понять, для общего развития.
 
Ответить
Сообщение
=ВПР("*"&G2;$A$2:$B$16;2;0)

Pelena, Круто все работает, до этого пользовался ВПР но не знал про "*", остальные варианты тоже работают, но для меня тяжело в них разобраться, чтобы потом прописать в другой книге. И не затруднит Вас объяснить для чего в первой формуле нажимать CTRL+SHIFT+ENTER, не могу понять, для общего развития.

Автор - Senya_20
Дата добавления - 16.02.2019 в 11:17
Pelena Дата: Суббота, 16.02.2019, 14:46 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14009
Репутация: 3065 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
для чего в первой формуле нажимать CTRL+SHIFT+ENTER

это из-за этой части
Код
$A$2:$B$16&""
которая преобразует число в текст. Массивный ввод в данном случае обеспечивает добавление пустой строки к КАЖДОМУ элементу диапазона


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
для чего в первой формуле нажимать CTRL+SHIFT+ENTER

это из-за этой части
Код
$A$2:$B$16&""
которая преобразует число в текст. Массивный ввод в данном случае обеспечивает добавление пустой строки к КАЖДОМУ элементу диапазона

Автор - Pelena
Дата добавления - 16.02.2019 в 14:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как формулой прописать CTRL+F (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!