Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как посчитать значение в обьединенной ячейке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать значение в обьединенной ячейке (Формулы/Formulas)
Как посчитать значение в обьединенной ячейке
md10 Дата: Воскресенье, 24.02.2019, 18:35 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте есть объединенная ячейка из трех строк, в ней хранится значение, как это значение умножить на число в соседних трех ячейках. чтоб растянуть формулу.
К сообщению приложен файл: _Microsoft_Exce.xlsx(8.0 Kb)


Сообщение отредактировал md10 - Воскресенье, 24.02.2019, 18:35
 
Ответить
СообщениеЗдравствуйте есть объединенная ячейка из трех строк, в ней хранится значение, как это значение умножить на число в соседних трех ячейках. чтоб растянуть формулу.

Автор - md10
Дата добавления - 24.02.2019 в 18:35
vikttur Дата: Воскресенье, 24.02.2019, 18:52 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Код
=ИНДЕКС(A:A;ЦЕЛОЕ((СТРОКА(A1)-1)/3)*3+1)*3

Возможно, не так понял. В заголовке - считать в объединенной ячейке, в сообщении - со ссылкой на эту ячейку...


Сообщение отредактировал vikttur - Воскресенье, 24.02.2019, 19:04
 
Ответить
Сообщение
Код
=ИНДЕКС(A:A;ЦЕЛОЕ((СТРОКА(A1)-1)/3)*3+1)*3

Возможно, не так понял. В заголовке - считать в объединенной ячейке, в сообщении - со ссылкой на эту ячейку...

Автор - vikttur
Дата добавления - 24.02.2019 в 18:52
bmv98rus Дата: Воскресенье, 24.02.2019, 19:09 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1827
Репутация: 297 ±
Замечаний: 0% ±

Excel 2013/2016
вариант для непредсказуемо объединённой ячейки
Код
=LOOKUP(2;1/($A$1:A1<>"");$A$1:A1*3)
 
Ответить
Сообщениевариант для непредсказуемо объединённой ячейки
Код
=LOOKUP(2;1/($A$1:A1<>"");$A$1:A1*3)

Автор - bmv98rus
Дата добавления - 24.02.2019 в 19:09
md10 Дата: Воскресенье, 24.02.2019, 19:17 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо. Оба варианта подходят. Расшифровать формулы не смог, но работают как надо. Если не сложно поясните, в гугле примеры с поиском нужных значений, не очень понятно.
 
Ответить
СообщениеСпасибо. Оба варианта подходят. Расшифровать формулы не смог, но работают как надо. Если не сложно поясните, в гугле примеры с поиском нужных значений, не очень понятно.

Автор - md10
Дата добавления - 24.02.2019 в 19:17
vikttur Дата: Воскресенье, 24.02.2019, 19:59 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Здесь только математика:
Код
=ЦЕЛОЕ((СТРОКА(A1)-1)/3)*3+1

Протяните эту формулу по строкам, проанализируйте результат.
 
Ответить
СообщениеЗдесь только математика:
Код
=ЦЕЛОЕ((СТРОКА(A1)-1)/3)*3+1

Протяните эту формулу по строкам, проанализируйте результат.

Автор - vikttur
Дата добавления - 24.02.2019 в 19:59
md10 Дата: Воскресенье, 24.02.2019, 20:41 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Протяните эту формулу по строкам, проанализируйте результат.

Это понятно) Я имею ввиду логику формулы пояснить если не сложно.
 
Ответить
Сообщение
Протяните эту формулу по строкам, проанализируйте результат.

Это понятно) Я имею ввиду логику формулы пояснить если не сложно.

Автор - md10
Дата добавления - 24.02.2019 в 20:41
_Boroda_ Дата: Воскресенье, 24.02.2019, 20:55 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14486
Репутация: 5788 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если добавить сверху две строки, то можно
Код
=СУММ(A1:A3)*3

Если добавить одну строку, то
Код
=ЕСЛИ(D2;D2*3;E1)

Если ничего не добавлять то
Код
=-3/ПРОСМОТР(;-1/G$1:G1)

Код
=3/ПРОСМОТР(2;1/G$1:G1)

Пояснялка для похожей формулы ПРОСМОТР вот здесь есть http://www.excelworld.ru/forum/2-16573-138042-16-1427281717
К сообщению приложен файл: 0310243.xlsx(8.4 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли добавить сверху две строки, то можно
Код
=СУММ(A1:A3)*3

Если добавить одну строку, то
Код
=ЕСЛИ(D2;D2*3;E1)

Если ничего не добавлять то
Код
=-3/ПРОСМОТР(;-1/G$1:G1)

Код
=3/ПРОСМОТР(2;1/G$1:G1)

Пояснялка для похожей формулы ПРОСМОТР вот здесь есть http://www.excelworld.ru/forum/2-16573-138042-16-1427281717

Автор - _Boroda_
Дата добавления - 24.02.2019 в 20:55
vikttur Дата: Воскресенье, 24.02.2019, 20:55 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Показанный фрагмент все объясняет! Получение числа, которое указывает на положение значения в столбце
Код
=ИНДЕКС(столбец;полученное_значение)

О функции должно быть все понятно.


Сообщение отредактировал vikttur - Воскресенье, 24.02.2019, 20:57
 
Ответить
СообщениеПоказанный фрагмент все объясняет! Получение числа, которое указывает на положение значения в столбце
Код
=ИНДЕКС(столбец;полученное_значение)

О функции должно быть все понятно.

Автор - vikttur
Дата добавления - 24.02.2019 в 20:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать значение в обьединенной ячейке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!