Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка данных по условиям! - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка данных по условиям! (Формулы/Formulas)
Выборка данных по условиям!
evgeni1990 Дата: Вторник, 26.02.2019, 15:23 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Уважаемые форумчане!

Прошу помощи в решении следующей задачи.
Есть три листа с данными, где указаны объекты и месяц, объекты на каждом листе могут иметь разный порядок, надо на лист "итого" вытащить эти данные согласно условию объект и месяц. формулой индекс+поискпоз не получается, пробовал использовать справочник по объектам и месяцам.
К сообщению приложен файл: 9262085.xlsx(23.2 Kb)
 
Ответить
СообщениеУважаемые форумчане!

Прошу помощи в решении следующей задачи.
Есть три листа с данными, где указаны объекты и месяц, объекты на каждом листе могут иметь разный порядок, надо на лист "итого" вытащить эти данные согласно условию объект и месяц. формулой индекс+поискпоз не получается, пробовал использовать справочник по объектам и месяцам.

Автор - evgeni1990
Дата добавления - 26.02.2019 в 15:23
Nic70y Дата: Вторник, 26.02.2019, 15:32 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5188
Репутация: 1125 ±
Замечаний: 0% ±

Excel 2013
как-то так
Код
=СУММЕСЛИ('Таблица 1'!A:A;$B5;ИНДЕКС('Таблица 1'!B:Q;ПОИСКПОЗ(B$3;МЕСЯЦ;);))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Вторник, 26.02.2019, 16:13
 
Ответить
Сообщениекак-то так
Код
=СУММЕСЛИ('Таблица 1'!A:A;$B5;ИНДЕКС('Таблица 1'!B:Q;ПОИСКПОЗ(B$3;МЕСЯЦ;);))

Автор - Nic70y
Дата добавления - 26.02.2019 в 15:32
_Boroda_ Дата: Вторник, 26.02.2019, 15:40 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14486
Репутация: 5788 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММЕСЛИ(ДВССЫЛ("'"&C$3&"'!A:A");$B5;ИНДЕКС(ДВССЫЛ("'"&C$3&"'!B:Q");;ПОИСКПОЗ($B$3;МЕСЯЦ;)))
К сообщению приложен файл: 9262085_1.xlsx(23.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММЕСЛИ(ДВССЫЛ("'"&C$3&"'!A:A");$B5;ИНДЕКС(ДВССЫЛ("'"&C$3&"'!B:Q");;ПОИСКПОЗ($B$3;МЕСЯЦ;)))

Автор - _Boroda_
Дата добавления - 26.02.2019 в 15:40
evgeni1990 Дата: Вторник, 26.02.2019, 15:53 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Nic70y спасибо за предложенный вариант, но не получается поменять месяц.
 
Ответить
СообщениеNic70y спасибо за предложенный вариант, но не получается поменять месяц.

Автор - evgeni1990
Дата добавления - 26.02.2019 в 15:53
Nic70y Дата: Вторник, 26.02.2019, 15:54 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5188
Репутация: 1125 ±
Замечаний: 0% ±

Excel 2013
не получается поменять месяц
так это Ваш выпадающий список...
замените в проверке данных на =МЕСЯЦ


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Вторник, 26.02.2019, 15:55
 
Ответить
Сообщение
не получается поменять месяц
так это Ваш выпадающий список...
замените в проверке данных на =МЕСЯЦ

Автор - Nic70y
Дата добавления - 26.02.2019 в 15:54
evgeni1990 Дата: Вторник, 26.02.2019, 15:58 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_ спасибо, подскажи, в твоем варианте он ссылается на название таблицы в столбце, а если убрать его, как тогда? в рабочем листе у меня их не будет, я их указал для понимания проблемы.
К сообщению приложен файл: 7714166.xlsx(23.4 Kb)
 
Ответить
Сообщение_Boroda_ спасибо, подскажи, в твоем варианте он ссылается на название таблицы в столбце, а если убрать его, как тогда? в рабочем листе у меня их не будет, я их указал для понимания проблемы.

Автор - evgeni1990
Дата добавления - 26.02.2019 в 15:58
evgeni1990 Дата: Вторник, 26.02.2019, 16:00 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
так это Ваш выпадающий список...
замените в проверке данных на =МЕСЯЦ

Исправил, но данные неверные при изменении месяца.
 
Ответить
Сообщение
так это Ваш выпадающий список...
замените в проверке данных на =МЕСЯЦ

Исправил, но данные неверные при изменении месяца.

Автор - evgeni1990
Дата добавления - 26.02.2019 в 16:00
Nic70y Дата: Вторник, 26.02.2019, 16:07 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5188
Репутация: 1125 ±
Замечаний: 0% ±

Excel 2013
блин, точно строку со столбцов перепутал %)
Код
=СУММЕСЛИ('Таблица 1'!A:A;$B5;ИНДЕКС('Таблица 1'!B:Q;;ПОИСКПОЗ(B$3;МЕСЯЦ;)))
К сообщению приложен файл: 4325267.xlsx(23.1 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениеблин, точно строку со столбцов перепутал %)
Код
=СУММЕСЛИ('Таблица 1'!A:A;$B5;ИНДЕКС('Таблица 1'!B:Q;;ПОИСКПОЗ(B$3;МЕСЯЦ;)))

Автор - Nic70y
Дата добавления - 26.02.2019 в 16:07
evgeni1990 Дата: Вторник, 26.02.2019, 16:16 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Да, все работает, еще раз спасибо!


Сообщение отредактировал evgeni1990 - Вторник, 26.02.2019, 16:38
 
Ответить
СообщениеДа, все работает, еще раз спасибо!

Автор - evgeni1990
Дата добавления - 26.02.2019 в 16:16
_Boroda_ Дата: Вторник, 26.02.2019, 16:20 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14486
Репутация: 5788 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так?
Код
=СУММЕСЛИ(ДВССЫЛ("'*"&СТОЛБЕЦ(A5)&"'!A:A");$B5;ИНДЕКС(ДВССЫЛ("'*"&СТОЛБЕЦ(A5)&"'!B:q");;ПОИСКПОЗ($B$3;МЕСЯЦ;)))

В следующий раз реальные данные кладите. И пояснения, типа "Это с листа 111, а это с листа 222"

И да, подскажите, я что-то запамятовал, мы когда с Вами на "ты" перешли?
К сообщению приложен файл: 9262085_2.xlsx(23.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак?
Код
=СУММЕСЛИ(ДВССЫЛ("'*"&СТОЛБЕЦ(A5)&"'!A:A");$B5;ИНДЕКС(ДВССЫЛ("'*"&СТОЛБЕЦ(A5)&"'!B:q");;ПОИСКПОЗ($B$3;МЕСЯЦ;)))

В следующий раз реальные данные кладите. И пояснения, типа "Это с листа 111, а это с листа 222"

И да, подскажите, я что-то запамятовал, мы когда с Вами на "ты" перешли?

Автор - _Boroda_
Дата добавления - 26.02.2019 в 16:20
Pelena Дата: Вторник, 26.02.2019, 16:27 | Сообщение № 11
Группа: Админы
Ранг: Местный житель
Сообщений: 13782
Репутация: 3027 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
evgeni1990, не надо цитировать пост целиком, это нарушение Правил форума. Исправьте


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеevgeni1990, не надо цитировать пост целиком, это нарушение Правил форума. Исправьте

Автор - Pelena
Дата добавления - 26.02.2019 в 16:27
evgeni1990 Дата: Вторник, 26.02.2019, 16:32 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Boroda_ Да,то что нужно, еще раз спасибо! рекомендации учту, за форму обращения пардон)...


Сообщение отредактировал evgeni1990 - Вторник, 26.02.2019, 16:38
 
Ответить
СообщениеBoroda_ Да,то что нужно, еще раз спасибо! рекомендации учту, за форму обращения пардон)...

Автор - evgeni1990
Дата добавления - 26.02.2019 в 16:32
alexa1965 Дата: Вторник, 26.02.2019, 17:00 | Сообщение № 13
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 137
Репутация: 5 ±
Замечаний: 0% ±

2003, 2010
Прошу прощения! А возможна ли подборка значений не по месяцам, а по кварталам?


Главное не быть балабастиком
 
Ответить
СообщениеПрошу прощения! А возможна ли подборка значений не по месяцам, а по кварталам?

Автор - alexa1965
Дата добавления - 26.02.2019 в 17:00
_Boroda_ Дата: Вторник, 26.02.2019, 17:09 | Сообщение № 14
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14486
Репутация: 5788 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Да :D

* Это намек


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДа :D

* Это намек

Автор - _Boroda_
Дата добавления - 26.02.2019 в 17:09
alexa1965 Дата: Вторник, 26.02.2019, 17:14 | Сообщение № 15
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 137
Репутация: 5 ±
Замечаний: 0% ±

2003, 2010
* Это намек

Спасибо за отклик. Постоянно пользуюсь и Вашими решениями. Я имел в виду выпадающий список по кварталам и соответственно выборку данных.


Главное не быть балабастиком
 
Ответить
Сообщение
* Это намек

Спасибо за отклик. Постоянно пользуюсь и Вашими решениями. Я имел в виду выпадающий список по кварталам и соответственно выборку данных.

Автор - alexa1965
Дата добавления - 26.02.2019 в 17:14
_Boroda_ Дата: Вторник, 26.02.2019, 17:45 | Сообщение № 16
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14486
Репутация: 5788 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Я Вас понял, но дело в том, что для перевода кварталов в месяцы есть куча нюансов. Например - в дате или в тексте месяцы, русская или латинская запись кварталов, один год в базе или несколько, ...
Другими словами - мы сейчас сделаем на файле ТСа покварталку, а потом окажется, что "А у меня в файле все не так".
Поэтому нужно что сделать? Как обычно - еще раз перечитать Правила форума, создать свою тему, приложить файл-пример


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЯ Вас понял, но дело в том, что для перевода кварталов в месяцы есть куча нюансов. Например - в дате или в тексте месяцы, русская или латинская запись кварталов, один год в базе или несколько, ...
Другими словами - мы сейчас сделаем на файле ТСа покварталку, а потом окажется, что "А у меня в файле все не так".
Поэтому нужно что сделать? Как обычно - еще раз перечитать Правила форума, создать свою тему, приложить файл-пример

Автор - _Boroda_
Дата добавления - 26.02.2019 в 17:45
alexa1965 Дата: Среда, 27.02.2019, 07:26 | Сообщение № 17
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 137
Репутация: 5 ±
Замечаний: 0% ±

2003, 2010
Правила форума, создать свою тему, приложить файл-пример

Да, конечно это так. Просто увидел Ваше решение данной проблемы и еще до конца не решил как его приспособить для себя. ДВССЫЛ не пользовал ни разу. Безусловно абсолютно другая база и другие требования. Если не разберусь сам, обязательно обращусь за помощью. Еще раз спасибо.


Главное не быть балабастиком
 
Ответить
Сообщение
Правила форума, создать свою тему, приложить файл-пример

Да, конечно это так. Просто увидел Ваше решение данной проблемы и еще до конца не решил как его приспособить для себя. ДВССЫЛ не пользовал ни разу. Безусловно абсолютно другая база и другие требования. Если не разберусь сам, обязательно обращусь за помощью. Еще раз спасибо.

Автор - alexa1965
Дата добавления - 27.02.2019 в 07:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка данных по условиям! (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!