Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод предпоследней строки с числами >0 из диапазона данных - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод предпоследней строки с числами >0 из диапазона данных (Формулы/Formulas)
Вывод предпоследней строки с числами >0 из диапазона данных
stalber Дата: Вторник, 05.03.2019, 11:13 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 268
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Подскажите пожалуйста формулу или что изменить в уже действующих формулах которые мне подсказали ранее. Там 3 варианта от разных пользователей, достаточно одну любую отредактировать.
Формулы которые есть они показывают ПОСЛЕДНИИ числа, а сейчас понадобилось ПРЕДпоследнии.
К сообщению приложен файл: vopros05032019.xlsx(13.1 Kb)
 
Ответить
СообщениеПодскажите пожалуйста формулу или что изменить в уже действующих формулах которые мне подсказали ранее. Там 3 варианта от разных пользователей, достаточно одну любую отредактировать.
Формулы которые есть они показывают ПОСЛЕДНИИ числа, а сейчас понадобилось ПРЕДпоследнии.

Автор - stalber
Дата добавления - 05.03.2019 в 11:13
_Boroda_ Дата: Вторник, 05.03.2019, 12:03 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6078 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Как-то незаметно проскочил Ваш этот вопрос в предыдущей теме. Ну ладно, так даже лучше, Вы только там потом ссылку сюда дайте
Быстренько накидал. Неоптимизировано
Код
=ЕСЛИОШИБКА(-1/ПРОСМОТР(;-1/ИНДЕКС(C:C;СЧЁТ(C:C)-$T24+ПРОСМОТР(;-1/C99:ИНДЕКС(C:C;СЧЁТ(C:C)-18);СТРОКА(C1:C99))):ИНДЕКС(C:C;СЧЁТ(C:C)-$T24+2));)
К сообщению приложен файл: vopros05032019_.xlsx(14.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеКак-то незаметно проскочил Ваш этот вопрос в предыдущей теме. Ну ладно, так даже лучше, Вы только там потом ссылку сюда дайте
Быстренько накидал. Неоптимизировано
Код
=ЕСЛИОШИБКА(-1/ПРОСМОТР(;-1/ИНДЕКС(C:C;СЧЁТ(C:C)-$T24+ПРОСМОТР(;-1/C99:ИНДЕКС(C:C;СЧЁТ(C:C)-18);СТРОКА(C1:C99))):ИНДЕКС(C:C;СЧЁТ(C:C)-$T24+2));)

Автор - _Boroda_
Дата добавления - 05.03.2019 в 12:03
bmv98rus Дата: Вторник, 05.03.2019, 12:39 | Сообщение № 3
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2627
Репутация: 451 ±
Замечаний: 0% ±

Excel 2013/2016
С заделом от _Boroda_,
Код
=IFERROR(INDEX(C:C;LARGE(IF(C99:INDEX(C:C;COUNT(C:C)-18);ROW(C99:INDEX(C:C;COUNT(C:C)-18)));2));)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеС заделом от _Boroda_,
Код
=IFERROR(INDEX(C:C;LARGE(IF(C99:INDEX(C:C;COUNT(C:C)-18);ROW(C99:INDEX(C:C;COUNT(C:C)-18)));2));)

Автор - bmv98rus
Дата добавления - 05.03.2019 в 12:39
AlexM Дата: Вторник, 05.03.2019, 12:42 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3885
Репутация: 976 ±
Замечаний: 0% ±

Excel 2003
Или я что-то не понял.
Формула массива
Код
=ИНДЕКС(C:C;НАИБОЛЬШИЙ((C21:C99>0)*СТРОКА(C21:C99);2))
К сообщению приложен файл: 0843525.xlsx(13.5 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеИли я что-то не понял.
Формула массива
Код
=ИНДЕКС(C:C;НАИБОЛЬШИЙ((C21:C99>0)*СТРОКА(C21:C99);2))

Автор - AlexM
Дата добавления - 05.03.2019 в 12:42
bmv98rus Дата: Вторник, 05.03.2019, 12:59 | Сообщение № 5
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2627
Репутация: 451 ±
Замечаний: 0% ±

Excel 2013/2016
AlexM, C21 не постоянная величина,
Цитата
Нужно найти предпоследнюю в зелёном диапазоне, данный зелёный диапазон через определённое время сдвигается вниз, единственное за что ухватится это то, что зелёный диапазон с самой нижней строки +20строк вверх.

конечно правильнее 99 заменить
Код
=INDEX(C:C;LARGE(IF(INDEX(C:C;COUNT(C:C)-18):INDEX(C:C;COUNT(C:C)+1);ROW(INDEX(C:C;COUNT(C:C)-18):INDEX(C:C;COUNT(C:C)+1)));2))


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Вторник, 05.03.2019, 13:04
 
Ответить
СообщениеAlexM, C21 не постоянная величина,
Цитата
Нужно найти предпоследнюю в зелёном диапазоне, данный зелёный диапазон через определённое время сдвигается вниз, единственное за что ухватится это то, что зелёный диапазон с самой нижней строки +20строк вверх.

конечно правильнее 99 заменить
Код
=INDEX(C:C;LARGE(IF(INDEX(C:C;COUNT(C:C)-18):INDEX(C:C;COUNT(C:C)+1);ROW(INDEX(C:C;COUNT(C:C)-18):INDEX(C:C;COUNT(C:C)+1)));2))

Автор - bmv98rus
Дата добавления - 05.03.2019 в 12:59
stalber Дата: Вторник, 05.03.2019, 15:39 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 268
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
А у фиксированной таблице, чтобы найти последнее число:
Код
=ИНДЕКС(F:F;НАИБОЛЬШИЙ((F5:F9>0)*СТРОКА(F5:F9);1))

и предпоследнее:
Код
=ИНДЕКС(F:F;НАИБОЛЬШИЙ((F5:F9>0)*СТРОКА(F5:F9);2))

Эти две формулы путём ввода ctrl+shift+enter.

А есть формулы без ввода массива?


Сообщение отредактировал stalber - Вторник, 05.03.2019, 15:45
 
Ответить
СообщениеА у фиксированной таблице, чтобы найти последнее число:
Код
=ИНДЕКС(F:F;НАИБОЛЬШИЙ((F5:F9>0)*СТРОКА(F5:F9);1))

и предпоследнее:
Код
=ИНДЕКС(F:F;НАИБОЛЬШИЙ((F5:F9>0)*СТРОКА(F5:F9);2))

Эти две формулы путём ввода ctrl+shift+enter.

А есть формулы без ввода массива?

Автор - stalber
Дата добавления - 05.03.2019 в 15:39
_Boroda_ Дата: Вторник, 05.03.2019, 15:52 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6078 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Дык все мои как раз немассивные


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДык все мои как раз немассивные

Автор - _Boroda_
Дата добавления - 05.03.2019 в 15:52
stalber Дата: Вторник, 05.03.2019, 15:56 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 268
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Дык все мои как раз немассивные

Я имел ввиду для фиксированной таблице, может есть возможность уменьшить формулу?
К сообщению приложен файл: vopros07032019.xlsx(9.8 Kb)


Сообщение отредактировал stalber - Вторник, 05.03.2019, 15:58
 
Ответить
Сообщение
Дык все мои как раз немассивные

Я имел ввиду для фиксированной таблице, может есть возможность уменьшить формулу?

Автор - stalber
Дата добавления - 05.03.2019 в 15:56
_Boroda_ Дата: Вторник, 05.03.2019, 16:04 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6078 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А че, разве большая формула? Ниче так вроде, симпатишная :D

Вот так попробуйте
Код
=ЕСЛИОШИБКА(-1/ПРОСМОТР(;-1/ИНДЕКС(C:C;ПРОСМОТР(;-1/C21:C40;СТРОКА(C21:C40))-1):C21);)

Или вот так
Код
=ИНДЕКС(C:C;НАИБОЛЬШИЙ(ИНДЕКС((C21:C40>0)*СТРОКА(C21:C40););2))

Кстати, для нефиксированного так
Код
=ИНДЕКС(C:C;НАИБОЛЬШИЙ(ИНДЕКС((C99:ИНДЕКС(C:C;СЧЁТ(C:C)-18)>0)*СТРОКА(C99:ИНДЕКС(C:C;СЧЁТ(C:C)-18)););2))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА че, разве большая формула? Ниче так вроде, симпатишная :D

Вот так попробуйте
Код
=ЕСЛИОШИБКА(-1/ПРОСМОТР(;-1/ИНДЕКС(C:C;ПРОСМОТР(;-1/C21:C40;СТРОКА(C21:C40))-1):C21);)

Или вот так
Код
=ИНДЕКС(C:C;НАИБОЛЬШИЙ(ИНДЕКС((C21:C40>0)*СТРОКА(C21:C40););2))

Кстати, для нефиксированного так
Код
=ИНДЕКС(C:C;НАИБОЛЬШИЙ(ИНДЕКС((C99:ИНДЕКС(C:C;СЧЁТ(C:C)-18)>0)*СТРОКА(C99:ИНДЕКС(C:C;СЧЁТ(C:C)-18)););2))

Автор - _Boroda_
Дата добавления - 05.03.2019 в 16:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод предпоследней строки с числами >0 из диапазона данных (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!