Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как посчитать два диапазона, которые соответствуют третьему? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать два диапазона, которые соответствуют третьему? (Формулы/Formulas)
Как посчитать два диапазона, которые соответствуют третьему?
bazaar Дата: Вторник, 19.03.2019, 16:04 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Задача такая, есть два листа, на одном ведется учет средств, на другом листе это все сводится в кешфлоу.

Нужно: посчитать соответствующие статьи расходов и доходов в заданном диапазоне дат. Штука в том, что статьи расходов и доходов считаются по двум колонкам и я нашел только как посчитать с помощью SUMIFS, но для второй колонки приходится дублировать формулу а я хочу ее оптимизировать.

В приложении пример, формула, которая используется сейчас в ячейке D16 второго листа
К сообщению приложен файл: 9158405.xlsx(52.6 Kb)
 
Ответить
СообщениеЗадача такая, есть два листа, на одном ведется учет средств, на другом листе это все сводится в кешфлоу.

Нужно: посчитать соответствующие статьи расходов и доходов в заданном диапазоне дат. Штука в том, что статьи расходов и доходов считаются по двум колонкам и я нашел только как посчитать с помощью SUMIFS, но для второй колонки приходится дублировать формулу а я хочу ее оптимизировать.

В приложении пример, формула, которая используется сейчас в ячейке D16 второго листа

Автор - bazaar
Дата добавления - 19.03.2019 в 16:04
bazaar Дата: Четверг, 21.03.2019, 13:03 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Все еще ищу решение
 
Ответить
СообщениеВсе еще ищу решение

Автор - bazaar
Дата добавления - 21.03.2019 в 13:03
sboy Дата: Четверг, 21.03.2019, 13:20 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2566
Репутация: 722 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Не информативный пример. Лично мне не совсем понятно, что нужно. А играть в угадайку не захотелось... А тема при этом все ниже и ниже, и все забы(и)ли


Яндекс: 410016850021169
 
Ответить
СообщениеДобрый день.
Не информативный пример. Лично мне не совсем понятно, что нужно. А играть в угадайку не захотелось... А тема при этом все ниже и ниже, и все забы(и)ли

Автор - sboy
Дата добавления - 21.03.2019 в 13:20
_Boroda_ Дата: Четверг, 21.03.2019, 15:16 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15576
Репутация: 6077 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Я тоже не совсем ясно понял. Так?
Код
=СУММПРОИЗВ(('Касса 2019'!$I$3:$I$99-'Касса 2019'!$H$3:$H$99)*('Касса 2019'!$D$3:$D$99=$B16)*('Касса 2019'!$A$3:$A$99<=КОНМЕСЯЦА(D$4;0))*('Касса 2019'!$A$3:$A$99>=D$4))
К сообщению приложен файл: 9158405_1.xlsx(50.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЯ тоже не совсем ясно понял. Так?
Код
=СУММПРОИЗВ(('Касса 2019'!$I$3:$I$99-'Касса 2019'!$H$3:$H$99)*('Касса 2019'!$D$3:$D$99=$B16)*('Касса 2019'!$A$3:$A$99<=КОНМЕСЯЦА(D$4;0))*('Касса 2019'!$A$3:$A$99>=D$4))

Автор - _Boroda_
Дата добавления - 21.03.2019 в 15:16
bazaar Дата: Вторник, 26.03.2019, 07:55 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума

Нет не так. Он почему-то суммирует в минус. Я попробую объяснить другими словами. У меня есть в таблице кешфлоу колонка ЗП Дизайнерам за январь. ЗП мы можем платить как из кассы так и с расчетного счета банка. Следовательно нужно найти все строчки с "Дизайнер", чтобы ячейка даты соответствовала условиям (попадала в месяц февраль например) и просуммировать все затраты на него в колонках "Кредит"
 
Ответить
СообщениеИзлишнее цитирование удалено администрацией - это нарушение п.5j Правил форума

Нет не так. Он почему-то суммирует в минус. Я попробую объяснить другими словами. У меня есть в таблице кешфлоу колонка ЗП Дизайнерам за январь. ЗП мы можем платить как из кассы так и с расчетного счета банка. Следовательно нужно найти все строчки с "Дизайнер", чтобы ячейка даты соответствовала условиям (попадала в месяц февраль например) и просуммировать все затраты на него в колонках "Кредит"

Автор - bazaar
Дата добавления - 26.03.2019 в 07:55
_Boroda_ Дата: Вторник, 26.03.2019, 09:08 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15576
Репутация: 6077 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Тогда так
Код
=СУММПРОИЗВ('Касса 2019'!$G$3:$I$99*('Касса 2019'!$D$3:$D$99=$B16)*('Касса 2019'!$A$3:$A$99<=КОНМЕСЯЦА(D$4;0))*('Касса 2019'!$A$3:$A$99>=D$4)*{1;0;1})


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТогда так
Код
=СУММПРОИЗВ('Касса 2019'!$G$3:$I$99*('Касса 2019'!$D$3:$D$99=$B16)*('Касса 2019'!$A$3:$A$99<=КОНМЕСЯЦА(D$4;0))*('Касса 2019'!$A$3:$A$99>=D$4)*{1;0;1})

Автор - _Boroda_
Дата добавления - 26.03.2019 в 09:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать два диапазона, которые соответствуют третьему? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!