Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/хотя бы одно число из диапазона по критерию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » хотя бы одно число из диапазона по критерию (Формулы/Formulas)
хотя бы одно число из диапазона по критерию
Artemon Дата: Вторник, 19.03.2019, 19:02 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый вечер
Помогите с небольшой формулой
есть столбец чисел, в котором есть значения , например
0,568965517
0,68
0,875
1
нужно, чтобы формула выдавала слово да если есть хоть одно число, которое входит в диапазон от 0,7 до 0,9 и выдавало нет, если такого числа нет
заранее спасибо
 
Ответить
СообщениеДобрый вечер
Помогите с небольшой формулой
есть столбец чисел, в котором есть значения , например
0,568965517
0,68
0,875
1
нужно, чтобы формула выдавала слово да если есть хоть одно число, которое входит в диапазон от 0,7 до 0,9 и выдавало нет, если такого числа нет
заранее спасибо

Автор - Artemon
Дата добавления - 19.03.2019 в 19:02
jakim Дата: Вторник, 19.03.2019, 19:47 | Сообщение № 2
Группа: Друзья
Ранг: Ветеран
Сообщений: 890
Репутация: 232 ±
Замечаний: 0% ±

Excel 2010
формула

Код
=ЕСЛИОШИБКА(АГРЕГАТ(15;6;$A$1:$A$100/(A$1:A$100>=C$1)/($A$1:$A$100<=D$1);ЧСТРОК($1:1));"")
К сообщению приложен файл: 2141079.xlsx(8.2 Kb)
 
Ответить
Сообщение
формула

Код
=ЕСЛИОШИБКА(АГРЕГАТ(15;6;$A$1:$A$100/(A$1:A$100>=C$1)/($A$1:$A$100<=D$1);ЧСТРОК($1:1));"")

Автор - jakim
Дата добавления - 19.03.2019 в 19:47
Artemon Дата: Вторник, 19.03.2019, 19:52 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
jakim, немного не так. нужно, чтобы выдавалось в ячейке "ДА", если есть хоть одно такое число и НЕТ, если нет числа из этого диапазона, а не как у вас само это число
 
Ответить
Сообщениеjakim, немного не так. нужно, чтобы выдавалось в ячейке "ДА", если есть хоть одно такое число и НЕТ, если нет числа из этого диапазона, а не как у вас само это число

Автор - Artemon
Дата добавления - 19.03.2019 в 19:52
jakim Дата: Вторник, 19.03.2019, 20:24 | Сообщение № 4
Группа: Друзья
Ранг: Ветеран
Сообщений: 890
Репутация: 232 ±
Замечаний: 0% ±

Excel 2010
Тогда так.

Код
=ЕСЛИ(ЕЧИСЛО(АГРЕГАТ(15;6;$A$1:$A$100/(A$1:A$100>=C$1)/($A$1:$A$100<=D$1);1));"ДА";"НЕТ")
К сообщению приложен файл: 1906804.xlsx(8.1 Kb)
 
Ответить
Сообщение
Тогда так.

Код
=ЕСЛИ(ЕЧИСЛО(АГРЕГАТ(15;6;$A$1:$A$100/(A$1:A$100>=C$1)/($A$1:$A$100<=D$1);1));"ДА";"НЕТ")

Автор - jakim
Дата добавления - 19.03.2019 в 20:24
Artemon Дата: Вторник, 19.03.2019, 20:32 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
jakim, Спасибо!
 
Ответить
Сообщениеjakim, Спасибо!

Автор - Artemon
Дата добавления - 19.03.2019 в 20:32
jakim Дата: Вторник, 19.03.2019, 20:32 | Сообщение № 6
Группа: Друзья
Ранг: Ветеран
Сообщений: 890
Репутация: 232 ±
Замечаний: 0% ±

Excel 2010
Ещё одна формула

Код
=ЕСЛИ(МАКС(ИНДЕКС((A1:A4>=C1)*(A1:A4<=D1);0))>0;"ДА";"НЕТ")
К сообщению приложен файл: 8440633.xlsx(8.1 Kb)
 
Ответить
Сообщение
Ещё одна формула

Код
=ЕСЛИ(МАКС(ИНДЕКС((A1:A4>=C1)*(A1:A4<=D1);0))>0;"ДА";"НЕТ")

Автор - jakim
Дата добавления - 19.03.2019 в 20:32
bmv98rus Дата: Вторник, 19.03.2019, 20:56 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 2023
Репутация: 320 ±
Замечаний: 20% ±

Excel 2013/2016
Код
=IF(COUNTIFS(A1:A4;">="&C1;A1:A4;"<="&D1);"ДА";"Нет")


Замечательный медведь, процентов на 20.
 
Ответить
Сообщение
Код
=IF(COUNTIFS(A1:A4;">="&C1;A1:A4;"<="&D1);"ДА";"Нет")

Автор - bmv98rus
Дата добавления - 19.03.2019 в 20:56
_Boroda_ Дата: Вторник, 19.03.2019, 21:08 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14864
Репутация: 5881 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ну тогда еще
Код
=ЕСЛИ(СЧЁТ(ТЕКСТ(A1:A4-,7;"[>,2]a;;0"));"Да";"Нет")

Код
=ЕСЛИ(-СЧЁТ(ТЕКСТ(A1:A4-C1;"[>"&D1-C1&"]a;;0"));"ДА";"Нет")

Вторая массивная Контрл Шифт Ентер ввод


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНу тогда еще
Код
=ЕСЛИ(СЧЁТ(ТЕКСТ(A1:A4-,7;"[>,2]a;;0"));"Да";"Нет")

Код
=ЕСЛИ(-СЧЁТ(ТЕКСТ(A1:A4-C1;"[>"&D1-C1&"]a;;0"));"ДА";"Нет")

Вторая массивная Контрл Шифт Ентер ввод

Автор - _Boroda_
Дата добавления - 19.03.2019 в 21:08
Artemon Дата: Вторник, 19.03.2019, 21:51 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
jakim, bmv98rus, _Boroda_, всем спасибо!
 
Ответить
Сообщениеjakim, bmv98rus, _Boroda_, всем спасибо!

Автор - Artemon
Дата добавления - 19.03.2019 в 21:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » хотя бы одно число из диапазона по критерию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!