Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вычисление количества дней до ближайшего дубля - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычисление количества дней до ближайшего дубля (Формулы/Formulas)
Вычисление количества дней до ближайшего дубля
sasha772 Дата: Вторник, 26.03.2019, 19:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день. Есть таблица с большим количеством телефонов 1000+, и датами их занесения. Необходимо при занесении нового телефона проверять его на дубль. Это пол дела. Основная задача, чтобы после проверки номера на дубль, напротив строки выводился номер строки когда последний раз был данный номер в базе, и если возможно количество дней, как давно был последний раз данный номера в базе.
К сообщению приложен файл: 9389165.xlsx(52.5 Kb)
 
Ответить
СообщениеДобрый день. Есть таблица с большим количеством телефонов 1000+, и датами их занесения. Необходимо при занесении нового телефона проверять его на дубль. Это пол дела. Основная задача, чтобы после проверки номера на дубль, напротив строки выводился номер строки когда последний раз был данный номер в базе, и если возможно количество дней, как давно был последний раз данный номера в базе.

Автор - sasha772
Дата добавления - 26.03.2019 в 19:57
Nic70y Дата: Вторник, 26.03.2019, 20:32 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5214
Репутация: 1130 ±
Замечаний: 0% ±

Excel 2013
e
Код
=СЧЁТЕСЛИ(D$1:D2;D2)&"\"&D2
f
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(СЧЁТЕСЛИ(D$1:D2;D2)-1&"\"&D2;E$1:E2;);"")
g
Код
=ЕСЛИ(F2="";"";A2-ИНДЕКС(A:A;F2))
К сообщению приложен файл: 5913748.xlsx(11.1 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениеe
Код
=СЧЁТЕСЛИ(D$1:D2;D2)&"\"&D2
f
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(СЧЁТЕСЛИ(D$1:D2;D2)-1&"\"&D2;E$1:E2;);"")
g
Код
=ЕСЛИ(F2="";"";A2-ИНДЕКС(A:A;F2))

Автор - Nic70y
Дата добавления - 26.03.2019 в 20:32
jakim Дата: Вторник, 26.03.2019, 20:54 | Сообщение № 3
Группа: Друзья
Ранг: Ветеран
Сообщений: 890
Репутация: 232 ±
Замечаний: 0% ±

Excel 2010
Посмотрите такой вариант

строка

Код
=ЕСЛИ(A2>0;АГРЕГАТ(14;6;СТРОКА($1:$200)/(D$2:D$200=D2);1);"")

дней

Код
=ЕСЛИ(A2>0;АГРЕГАТ(14;6;A$2:A$200/(D$2:D$200=D2);1)-АГРЕГАТ(15;6;A$2:A$200/(D$2:D$200=D2);1)+1;"")
К сообщению приложен файл: 2132372.xlsx(11.0 Kb)
 
Ответить
Сообщение
Посмотрите такой вариант

строка

Код
=ЕСЛИ(A2>0;АГРЕГАТ(14;6;СТРОКА($1:$200)/(D$2:D$200=D2);1);"")

дней

Код
=ЕСЛИ(A2>0;АГРЕГАТ(14;6;A$2:A$200/(D$2:D$200=D2);1)-АГРЕГАТ(15;6;A$2:A$200/(D$2:D$200=D2);1)+1;"")

Автор - jakim
Дата добавления - 26.03.2019 в 20:54
_Boroda_ Дата: Вторник, 26.03.2019, 22:25 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14864
Репутация: 5881 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант дней
Код
=ЕСЛИОШИБКА(A2+ПРОСМОТР(;-A$1:A1/(D$1:D1=D2));)

Строк
Код
=ЕСЛИОШИБКА(-ПРОСМОТР(;-СТРОКА(D$1:D1)/(D$1:D1=D2));)

Формат ячеек
0;;
К сообщению приложен файл: 9389165_1.xlsx(11.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант дней
Код
=ЕСЛИОШИБКА(A2+ПРОСМОТР(;-A$1:A1/(D$1:D1=D2));)

Строк
Код
=ЕСЛИОШИБКА(-ПРОСМОТР(;-СТРОКА(D$1:D1)/(D$1:D1=D2));)

Формат ячеек
0;;

Автор - _Boroda_
Дата добавления - 26.03.2019 в 22:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычисление количества дней до ближайшего дубля (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!