Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск наименьших значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск наименьших значений (Формулы/Formulas)
Поиск наименьших значений
Klerik Дата: Пятница, 29.03.2019, 17:20 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Необходимо из массива, Выявить наименьшие значения, и вывести ее в другую табличку, где будет видно: кем, по каким регионам и каким видом транспорта выгодней возить.Подскажите пожалуйста как это сделать ?
К сообщению приложен файл: 7199134.xls(34.5 Kb)


Сообщение отредактировал Klerik - Пятница, 29.03.2019, 17:39
 
Ответить
СообщениеНеобходимо из массива, Выявить наименьшие значения, и вывести ее в другую табличку, где будет видно: кем, по каким регионам и каким видом транспорта выгодней возить.Подскажите пожалуйста как это сделать ?

Автор - Klerik
Дата добавления - 29.03.2019 в 17:20
_Boroda_ Дата: Пятница, 29.03.2019, 19:18 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14916
Репутация: 5900 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Не знаю, правильно ли я понял, что из любой предложенной таблички нужно сделать маленькую, из которой было бы понятно, на ком выгоднее ехать
Если да, то у меня что-то такое страшненькое получилось. Зато немассивное :D
Код
=ПОДСТАВИТЬ(ПСТР(ПРОСМОТР(;-1/(МИН(ИНДЕКС($B4:$Q4;СЧЁТЗ($T$3:T$3)*4-3):ИНДЕКС($B4:$Q4;СЧЁТЗ($T$3:T$3)*4))=ИНДЕКС($B4:$Q4;СЧЁТЗ($T$3:T$3)*4-3):ИНДЕКС($B4:$Q4;СЧЁТЗ($T$3:T$3)*4));$B$3:$E$3);6;99);"""";)

И добавил еще автораскраску мин. суммы в исходной таблице
К сообщению приложен файл: 7199134_1.xls(55.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНе знаю, правильно ли я понял, что из любой предложенной таблички нужно сделать маленькую, из которой было бы понятно, на ком выгоднее ехать
Если да, то у меня что-то такое страшненькое получилось. Зато немассивное :D
Код
=ПОДСТАВИТЬ(ПСТР(ПРОСМОТР(;-1/(МИН(ИНДЕКС($B4:$Q4;СЧЁТЗ($T$3:T$3)*4-3):ИНДЕКС($B4:$Q4;СЧЁТЗ($T$3:T$3)*4))=ИНДЕКС($B4:$Q4;СЧЁТЗ($T$3:T$3)*4-3):ИНДЕКС($B4:$Q4;СЧЁТЗ($T$3:T$3)*4));$B$3:$E$3);6;99);"""";)

И добавил еще автораскраску мин. суммы в исходной таблице

Автор - _Boroda_
Дата добавления - 29.03.2019 в 19:18
bmv98rus Дата: Пятница, 29.03.2019, 20:47 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 2054
Репутация: 324 ±
Замечаний: 20% ±

Excel 2013/2016
Длинно, не массивно,
За основу взят файл _Boroda_,
Код
=SUBSTITUTE(MID(INDEX(INDEX($B$3:$Q$3;MATCH(T$3;$B$2:$Q$2;)):INDEX($B$3:$Q$3;MATCH(T$3;$B$2:$Q$2;)+3);MATCH(MIN(INDEX($B4:$Q4;MATCH(T$3;$B$2:$Q$2;)):INDEX($B4:$Q4;MATCH(T$3;$B$2:$Q$2;)+3));INDEX($B4:$Q4;MATCH(T$3;$B$2:$Q$2;)):INDEX($B4:$Q4;MATCH(T$3;$B$2:$Q$2;)+3);));6;99);"""";"")

Если тоннаж всегда на этих местах, то
Код
=SUBSTITUTE(MID(INDEX(INDEX($B$3:$Q$3;(COLUMN(A1)-1)*4+1):INDEX($B$3:$Q$3;COLUMN(A1)*4);MATCH(MIN(INDEX($B4:$Q4;(COLUMN(A1)-1)*4+1):INDEX($B4:$Q4;COLUMN(A1)*4));INDEX($B4:$Q4;(COLUMN(A1)-1)*4+1):INDEX($B4:$Q4;COLUMN(A1)*4);));6;99);"""";"")
К сообщению приложен файл: Copy_of_771.xlsx(21.3 Kb)


Замечательный медведь, процентов на 20.
 
Ответить
СообщениеДлинно, не массивно,
За основу взят файл _Boroda_,
Код
=SUBSTITUTE(MID(INDEX(INDEX($B$3:$Q$3;MATCH(T$3;$B$2:$Q$2;)):INDEX($B$3:$Q$3;MATCH(T$3;$B$2:$Q$2;)+3);MATCH(MIN(INDEX($B4:$Q4;MATCH(T$3;$B$2:$Q$2;)):INDEX($B4:$Q4;MATCH(T$3;$B$2:$Q$2;)+3));INDEX($B4:$Q4;MATCH(T$3;$B$2:$Q$2;)):INDEX($B4:$Q4;MATCH(T$3;$B$2:$Q$2;)+3);));6;99);"""";"")

Если тоннаж всегда на этих местах, то
Код
=SUBSTITUTE(MID(INDEX(INDEX($B$3:$Q$3;(COLUMN(A1)-1)*4+1):INDEX($B$3:$Q$3;COLUMN(A1)*4);MATCH(MIN(INDEX($B4:$Q4;(COLUMN(A1)-1)*4+1):INDEX($B4:$Q4;COLUMN(A1)*4));INDEX($B4:$Q4;(COLUMN(A1)-1)*4+1):INDEX($B4:$Q4;COLUMN(A1)*4);));6;99);"""";"")

Автор - bmv98rus
Дата добавления - 29.03.2019 в 20:47
Klerik Дата: Понедельник, 01.04.2019, 11:28 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Как правильно протянуть формулу?
Пробую обычным способом, не получается.
К сообщению приложен файл: 8859581.xls(37.0 Kb)


Сообщение отредактировал Klerik - Понедельник, 01.04.2019, 11:58
 
Ответить
СообщениеКак правильно протянуть формулу?
Пробую обычным способом, не получается.

Автор - Klerik
Дата добавления - 01.04.2019 в 11:28
Klerik Дата: Понедельник, 01.04.2019, 12:11 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
[Длинно, не массивно,
За основу взят файл _Boroda_,

Спасибо большое, это то,что нужно !


Сообщение отредактировал Klerik - Понедельник, 01.04.2019, 12:22
 
Ответить
Сообщение[Длинно, не массивно,
За основу взят файл _Boroda_,

Спасибо большое, это то,что нужно !

Автор - Klerik
Дата добавления - 01.04.2019 в 12:11
_Boroda_ Дата: Понедельник, 01.04.2019, 12:12 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14916
Репутация: 5900 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Это совсем другое дело
Код
=ИНДЕКС(B$3:L$3;ПОИСКПОЗ(МИН(B4:L4);B4:L4;))

Код
=ПРОСМОТР(;-1/(МИН(B4:L4)=B4:L4);B$3:L$3)


Лучше наверное так
Код
=ЕСЛИ(МАКС(B4:L4);ИНДЕКС(B$3:L$3;ПОИСКПОЗ(МИН(B4:L4);B4:L4;));"")

Код
=ЕСЛИ(МАКС(B4:L4);ПРОСМОТР(;-1/(МИН(B4:L4)=B4:L4);B$3:L$3);"")


Klerik, уберите излишнее цитирование в своем посте - это нарушение Правил форума
К сообщению приложен файл: 8859581_1.xls(43.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЭто совсем другое дело
Код
=ИНДЕКС(B$3:L$3;ПОИСКПОЗ(МИН(B4:L4);B4:L4;))

Код
=ПРОСМОТР(;-1/(МИН(B4:L4)=B4:L4);B$3:L$3)


Лучше наверное так
Код
=ЕСЛИ(МАКС(B4:L4);ИНДЕКС(B$3:L$3;ПОИСКПОЗ(МИН(B4:L4);B4:L4;));"")

Код
=ЕСЛИ(МАКС(B4:L4);ПРОСМОТР(;-1/(МИН(B4:L4)=B4:L4);B$3:L$3);"")


Klerik, уберите излишнее цитирование в своем посте - это нарушение Правил форума

Автор - _Boroda_
Дата добавления - 01.04.2019 в 12:12
AlexM Дата: Понедельник, 01.04.2019, 12:41 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3828
Репутация: 965 ±
Замечаний: 0% ±

Excel 2003
Для первой задачи еще формулы
Код
=ПОДСТАВИТЬ(ПСТР(ПРОСМОТР(2;1/(МИН(ИНДЕКС($B4:$Q4;Ч(ИНДЕКС(СТОЛБЕЦ(A1)*4-{3:2:1:0};))))=ИНДЕКС($B4:$Q4;Ч(ИНДЕКС(СТОЛБЕЦ(A1)*4-{3:2:1:0};))));$B$3:$E$3);6;99);"""";)
Код
=ПОДСТАВИТЬ(ПСТР(ПРОСМОТР(2;1/(МИН(ИНДЕКС(B4:Q4;Ч(ИНДЕКС(СТОЛБЕЦ(B1)*3-{5:4:3:2};))))=ИНДЕКС(B4:Q4;Ч(ИНДЕКС(СТОЛБЕЦ(B1)*3-{5:4:3:2};))));$B$3:$E$3);6;99);"""";)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Понедельник, 01.04.2019, 13:29
 
Ответить
СообщениеДля первой задачи еще формулы
Код
=ПОДСТАВИТЬ(ПСТР(ПРОСМОТР(2;1/(МИН(ИНДЕКС($B4:$Q4;Ч(ИНДЕКС(СТОЛБЕЦ(A1)*4-{3:2:1:0};))))=ИНДЕКС($B4:$Q4;Ч(ИНДЕКС(СТОЛБЕЦ(A1)*4-{3:2:1:0};))));$B$3:$E$3);6;99);"""";)
Код
=ПОДСТАВИТЬ(ПСТР(ПРОСМОТР(2;1/(МИН(ИНДЕКС(B4:Q4;Ч(ИНДЕКС(СТОЛБЕЦ(B1)*3-{5:4:3:2};))))=ИНДЕКС(B4:Q4;Ч(ИНДЕКС(СТОЛБЕЦ(B1)*3-{5:4:3:2};))));$B$3:$E$3);6;99);"""";)

Автор - AlexM
Дата добавления - 01.04.2019 в 12:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск наименьших значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!