Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как сделать зависимость одной ячейки от двух со списком - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сделать зависимость одной ячейки от двух со списком (Формулы/Formulas)
Как сделать зависимость одной ячейки от двух со списком
smokedi Дата: Среда, 10.04.2019, 09:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброе утро! Помогите с формулой, как правильно это сделать?
В ячейке D1 есть список(варианты в списке обозначаются так: A.:(описание),B.:(описание),C.:(описание),D.:(описание),E.:(описание)), в ячейке E1 второй список, варианты обозначаются так: 1.:(описание),2.:(описание),3.:(описание),4.:(описание),5.:(описание).
И нужно сделать чтобы в ячейке F3 была формула, которая бы выводила определенный текст в зависимости от вариантов в ячейках D1 и E1.
Если получилось из двух ячеек вариант А1,А2,А3,А4,А5, В1,В2,В3,В4, С1,С2,С3, D1,D2,Е1 , тогда выводить слово "Существенный", если В5, С4,С5,D3,D4,D5,Е2,Е3,Е4,Е5 - то выводить "Несущественный"

Файл приложил к письму. Большое спасибо за помощь! Сильно не ругайте.
К сообщению приложен файл: _Microsoft_Exce.xlsx(14.7 Kb)
 
Ответить
СообщениеДоброе утро! Помогите с формулой, как правильно это сделать?
В ячейке D1 есть список(варианты в списке обозначаются так: A.:(описание),B.:(описание),C.:(описание),D.:(описание),E.:(описание)), в ячейке E1 второй список, варианты обозначаются так: 1.:(описание),2.:(описание),3.:(описание),4.:(описание),5.:(описание).
И нужно сделать чтобы в ячейке F3 была формула, которая бы выводила определенный текст в зависимости от вариантов в ячейках D1 и E1.
Если получилось из двух ячеек вариант А1,А2,А3,А4,А5, В1,В2,В3,В4, С1,С2,С3, D1,D2,Е1 , тогда выводить слово "Существенный", если В5, С4,С5,D3,D4,D5,Е2,Е3,Е4,Е5 - то выводить "Несущественный"

Файл приложил к письму. Большое спасибо за помощь! Сильно не ругайте.

Автор - smokedi
Дата добавления - 10.04.2019 в 09:39
WildGodlike Дата: Среда, 10.04.2019, 09:59 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
smokedi,Как то так :D но работает ))))
Код
=ЕСЛИ(ИЛИ(СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C1;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C2;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C3;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C4;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C5;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C6;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C7;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C8;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C9;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C10);"Несущественный";"Существенный")
К сообщению приложен файл: -Microsoft_Exce.xlsx(15.5 Kb)
 
Ответить
Сообщениеsmokedi,Как то так :D но работает ))))
Код
=ЕСЛИ(ИЛИ(СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C1;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C2;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C3;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C4;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C5;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C6;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C7;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C8;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C9;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C10);"Несущественный";"Существенный")

Автор - WildGodlike
Дата добавления - 10.04.2019 в 09:59
_Boroda_ Дата: Среда, 10.04.2019, 10:14 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14864
Репутация: 5881 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант. Тоже работает :)
Код
=ЕСЛИ(КОДСИМВ(D2)+ЛЕВБ(E2)>70;"Не с";"С")&"ущественный"
Внизу таблица для пояснения логики

Или так
Код
=КОДСИМВ(D2)+ЛЕВБ(E2)-71
И формат ячейки"Не существенный";"Существенный"

* Любопытно, ввел формулу
Код
=КОДСИМВ(D2)+ЛЕВБ(E2)
И формат ячейки[>70]"Не существенный";"Существенный" - рухнул Excel
К сообщению приложен файл: 81627878_1.xlsx(15.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант. Тоже работает :)
Код
=ЕСЛИ(КОДСИМВ(D2)+ЛЕВБ(E2)>70;"Не с";"С")&"ущественный"
Внизу таблица для пояснения логики

Или так
Код
=КОДСИМВ(D2)+ЛЕВБ(E2)-71
И формат ячейки"Не существенный";"Существенный"

* Любопытно, ввел формулу
Код
=КОДСИМВ(D2)+ЛЕВБ(E2)
И формат ячейки[>70]"Не существенный";"Существенный" - рухнул Excel

Автор - _Boroda_
Дата добавления - 10.04.2019 в 10:14
smokedi Дата: Среда, 10.04.2019, 11:22 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
WildGodlike, огромное спасибо! очень помог! Все работает, единственное как-то можно сделать чтобы если в Ячейках D и E нет информации(допустим удалил вручную), то в ячейках F столба было пусто или писал: "Заполните такие-то ячейки"?
 
Ответить
СообщениеWildGodlike, огромное спасибо! очень помог! Все работает, единственное как-то можно сделать чтобы если в Ячейках D и E нет информации(допустим удалил вручную), то в ячейках F столба было пусто или писал: "Заполните такие-то ячейки"?

Автор - smokedi
Дата добавления - 10.04.2019 в 11:22
WildGodlike Дата: Среда, 10.04.2019, 14:13 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
smokedi,
Код
=ЕСЛИ(ИЛИ([[Вероятность ]]="";[Тяжесть]="");"";ЕСЛИ(ИЛИ(СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C1;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C2;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C3;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C4;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C5;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C6;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C7;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C8;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C9;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C10);"Несущественный";"Существенный"))


=ЕСЛИ(ИЛИ([[Вероятность ]]="";[Тяжесть]="");"";

Если нужен текст вот сюда в формуле между кавычками напишите всё что хотите.

_Boroda_, кроме как..."А чё так можно было?????? О_О" эмоций не возникает при виде такого варианта....шок.


Сообщение отредактировал WildGodlike - Среда, 10.04.2019, 15:19
 
Ответить
Сообщениеsmokedi,
Код
=ЕСЛИ(ИЛИ([[Вероятность ]]="";[Тяжесть]="");"";ЕСЛИ(ИЛИ(СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C1;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C2;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C3;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C4;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C5;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C6;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C7;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C8;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C9;СЦЕПИТЬ(ЛЕВСИМВ([[Вероятность ]];1);ЛЕВСИМВ([Тяжесть];1))=Лист2!C10);"Несущественный";"Существенный"))


=ЕСЛИ(ИЛИ([[Вероятность ]]="";[Тяжесть]="");"";

Если нужен текст вот сюда в формуле между кавычками напишите всё что хотите.

_Boroda_, кроме как..."А чё так можно было?????? О_О" эмоций не возникает при виде такого варианта....шок.

Автор - WildGodlike
Дата добавления - 10.04.2019 в 14:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сделать зависимость одной ячейки от двух со списком (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!