Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет количества уникальных значений на разных листах - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества уникальных значений на разных листах (Формулы/Formulas)
Подсчет количества уникальных значений на разных листах
Gusman Дата: Суббота, 13.04.2019, 14:30 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!

Прошу помочь мне в решении проблемы:

1) Есть 3 листа (Лист 1, Лист 2, Лист 3)

2) В ячейках каждого листа в полях A2-A5 есть текст, а также пустые поля (например, Текст 1, Текст 2, пусто, Текст 3)

- Как создать формулу, которая подсчитывает количество уникальных только текстовых значений по всех листах (Лист 1, Лист 2, Лист 3) по ячейкам A2-A5?

- Количество одинаковых текстовых значений в ячейках A2-A5 на Листе 1 и Листе 2?

Блогадарю за ответ
 
Ответить
СообщениеДобрый день!

Прошу помочь мне в решении проблемы:

1) Есть 3 листа (Лист 1, Лист 2, Лист 3)

2) В ячейках каждого листа в полях A2-A5 есть текст, а также пустые поля (например, Текст 1, Текст 2, пусто, Текст 3)

- Как создать формулу, которая подсчитывает количество уникальных только текстовых значений по всех листах (Лист 1, Лист 2, Лист 3) по ячейкам A2-A5?

- Количество одинаковых текстовых значений в ячейках A2-A5 на Листе 1 и Листе 2?

Блогадарю за ответ

Автор - Gusman
Дата добавления - 13.04.2019 в 14:30
Nic70y Дата: Суббота, 13.04.2019, 17:15 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5429
Репутация: 1183 ±
Замечаний: 0% ±

ru13;10;03
Файл нам самим рисовать?
[p.s.]У Вас что-то с Энтером...[/p.s.]


ЯД(poison) 41001841029809
 
Ответить
СообщениеФайл нам самим рисовать?
[p.s.]У Вас что-то с Энтером...[/p.s.]

Автор - Nic70y
Дата добавления - 13.04.2019 в 17:15
Gusman Дата: Суббота, 13.04.2019, 17:31 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
А можно как то здесь сформировать эксель, а то нет доступа к экселю?

Прикладываю подобие того, что нужно.
К сообщению приложен файл: 8499493.png(60.9 Kb)
 
Ответить
СообщениеА можно как то здесь сформировать эксель, а то нет доступа к экселю?

Прикладываю подобие того, что нужно.

Автор - Gusman
Дата добавления - 13.04.2019 в 17:31
Nic70y Дата: Суббота, 13.04.2019, 17:32 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 5429
Репутация: 1183 ±
Замечаний: 0% ±

ru13;10;03
а то нет доступа к экселю
нет доступа - нет ответа - все просто.
зачем ответ, если нет доступа?


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Суббота, 13.04.2019, 17:32
 
Ответить
Сообщение
а то нет доступа к экселю
нет доступа - нет ответа - все просто.
зачем ответ, если нет доступа?

Автор - Nic70y
Дата добавления - 13.04.2019 в 17:32
Gusman Дата: Суббота, 13.04.2019, 17:41 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
На Маке нет Эксель, сформировал с использованием онлайн версии. Так пойдет?

Принцип наверное схожий с моим вопросом.

Прошу помочь по возможности
К сообщению приложен файл: 7553910.xlsx(4.3 Kb)
 
Ответить
СообщениеНа Маке нет Эксель, сформировал с использованием онлайн версии. Так пойдет?

Принцип наверное схожий с моим вопросом.

Прошу помочь по возможности

Автор - Gusman
Дата добавления - 13.04.2019 в 17:41
_Boroda_ Дата: Суббота, 13.04.2019, 17:51 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15417
Репутация: 6032 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ(1/СЧЁТЕСЛИ(A6:H6;A6:H6&""))-(СЧЁТЗ(A6:H6)<>8)


Не совсем ясно причем здесь листы
К сообщению приложен файл: 7553910_1.xlsx(9.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ(1/СЧЁТЕСЛИ(A6:H6;A6:H6&""))-(СЧЁТЗ(A6:H6)<>8)


Не совсем ясно причем здесь листы

Автор - _Boroda_
Дата добавления - 13.04.2019 в 17:51
Nic70y Дата: Суббота, 13.04.2019, 17:55 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 5429
Репутация: 1183 ±
Замечаний: 0% ±

ru13;10;03
по всех листах

в примере только один лист.
вариант - формула массива:
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$1:H$15;ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(A$6:H$15<>"";СТРОКА(A$6:H$15)/100+СТОЛБЕЦ(A$6:H$15));СТРОКА(I1));1)*100;);НАИМЕНЬШИЙ(ЕСЛИ(A$6:H$15<>"";СТОЛБЕЦ(A$6:H$15));СТРОКА(I1)));"")


АпДэйт - походу не правильно понял, ну ладно вдруг для чего нибудь пригодиться.
К сообщению приложен файл: 0397272.xlsx(11.0 Kb)


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Суббота, 13.04.2019, 17:57
 
Ответить
Сообщение
по всех листах

в примере только один лист.
вариант - формула массива:
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$1:H$15;ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(A$6:H$15<>"";СТРОКА(A$6:H$15)/100+СТОЛБЕЦ(A$6:H$15));СТРОКА(I1));1)*100;);НАИМЕНЬШИЙ(ЕСЛИ(A$6:H$15<>"";СТОЛБЕЦ(A$6:H$15));СТРОКА(I1)));"")


АпДэйт - походу не правильно понял, ну ладно вдруг для чего нибудь пригодиться.

Автор - Nic70y
Дата добавления - 13.04.2019 в 17:55
Gusman Дата: Суббота, 13.04.2019, 17:59 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Благодарю, но надо не по отдельному столбцу, а по массиву A6:H15.

Итог - одно число в ячейке I6

Т.е. по сути убрать все повторения из массива и вывести итог.

Это данные на разных листах, я их собрал на одном листе в данном случае.


Сообщение отредактировал Gusman - Суббота, 13.04.2019, 18:03
 
Ответить
СообщениеБлагодарю, но надо не по отдельному столбцу, а по массиву A6:H15.

Итог - одно число в ячейке I6

Т.е. по сути убрать все повторения из массива и вывести итог.

Это данные на разных листах, я их собрал на одном листе в данном случае.

Автор - Gusman
Дата добавления - 13.04.2019 в 17:59
_Boroda_ Дата: Суббота, 13.04.2019, 18:04 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15417
Репутация: 6032 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Тогда еще проще
Код
=СУММПРОИЗВ(1/СЧЁТЕСЛИ(A6:H16;A6:H16&""))-1

Обратите внимание, что в формуле не 15, а 16 - мы сознательно захватываем пустые ячейки, чтобы не проверять их наличие в диапазоне


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТогда еще проще
Код
=СУММПРОИЗВ(1/СЧЁТЕСЛИ(A6:H16;A6:H16&""))-1

Обратите внимание, что в формуле не 15, а 16 - мы сознательно захватываем пустые ячейки, чтобы не проверять их наличие в диапазоне

Автор - _Boroda_
Дата добавления - 13.04.2019 в 18:04
Gusman Дата: Суббота, 13.04.2019, 18:15 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Благодарю, именно это и нужно было. Для минимальных вариантов реализации мне это хватит.

Если еще получится это сделать для разных листов (чтобы не копировать данные в один лист, файл приложил) буду благодарен.

Если трудоемко, то спасибо и на этом.
К сообщению приложен файл: NEW-1.xlsx(15.3 Kb)


Сообщение отредактировал Gusman - Суббота, 13.04.2019, 18:16
 
Ответить
СообщениеБлагодарю, именно это и нужно было. Для минимальных вариантов реализации мне это хватит.

Если еще получится это сделать для разных листов (чтобы не копировать данные в один лист, файл приложил) буду благодарен.

Если трудоемко, то спасибо и на этом.

Автор - Gusman
Дата добавления - 13.04.2019 в 18:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества уникальных значений на разных листах (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!