Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывести нижнюю строку из двух листов, там где числа >0 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести нижнюю строку из двух листов, там где числа >0 (Формулы/Formulas)
Вывести нижнюю строку из двух листов, там где числа >0
stalber Дата: Вторник, 30.04.2019, 16:11 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 260
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
День добрый, подскажите пожалуйста формулу.

Имеется такая формула:
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(Лист1!$D$2:$D$9999>0)/(Лист1!$E$2:$E$9999>0)/(Лист1!$F$2:$F$9999>0);Лист1!D2:D9999);"")

Данная формула, выводит нижние числа из Лист1 если вся нижняя строка имеет число больше 0, если одно из чисел имеет 0 то формула берёт выше данные, там где все заполнены числа и они больше нуля.

Эту формулу необходимо отредактировать, нужно добавить в неё дополнительное условие:
Формула сначала смотрит нижнюю строку в Лист1, если она заполнена, то берёт её, если там обнаруживает 0, то обращается к Лист2 к такой же строке, если там заполнена то выводит, если там обнаруживает 0, смотрит выше данные в Лист1 и так поочерёдно ищет заполненную нижнюю строку из двух листов.

То есть формуле необходимо смотреть нижнюю строку в ДВУХ листах, и там где заполнены числа больше 0, ту строку и вывести.

Я заполняю данные поочерёдно, сначала Лист1 затем Лист2, если в Лист1 все числа >0 то формула их выводит, затем заполняю Лист2 если и там все >0 то тогда эти числа выводит.
К сообщению приложен файл: vopros_30042019.xlsx(10.5 Kb)


Сообщение отредактировал stalber - Вторник, 30.04.2019, 16:12
 
Ответить
СообщениеДень добрый, подскажите пожалуйста формулу.

Имеется такая формула:
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(Лист1!$D$2:$D$9999>0)/(Лист1!$E$2:$E$9999>0)/(Лист1!$F$2:$F$9999>0);Лист1!D2:D9999);"")

Данная формула, выводит нижние числа из Лист1 если вся нижняя строка имеет число больше 0, если одно из чисел имеет 0 то формула берёт выше данные, там где все заполнены числа и они больше нуля.

Эту формулу необходимо отредактировать, нужно добавить в неё дополнительное условие:
Формула сначала смотрит нижнюю строку в Лист1, если она заполнена, то берёт её, если там обнаруживает 0, то обращается к Лист2 к такой же строке, если там заполнена то выводит, если там обнаруживает 0, смотрит выше данные в Лист1 и так поочерёдно ищет заполненную нижнюю строку из двух листов.

То есть формуле необходимо смотреть нижнюю строку в ДВУХ листах, и там где заполнены числа больше 0, ту строку и вывести.

Я заполняю данные поочерёдно, сначала Лист1 затем Лист2, если в Лист1 все числа >0 то формула их выводит, затем заполняю Лист2 если и там все >0 то тогда эти числа выводит.

Автор - stalber
Дата добавления - 30.04.2019 в 16:11
Karataev Дата: Вторник, 30.04.2019, 22:48 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1326
Репутация: 524 ±
Замечаний: 0% ±

Excel
Может быть будет достаточно макроса (не знаю, как сделать формулой).


Киви-кошелек: 9166309108
Яндекс-деньги: 410014131888288
 
Ответить
СообщениеМожет быть будет достаточно макроса (не знаю, как сделать формулой).

Автор - Karataev
Дата добавления - 30.04.2019 в 22:48
stalber Дата: Четверг, 02.05.2019, 12:37 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 260
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Может быть будет достаточно макроса (не знаю, как сделать формулой).

Спасибо за помощь.

Тему подниму всё таки, хотелось бы формулу получить, помогите пожалуйста.
 
Ответить
Сообщение
Может быть будет достаточно макроса (не знаю, как сделать формулой).

Спасибо за помощь.

Тему подниму всё таки, хотелось бы формулу получить, помогите пожалуйста.

Автор - stalber
Дата добавления - 02.05.2019 в 12:37
Pelena Дата: Четверг, 02.05.2019, 14:08 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14022
Репутация: 3069 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Так подойдёт?
Код
=ЕСЛИОШИБКА(ЕСЛИ(ПРОСМОТР(;-1/(Лист1!$D$2:$D$9999>0)/(Лист1!$E$2:$E$9999>0)/(Лист1!$F$2:$F$9999>0);СТРОКА(Лист1!$D$2:$D$9999))>ПРОСМОТР(;-1/(Лист2!$D$2:$D$9999>0)/(Лист2!$E$2:$E$9999>0)/(Лист2!$F$2:$F$9999>0);СТРОКА(Лист2!$D$2:$D$9999));ПРОСМОТР(;-1/(Лист1!$D$2:$D$9999>0)/(Лист1!$E$2:$E$9999>0)/(Лист1!$F$2:$F$9999>0);Лист1!D2:D9999);ПРОСМОТР(;-1/(Лист2!$D$2:$D$9999>0)/(Лист2!$E$2:$E$9999>0)/(Лист2!$F$2:$F$9999>0);Лист2!D2:D9999));"")
К сообщению приложен файл: 6301599.xlsx(11.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТак подойдёт?
Код
=ЕСЛИОШИБКА(ЕСЛИ(ПРОСМОТР(;-1/(Лист1!$D$2:$D$9999>0)/(Лист1!$E$2:$E$9999>0)/(Лист1!$F$2:$F$9999>0);СТРОКА(Лист1!$D$2:$D$9999))>ПРОСМОТР(;-1/(Лист2!$D$2:$D$9999>0)/(Лист2!$E$2:$E$9999>0)/(Лист2!$F$2:$F$9999>0);СТРОКА(Лист2!$D$2:$D$9999));ПРОСМОТР(;-1/(Лист1!$D$2:$D$9999>0)/(Лист1!$E$2:$E$9999>0)/(Лист1!$F$2:$F$9999>0);Лист1!D2:D9999);ПРОСМОТР(;-1/(Лист2!$D$2:$D$9999>0)/(Лист2!$E$2:$E$9999>0)/(Лист2!$F$2:$F$9999>0);Лист2!D2:D9999));"")

Автор - Pelena
Дата добавления - 02.05.2019 в 14:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести нижнюю строку из двух листов, там где числа >0 (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!