Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенести данные и формулу с сохранением работоспособности - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенести данные и формулу с сохранением работоспособности (Формулы/Formulas)
Перенести данные и формулу с сохранением работоспособности
Kaktus8 Дата: Воскресенье, 05.05.2019, 00:48 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 65
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Уважаемые знатоки Excel-a!
Помогите, пожалуйста, поправить формулу, которая работает в левой части таблицы (слева от красного столбца), а в правой части этой же таблицы - не хочет.
Файл прилагаю. Слева от красного столбца работает, а справа - нет.
Как сделать её рабочей?
Формулы такие:
Код
=НАИМЕНЬШИЙ(ЧАСТОТА(МУМНОЖ(--A$2:K$3096;10^ТРАНСП(СТОЛБЕЦ(A$1:K$1)));МУМНОЖ(--A$2:K$3096;10^ТРАНСП(СТОЛБЕЦ(A$1:K$1))));ЧСТРОК(A$1:A$3097)-СТРОКА())


Код
=ЕСЛИ($L2;ИНДЕКС(A:A;ОСТАТ(НАИМЕНЬШИЙ(ЧАСТОТА(МУМНОЖ(--$A$2:$K$3096;10^ТРАНСП(СТОЛБЕЦ($A$1:$K$1)));МУМНОЖ(--$A$2:$K$3096;10^ТРАНСП(СТОЛБЕЦ($A$1:$K$1))))+СТРОКА(A$2:A$3097)%%;ЧСТРОК(A$1:A$3097)-СТРОКА());1)/1%%);)
К сообщению приложен файл: 3-1a_4_2.xlsx(33.5 Kb)
 
Ответить
СообщениеУважаемые знатоки Excel-a!
Помогите, пожалуйста, поправить формулу, которая работает в левой части таблицы (слева от красного столбца), а в правой части этой же таблицы - не хочет.
Файл прилагаю. Слева от красного столбца работает, а справа - нет.
Как сделать её рабочей?
Формулы такие:
Код
=НАИМЕНЬШИЙ(ЧАСТОТА(МУМНОЖ(--A$2:K$3096;10^ТРАНСП(СТОЛБЕЦ(A$1:K$1)));МУМНОЖ(--A$2:K$3096;10^ТРАНСП(СТОЛБЕЦ(A$1:K$1))));ЧСТРОК(A$1:A$3097)-СТРОКА())


Код
=ЕСЛИ($L2;ИНДЕКС(A:A;ОСТАТ(НАИМЕНЬШИЙ(ЧАСТОТА(МУМНОЖ(--$A$2:$K$3096;10^ТРАНСП(СТОЛБЕЦ($A$1:$K$1)));МУМНОЖ(--$A$2:$K$3096;10^ТРАНСП(СТОЛБЕЦ($A$1:$K$1))))+СТРОКА(A$2:A$3097)%%;ЧСТРОК(A$1:A$3097)-СТРОКА());1)/1%%);)

Автор - Kaktus8
Дата добавления - 05.05.2019 в 00:48
bmv98rus Дата: Воскресенье, 05.05.2019, 08:39 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 2470
Репутация: 426 ±
Замечаний: 0% ±

Excel 2013/2016
Kaktus8, Вы пробовали разобраться в формуле?
Это часть
Код
=TRANSPOSE(COLUMN(A$1:K$1))
должна остаться такой же и во второй ибо это
Код
=10^TRANSPOSE(COLUMN(NTX$1:NUH$1))

ну очень большие числа 10^10008..... А самое компактное и менее затратное , при неизменной ширине таблицы заменить это на
Код
=10^ROW($A$1:$A$11)
или
Код
=10^{1;2;3;4;5;6;7;8;9;10;11}
. все автоматом массивным становится и не требует трех кнопок при вводе.


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Воскресенье, 05.05.2019, 09:46
 
Ответить
СообщениеKaktus8, Вы пробовали разобраться в формуле?
Это часть
Код
=TRANSPOSE(COLUMN(A$1:K$1))
должна остаться такой же и во второй ибо это
Код
=10^TRANSPOSE(COLUMN(NTX$1:NUH$1))

ну очень большие числа 10^10008..... А самое компактное и менее затратное , при неизменной ширине таблицы заменить это на
Код
=10^ROW($A$1:$A$11)
или
Код
=10^{1;2;3;4;5;6;7;8;9;10;11}
. все автоматом массивным становится и не требует трех кнопок при вводе.

Автор - bmv98rus
Дата добавления - 05.05.2019 в 08:39
Pelena Дата: Воскресенье, 05.05.2019, 08:52 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 14329
Репутация: 3132 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Так подойдёт?
К сообщению приложен файл: 0922278.xlsx(33.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТак подойдёт?

Автор - Pelena
Дата добавления - 05.05.2019 в 08:52
Kaktus8 Дата: Воскресенье, 05.05.2019, 17:01 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 65
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
bmv98rus,
Большое спасибо за подсказки!

Вы пробовали разобраться в формуле?

Я совсем новичок и мне пока ещё очень тяжело даются большие формулы :(
То, что ошибка возникает из-за слишком больших чисел, я понял. А вот то, что указанную Вами часть формулы можно оставить без изменений, - не догадался.
%)

Так подойдёт?

Да!
Большущее спасибо за работоспособный пример!
yes
 
Ответить
Сообщениеbmv98rus,
Большое спасибо за подсказки!

Вы пробовали разобраться в формуле?

Я совсем новичок и мне пока ещё очень тяжело даются большие формулы :(
То, что ошибка возникает из-за слишком больших чисел, я понял. А вот то, что указанную Вами часть формулы можно оставить без изменений, - не догадался.
%)

Так подойдёт?

Да!
Большущее спасибо за работоспособный пример!
yes

Автор - Kaktus8
Дата добавления - 05.05.2019 в 17:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенести данные и формулу с сохранением работоспособности (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!