Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/выполнить динамическую сортировку с двумя условиями - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выполнить динамическую сортировку с двумя условиями (Формулы/Formulas)
выполнить динамическую сортировку с двумя условиями
akocherovskiy Дата: Вторник, 07.05.2019, 15:38 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Требуется выполнить сортировку из массива с двумя условиями. Таблица динамическая.
К сообщению приложен файл: ___2_.xlsx(9.0 Kb)
 
Ответить
СообщениеТребуется выполнить сортировку из массива с двумя условиями. Таблица динамическая.

Автор - akocherovskiy
Дата добавления - 07.05.2019 в 15:38
Che79 Дата: Вторник, 07.05.2019, 15:49 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1323
Репутация: 238 ±
Замечаний: 0% ±

Excel 2013, 365
И Вам здравствуйте! так нужно?
Код
=ИНДЕКС($A$2:$A$1000;ПОИСКПОЗ(E2&F2;$C$2:$C$1000&$B$2:$B$1000;))
формула массива (ввод Кнтрл+Шифт + Энтер) + в файле вариант сводной таблицей
К сообщению приложен файл: _2_1.xlsx(14.6 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеИ Вам здравствуйте! так нужно?
Код
=ИНДЕКС($A$2:$A$1000;ПОИСКПОЗ(E2&F2;$C$2:$C$1000&$B$2:$B$1000;))
формула массива (ввод Кнтрл+Шифт + Энтер) + в файле вариант сводной таблицей

Автор - Che79
Дата добавления - 07.05.2019 в 15:49
akocherovskiy Дата: Вторник, 07.05.2019, 15:58 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
И Вам здравствуйте! так нужно?

=ИНДЕКС($A$2:$A$1000;ПОИСКПОЗ(E2&F2;$C$2:$C$1000&$B$2:$B$1000;))
формула массива (ввод Кнтрл+Шифт + Энтер) + в файле вариант сводной таблицей


Спасибо. Близко, но не совсем. Можно ли сделать, чтобы по одной комбинации условий выводились только уникальные бортовые номер (без повторений)?
На примере 14го участка: сейчас там только 205-ая машина, а можно ли сделать, чтобы заполненными оказались только три строки с номерами машин: 205, 208, 209?
Сводная точно не подходит.
 
Ответить
Сообщение
И Вам здравствуйте! так нужно?

=ИНДЕКС($A$2:$A$1000;ПОИСКПОЗ(E2&F2;$C$2:$C$1000&$B$2:$B$1000;))
формула массива (ввод Кнтрл+Шифт + Энтер) + в файле вариант сводной таблицей


Спасибо. Близко, но не совсем. Можно ли сделать, чтобы по одной комбинации условий выводились только уникальные бортовые номер (без повторений)?
На примере 14го участка: сейчас там только 205-ая машина, а можно ли сделать, чтобы заполненными оказались только три строки с номерами машин: 205, 208, 209?
Сводная точно не подходит.

Автор - akocherovskiy
Дата добавления - 07.05.2019 в 15:58
Pelena Дата: Вторник, 07.05.2019, 17:19 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14022
Репутация: 3069 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
akocherovskiy, не надо цитировать пост целиком, это нарушение Правил форума. Исправьте.

Цитата akocherovskiy, 07.05.2019 в 15:58, в сообщении № 3 ()
Сводная точно не подходит
Почему? Это самый быстрый вариант


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеakocherovskiy, не надо цитировать пост целиком, это нарушение Правил форума. Исправьте.

Цитата akocherovskiy, 07.05.2019 в 15:58, в сообщении № 3 ()
Сводная точно не подходит
Почему? Это самый быстрый вариант

Автор - Pelena
Дата добавления - 07.05.2019 в 17:19
jakim Дата: Вторник, 07.05.2019, 17:53 | Сообщение № 5
Группа: Друзья
Ранг: Ветеран
Сообщений: 895
Репутация: 232 ±
Замечаний: 0% ±

Excel 2010
Вариант с функцией АГРЕГАТ.
К сообщению приложен файл: 2-1.xlsx(9.9 Kb)
 
Ответить
Сообщение
Вариант с функцией АГРЕГАТ.

Автор - jakim
Дата добавления - 07.05.2019 в 17:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выполнить динамическую сортировку с двумя условиями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!