Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск списка в списке с частичным вхождением / в Excel - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск списка в списке с частичным вхождением / в Excel (Формулы/Formulas)
Поиск списка в списке с частичным вхождением / в Excel
ZaharZZ Дата: Вторник, 11.06.2019, 10:44 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день! Помогите построить формулу.

Есть список значений № 1:
истина а
правда
дерево
валера
камень
знак

Есть список значений № 2:
истина
камень
дерево

Необходимо, чтоб в списке № 1 искался список № 2 даже если значение из списка № 2 входит частично. Пробовал формулу:
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(A1;$E$1:$E$70;0));A1;0)

Но с этой формулой Эксель не находит "истина" из второго списка значение "истина а" в списке № 1

Помогите разобраться :)

Файл пример прилагаю:
К сообщению приложен файл: 3905149.xlsx(3.9 Kb)


Сообщение отредактировал ZaharZZ - Вторник, 11.06.2019, 11:35
 
Ответить
СообщениеДобрый день! Помогите построить формулу.

Есть список значений № 1:
истина а
правда
дерево
валера
камень
знак

Есть список значений № 2:
истина
камень
дерево

Необходимо, чтоб в списке № 1 искался список № 2 даже если значение из списка № 2 входит частично. Пробовал формулу:
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(A1;$E$1:$E$70;0));A1;0)

Но с этой формулой Эксель не находит "истина" из второго списка значение "истина а" в списке № 1

Помогите разобраться :)

Файл пример прилагаю:

Автор - ZaharZZ
Дата добавления - 11.06.2019 в 10:44
китин Дата: Вторник, 11.06.2019, 10:48 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5828
Репутация: 907 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ZaharZZ, оформите ваш пост в соответствие с п.3 Правил форума в части тэгов. пояснялка здесь

и приложите файл-пример


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеZaharZZ, оформите ваш пост в соответствие с п.3 Правил форума в части тэгов. пояснялка здесь

и приложите файл-пример

Автор - китин
Дата добавления - 11.06.2019 в 10:48
ZaharZZ Дата: Среда, 19.06.2019, 10:56 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
неужели никто не знает...
 
Ответить
Сообщениенеужели никто не знает...

Автор - ZaharZZ
Дата добавления - 19.06.2019 в 10:56
sboy Дата: Среда, 19.06.2019, 11:17 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2566
Репутация: 722 ±
Замечаний: 0% ±

Excel 2010
Знают многие, но Вы не устранили замечание модератора (а теперь уже и не сможете). Ждем решения модераторов форума


Яндекс: 410016850021169
 
Ответить
СообщениеЗнают многие, но Вы не устранили замечание модератора (а теперь уже и не сможете). Ждем решения модераторов форума

Автор - sboy
Дата добавления - 19.06.2019 в 11:17
китин Дата: Среда, 19.06.2019, 11:29 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 5828
Репутация: 907 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Прошло больше суток ТС исправить не может. исправил сам


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеПрошло больше суток ТС исправить не может. исправил сам

Автор - китин
Дата добавления - 19.06.2019 в 11:29
_Boroda_ Дата: Среда, 19.06.2019, 11:30 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15576
Репутация: 6077 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Все знают. Но на этом форуме не отвечают на вопросы, заданные с нарушением Правил форума или с неисправленными замечаниями модератора
Вы Правила форума прочитали? Пункт 3 Правил Вам понятен?
Нужно было оформить формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)
Сейчас уже сутки прошли, Вам правка первого поста недоступна. Поправил за Вас (не, пока писал, Игорь уже поправил), но в следующий раз сразу делайте


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВсе знают. Но на этом форуме не отвечают на вопросы, заданные с нарушением Правил форума или с неисправленными замечаниями модератора
Вы Правила форума прочитали? Пункт 3 Правил Вам понятен?
Нужно было оформить формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)
Сейчас уже сутки прошли, Вам правка первого поста недоступна. Поправил за Вас (не, пока писал, Игорь уже поправил), но в следующий раз сразу делайте

Автор - _Boroda_
Дата добавления - 19.06.2019 в 11:30
Nic70y Дата: Среда, 19.06.2019, 11:34 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 5601
Репутация: 1224 ±
Замечаний: 0% ±

ru13;10;03
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(ЛЕВБ(A1;ПОИСК(" ";A1&" ")-1);$E$1:$E$70;0));A1;0)
вдруг правильно


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(ЛЕВБ(A1;ПОИСК(" ";A1&" ")-1);$E$1:$E$70;0));A1;0)
вдруг правильно

Автор - Nic70y
Дата добавления - 19.06.2019 в 11:34
sboy Дата: Среда, 19.06.2019, 11:35 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2566
Репутация: 722 ±
Замечаний: 0% ±

Excel 2010
вдруг правильно

Код
=ЕСЛИ(СУММ(--ЕЧИСЛО(ПОИСК($E$1:$E$3;A1)));;A1)
К сообщению приложен файл: 8930524.xlsx(8.5 Kb)


Яндекс: 410016850021169
 
Ответить
Сообщение
вдруг правильно

Код
=ЕСЛИ(СУММ(--ЕЧИСЛО(ПОИСК($E$1:$E$3;A1)));;A1)

Автор - sboy
Дата добавления - 19.06.2019 в 11:35
_Boroda_ Дата: Среда, 19.06.2019, 11:39 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15576
Репутация: 6077 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вдруг
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/(ПОИСК(E$1:E$9;"    "&A1)>1))-1;A1)
К сообщению приложен файл: 14_5.xlsm(9.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вдруг
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/(ПОИСК(E$1:E$9;"    "&A1)>1))-1;A1)

Автор - _Boroda_
Дата добавления - 19.06.2019 в 11:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск списка в списке с частичным вхождением / в Excel (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!