Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Если те же ФИО есть на другом листе то значение - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если те же ФИО есть на другом листе то значение (Формулы/Formulas)
Если те же ФИО есть на другом листе то значение
Leem Дата: Суббота, 22.06.2019, 23:14 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доброго дня, друзья.
Суть "задачи" вроде бы проста. но я не додумался как ее решить и прошу помощи.

На одном листе находится МЕСЯЧНЫЙ ГРАФИК
на остальных листах есть конкретная дата и список ФИО только тех работников, которые выходили на смену именно в эту дату.

Надо сверить список всех работников со списками по дням и в месячном графике напротив ФИО данного работника поставить значение ДЕНЬ той даты когда выходил этот работник
Я сделал файл для примера где красным шрифтом указал цифрами то что необходимо, но вместо цифр там должно быть ДЕНЬ из ячейки А1 соответствующеего дневного листа.
К сообщению приложен файл: If1.xlsx(9.6 Kb)


Ктулху всех спасет
 
Ответить
СообщениеДоброго дня, друзья.
Суть "задачи" вроде бы проста. но я не додумался как ее решить и прошу помощи.

На одном листе находится МЕСЯЧНЫЙ ГРАФИК
на остальных листах есть конкретная дата и список ФИО только тех работников, которые выходили на смену именно в эту дату.

Надо сверить список всех работников со списками по дням и в месячном графике напротив ФИО данного работника поставить значение ДЕНЬ той даты когда выходил этот работник
Я сделал файл для примера где красным шрифтом указал цифрами то что необходимо, но вместо цифр там должно быть ДЕНЬ из ячейки А1 соответствующеего дневного листа.

Автор - Leem
Дата добавления - 22.06.2019 в 23:14
gling Дата: Суббота, 22.06.2019, 23:48 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1952
Репутация: 485 ±
Замечаний: 0% ±

2010
Здравствуйте. Красный шрифт не нашел, может файл не тот? Но есть вариант, сделал как понял.
Код
=ЕСЛИ(СУММПРОИЗВ(СЧЁТЕСЛИ($A2;ДВССЫЛ("'"&ТЕКСТ(B$1;"ДД.ММ.ГГ")&"'!A1:A100")));"Выходил "&ТЕКСТ(B$1;"ДД.ММ.ГГГГ");"")
К сообщению приложен файл: 9419639.xlsx(11.7 Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Воскресенье, 23.06.2019, 00:03
 
Ответить
СообщениеЗдравствуйте. Красный шрифт не нашел, может файл не тот? Но есть вариант, сделал как понял.
Код
=ЕСЛИ(СУММПРОИЗВ(СЧЁТЕСЛИ($A2;ДВССЫЛ("'"&ТЕКСТ(B$1;"ДД.ММ.ГГ")&"'!A1:A100")));"Выходил "&ТЕКСТ(B$1;"ДД.ММ.ГГГГ");"")

Автор - gling
Дата добавления - 22.06.2019 в 23:48
Leem Дата: Воскресенье, 23.06.2019, 02:20 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
=ЕСЛИ(СУММПРОИЗВ(СЧЁТЕСЛИ($A2;ДВССЫЛ("'"&ТЕКСТ(B$1;"ДД.ММ.ГГ")&"'!A1:A100")));"Выходил "&ТЕКСТ(B$1;"ДД.ММ.ГГГГ");"")


Благодарю. Поиск происходит, но мне необходимо, чтобы вместо слов выходил и дд.мм.гггг в этих ячейках появлялось значение дня из дневного листа.

т.е. например в файле с вашим примером Петров и Сидоров выходили на работу 10.05.19 и на листе МЕСЯЧНЫЙ СПИСОК в ячейках B3 и B4 необходимо получить
день, взятый из листа 10.05.19 в ячейке А1.
Это возможно?


Ктулху всех спасет
 
Ответить
Сообщение
=ЕСЛИ(СУММПРОИЗВ(СЧЁТЕСЛИ($A2;ДВССЫЛ("'"&ТЕКСТ(B$1;"ДД.ММ.ГГ")&"'!A1:A100")));"Выходил "&ТЕКСТ(B$1;"ДД.ММ.ГГГГ");"")


Благодарю. Поиск происходит, но мне необходимо, чтобы вместо слов выходил и дд.мм.гггг в этих ячейках появлялось значение дня из дневного листа.

т.е. например в файле с вашим примером Петров и Сидоров выходили на работу 10.05.19 и на листе МЕСЯЧНЫЙ СПИСОК в ячейках B3 и B4 необходимо получить
день, взятый из листа 10.05.19 в ячейке А1.
Это возможно?

Автор - Leem
Дата добавления - 23.06.2019 в 02:20
gling Дата: Воскресенье, 23.06.2019, 06:58 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1952
Репутация: 485 ±
Замечаний: 0% ±

2010
день, взятый из листа 10.05.19 в ячейке А1.
Это возможно?
Если покажите как должно быть, то можно попробовать. В А1 на всех листах Дата, дата и есть день. Вам что нужно, чтобы прописался день недели или просто день без обозначения месяца и года, типа просто 10? Кроме того, у вас название листа совпадает с датой в ячейках А1, какая разница от куда брать дату из А1, из названия листа или из ячеек строки 1? Или в реальном файле не так?


ЯД-41001506838083

Сообщение отредактировал gling - Воскресенье, 23.06.2019, 06:59
 
Ответить
Сообщение
день, взятый из листа 10.05.19 в ячейке А1.
Это возможно?
Если покажите как должно быть, то можно попробовать. В А1 на всех листах Дата, дата и есть день. Вам что нужно, чтобы прописался день недели или просто день без обозначения месяца и года, типа просто 10? Кроме того, у вас название листа совпадает с датой в ячейках А1, какая разница от куда брать дату из А1, из названия листа или из ячеек строки 1? Или в реальном файле не так?

Автор - gling
Дата добавления - 23.06.2019 в 06:58
Leem Дата: Воскресенье, 23.06.2019, 07:26 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Если покажите как должно быть, то можно попробовать. В А1 на всех листах Дата, дата и есть день. Вам что нужно, чтобы прописался день недели или просто день без обозначения месяца и года, типа просто 10? Кроме того, у вас название листа совпадает с датой в ячейках А1, какая разница от куда брать дату из А1, из названия листа или из ячеек строки 1? Или в реальном файле не так?


Благодарю за помощь...

Просто день без обозначения месяца и года, типа просто 10. Но брать его необходимо именно из ячейки А1 того листа где нашелся этот работник.
Изменил первоначальный файл убрав одинаковые названия.
Во вложении
К сообщению приложен файл: 2405565.xlsx(9.7 Kb)


Ктулху всех спасет
 
Ответить
Сообщение
Если покажите как должно быть, то можно попробовать. В А1 на всех листах Дата, дата и есть день. Вам что нужно, чтобы прописался день недели или просто день без обозначения месяца и года, типа просто 10? Кроме того, у вас название листа совпадает с датой в ячейках А1, какая разница от куда брать дату из А1, из названия листа или из ячеек строки 1? Или в реальном файле не так?


Благодарю за помощь...

Просто день без обозначения месяца и года, типа просто 10. Но брать его необходимо именно из ячейки А1 того листа где нашелся этот работник.
Изменил первоначальный файл убрав одинаковые названия.
Во вложении

Автор - Leem
Дата добавления - 23.06.2019 в 07:26
Светлый Дата: Воскресенье, 23.06.2019, 09:28 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1147
Репутация: 292 ±
Замечаний: 0% ±

Excel 2010
Ещё больше запутали. Может быть так. Массивная:
Код
=ЕСЛИОШИБКА(ДЕНЬ(НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ(ДВССЫЛ("Цех"&СТОЛБЕЦ($A:$B)&"!A1:A9");$A2);Ч(ДВССЫЛ("Цех"&Ч(ИНДЕКС(СТОЛБЕЦ($A:$B);))&"!A1")));СТОЛБЕЦ(A2)));"")
К сообщению приложен файл: 2405565-1.xlsx(10.5 Kb)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеЕщё больше запутали. Может быть так. Массивная:
Код
=ЕСЛИОШИБКА(ДЕНЬ(НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ(ДВССЫЛ("Цех"&СТОЛБЕЦ($A:$B)&"!A1:A9");$A2);Ч(ДВССЫЛ("Цех"&Ч(ИНДЕКС(СТОЛБЕЦ($A:$B);))&"!A1")));СТОЛБЕЦ(A2)));"")

Автор - Светлый
Дата добавления - 23.06.2019 в 09:28
Leem Дата: Воскресенье, 23.06.2019, 09:48 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Цитата Светлый, 23.06.2019 в 09:28, в сообщении № 6 ()
Может быть так.

Точно так. С Рауткиным ошибка, он отображается не в том столбце, но именно то, что хотел.
Благодарю. yes


Ктулху всех спасет
 
Ответить
Сообщение
Цитата Светлый, 23.06.2019 в 09:28, в сообщении № 6 ()
Может быть так.

Точно так. С Рауткиным ошибка, он отображается не в том столбце, но именно то, что хотел.
Благодарю. yes

Автор - Leem
Дата добавления - 23.06.2019 в 09:48
gling Дата: Воскресенье, 23.06.2019, 22:45 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1952
Репутация: 485 ±
Замечаний: 0% ±

2010
Еще вариант.
Код
=ЕСЛИ(СУММПРОИЗВ(СЧЁТЕСЛИ($A2;ДВССЫЛ("'"&B$1&"'!A1:A100")));ДЕНЬ(ДВССЫЛ("'"&B$1&"'!A1"));"")
К сообщению приложен файл: 2030552.xlsx(10.5 Kb)


ЯД-41001506838083
 
Ответить
СообщениеЕще вариант.
Код
=ЕСЛИ(СУММПРОИЗВ(СЧЁТЕСЛИ($A2;ДВССЫЛ("'"&B$1&"'!A1:A100")));ДЕНЬ(ДВССЫЛ("'"&B$1&"'!A1"));"")

Автор - gling
Дата добавления - 23.06.2019 в 22:45
Leem Дата: Пятница, 28.06.2019, 08:37 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Еще вариант.

Благодарю. Я решил вашим первым вариантом, но попробую применить.

Можно еще вопрос в этой же теме по похожему случаю? Имеется 2 списка: 1-ый полный список работников и 2-й список работников на конкретном участке. 2-й список всегда меняется т.е. во второй список ежедневно попадают разные люди из первого списка.

Необходимо создать третий список из тех кого нет в первом списке.
Ну т.е.
1 (полный список):

Иванов А.А.
Петров Б.Б.
Сидоров С.С.
Кваснин У.К.
Шариков А.К.

2 (список)

Иванов А.А.
Шариков А.К.

Необходимо создать третий список с условием того, чтобы этих людей не было во втором

3 (список)
Петров Б.Б.
Сидоров С.С.
Кваснин У.К.

Это возможно?


Ктулху всех спасет
 
Ответить
Сообщение
Еще вариант.

Благодарю. Я решил вашим первым вариантом, но попробую применить.

Можно еще вопрос в этой же теме по похожему случаю? Имеется 2 списка: 1-ый полный список работников и 2-й список работников на конкретном участке. 2-й список всегда меняется т.е. во второй список ежедневно попадают разные люди из первого списка.

Необходимо создать третий список из тех кого нет в первом списке.
Ну т.е.
1 (полный список):

Иванов А.А.
Петров Б.Б.
Сидоров С.С.
Кваснин У.К.
Шариков А.К.

2 (список)

Иванов А.А.
Шариков А.К.

Необходимо создать третий список с условием того, чтобы этих людей не было во втором

3 (список)
Петров Б.Б.
Сидоров С.С.
Кваснин У.К.

Это возможно?

Автор - Leem
Дата добавления - 28.06.2019 в 08:37
китин Дата: Пятница, 28.06.2019, 09:16 | Сообщение № 10
Группа: Модераторы
Ранг: Экселист
Сообщений: 5659
Репутация: 896 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Leem,
- п.4 Правил форума: один вопрос - одна тема


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеLeem,
- п.4 Правил форума: один вопрос - одна тема

Автор - китин
Дата добавления - 28.06.2019 в 09:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если те же ФИО есть на другом листе то значение (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!