Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Три рандомных списка из общего с условиями - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Три рандомных списка из общего с условиями (Формулы/Formulas)
Три рандомных списка из общего с условиями
Leem Дата: Пятница, 28.06.2019, 11:59 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доброго дня, друзья.
Необходимо, используя генератор случайных чисел решить проблему:
Имеется ОБЩИЙ список рабочих: 30 чел.
Имеется список рабочих ЦЕХ (одновременно находящихся и в общем списке): 3 чел.
Необходимо из ОБЩЕГО списка тех, кого нет в списке рабочих ЦЕХ, сформировать три рандомных списка по 3 человека в каждом (3_1, 3_2, 3_3). (Обязательным условием является то, что если рабочий попал в список 3_1, то он не может попасть в списки 3_2 и 3_3) и соответственно тот, кто попал в списки 3_1, 3_2 не попадает в список 3_3)

Уважаемый Boroda помог в создании списка из отсутствующих, но я подумал, что, вдруг с этими условиями возможно другой алгоритм решения.
Благодарю.
К сообщению приложен файл: 3s.xlsx(12.7 Kb)


Ктулху всех спасет
 
Ответить
СообщениеДоброго дня, друзья.
Необходимо, используя генератор случайных чисел решить проблему:
Имеется ОБЩИЙ список рабочих: 30 чел.
Имеется список рабочих ЦЕХ (одновременно находящихся и в общем списке): 3 чел.
Необходимо из ОБЩЕГО списка тех, кого нет в списке рабочих ЦЕХ, сформировать три рандомных списка по 3 человека в каждом (3_1, 3_2, 3_3). (Обязательным условием является то, что если рабочий попал в список 3_1, то он не может попасть в списки 3_2 и 3_3) и соответственно тот, кто попал в списки 3_1, 3_2 не попадает в список 3_3)

Уважаемый Boroda помог в создании списка из отсутствующих, но я подумал, что, вдруг с этими условиями возможно другой алгоритм решения.
Благодарю.

Автор - Leem
Дата добавления - 28.06.2019 в 11:59
_Boroda_ Дата: Пятница, 28.06.2019, 12:07 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15401
Репутация: 6031 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
3 списка на одном листе в одном столбце
Код
=ЕСЛИОШИБКА(ИНДЕКС(Общий!A:A;НАИБОЛЬШИЙ(СТРОКА(Общий!A$1:A$99)^НЕ(СЧЁТЕСЛИ(A$1:A1;Общий!A$1:A$99&"")+СЧЁТЕСЛИ(ЦЕХ!A:A;Общий!A$1:A$99));СЛУЧМЕЖДУ(1;СЧЁТЗ(Общий!A:A)-СЧЁТЗ(ЦЕХ!A:A)-СЧЁТЗ(A$1:A1))));"")
К сообщению приложен файл: 3s_1.xlsx(13.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение3 списка на одном листе в одном столбце
Код
=ЕСЛИОШИБКА(ИНДЕКС(Общий!A:A;НАИБОЛЬШИЙ(СТРОКА(Общий!A$1:A$99)^НЕ(СЧЁТЕСЛИ(A$1:A1;Общий!A$1:A$99&"")+СЧЁТЕСЛИ(ЦЕХ!A:A;Общий!A$1:A$99));СЛУЧМЕЖДУ(1;СЧЁТЗ(Общий!A:A)-СЧЁТЗ(ЦЕХ!A:A)-СЧЁТЗ(A$1:A1))));"")

Автор - _Boroda_
Дата добавления - 28.06.2019 в 12:07
Leem Дата: Воскресенье, 30.06.2019, 08:02 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Друзья, hands


Ктулху всех спасет

Сообщение отредактировал Leem - Воскресенье, 30.06.2019, 08:19
 
Ответить
СообщениеДрузья, hands

Автор - Leem
Дата добавления - 30.06.2019 в 08:02
Leem Дата: Воскресенье, 30.06.2019, 08:59 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
=ЕСЛИОШИБКА(ИНДЕКС(Общий!A:A;НАИБОЛЬШИЙ(СТРОКА(Общий!A$1:A$99)^НЕ(СЧЁТЕСЛИ(A$1:A1;Общий!A$1:A$99&"")+СЧЁТЕСЛИ(ЦЕХ!A:A;Общий!A$1:A$99));СЛУЧМЕЖДУ(1;СЧЁТЗ(Общий!A:A)-СЧЁТЗ(ЦЕХ!A:A)-СЧЁТЗ(A$1:A1))));"")

Подскажите пожалуйста, какой диапазон входит в СЧЁТЕСЛИ(A$1:A1


Ктулху всех спасет
 
Ответить
Сообщение
=ЕСЛИОШИБКА(ИНДЕКС(Общий!A:A;НАИБОЛЬШИЙ(СТРОКА(Общий!A$1:A$99)^НЕ(СЧЁТЕСЛИ(A$1:A1;Общий!A$1:A$99&"")+СЧЁТЕСЛИ(ЦЕХ!A:A;Общий!A$1:A$99));СЛУЧМЕЖДУ(1;СЧЁТЗ(Общий!A:A)-СЧЁТЗ(ЦЕХ!A:A)-СЧЁТЗ(A$1:A1))));"")

Подскажите пожалуйста, какой диапазон входит в СЧЁТЕСЛИ(A$1:A1

Автор - Leem
Дата добавления - 30.06.2019 в 08:59
_Boroda_ Дата: Воскресенье, 30.06.2019, 17:36 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15401
Репутация: 6031 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
какой диапазон входит в СЧЁТЕСЛИ(A$1:A1

Это смотря в какой строке формула находится. Если в строке 2, то диапазон A$1:A1, а при протягивании формулы вниз диапазон тоже протягивается и увеличивается. Для формулы в строке 3 - A$1:A2, в строке 4 - A$1:A3, ...


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
какой диапазон входит в СЧЁТЕСЛИ(A$1:A1

Это смотря в какой строке формула находится. Если в строке 2, то диапазон A$1:A1, а при протягивании формулы вниз диапазон тоже протягивается и увеличивается. Для формулы в строке 3 - A$1:A2, в строке 4 - A$1:A3, ...

Автор - _Boroda_
Дата добавления - 30.06.2019 в 17:36
Leem Дата: Понедельник, 01.07.2019, 18:31 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
А как можно добить еще три списка на другом листе, чтобы соблюдались условия: в этих списках не повторялись фамилии из ЦЕХ и первых трех созданных ранее списков? Вроде бы должно быть просто, но я уже часа 2 бьюсь....


Ктулху всех спасет
 
Ответить
СообщениеА как можно добить еще три списка на другом листе, чтобы соблюдались условия: в этих списках не повторялись фамилии из ЦЕХ и первых трех созданных ранее списков? Вроде бы должно быть просто, но я уже часа 2 бьюсь....

Автор - Leem
Дата добавления - 01.07.2019 в 18:31
Leem Дата: Понедельник, 01.07.2019, 20:45 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Решил создать новый файл с условиями: Надеюсь пояснения в файле достаточны.
Благодарю, если кто покажет как это решить.
К сообщению приложен файл: How.xlsx(20.3 Kb)


Ктулху всех спасет
 
Ответить
СообщениеРешил создать новый файл с условиями: Надеюсь пояснения в файле достаточны.
Благодарю, если кто покажет как это решить.

Автор - Leem
Дата добавления - 01.07.2019 в 20:45
_Boroda_ Дата: Среда, 03.07.2019, 09:30 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15401
Репутация: 6031 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ваш последний файл я не совсем понял, держите пару решений по первому
В файле _2 на мой взгляд самое простое решение с доплистом. В файле _3 формулы сразу на нужных листах
Код
=ЕСЛИОШИБКА(ИНДЕКС(Общий!A:A;НАИБОЛЬШИЙ(СТРОКА(Общий!A$1:A$99)^НЕ(СЧЁТЕСЛИ(A$1:A1;Общий!A$1:A$99&"")+СЧЁТЕСЛИ(ЦЕХ!A:A;Общий!A$1:A$99)+СЧЁТЕСЛИ('3_1'!A$2:A$4;Общий!A$1:A$99)+СЧЁТЕСЛИ('3_2'!A$2:A$4;Общий!A$1:A$99));СЛУЧМЕЖДУ(1;СЧЁТЗ(Общий!A:A)-СЧЁТЗ(ЦЕХ!A:A)-СТРОКА(A1)-6)));"")
К сообщению приложен файл: 3s_2.xlsx(14.0 Kb) · 3s_3.xlsx(16.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВаш последний файл я не совсем понял, держите пару решений по первому
В файле _2 на мой взгляд самое простое решение с доплистом. В файле _3 формулы сразу на нужных листах
Код
=ЕСЛИОШИБКА(ИНДЕКС(Общий!A:A;НАИБОЛЬШИЙ(СТРОКА(Общий!A$1:A$99)^НЕ(СЧЁТЕСЛИ(A$1:A1;Общий!A$1:A$99&"")+СЧЁТЕСЛИ(ЦЕХ!A:A;Общий!A$1:A$99)+СЧЁТЕСЛИ('3_1'!A$2:A$4;Общий!A$1:A$99)+СЧЁТЕСЛИ('3_2'!A$2:A$4;Общий!A$1:A$99));СЛУЧМЕЖДУ(1;СЧЁТЗ(Общий!A:A)-СЧЁТЗ(ЦЕХ!A:A)-СТРОКА(A1)-6)));"")

Автор - _Boroda_
Дата добавления - 03.07.2019 в 09:30
Leem Дата: Среда, 03.07.2019, 17:14 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
В файле _2 на мой взгляд самое простое решение с доплистом.


Идеально подошло. Такой вариант и прост и удачно влился... hands hands hands hands hands hands hands hands hands hands hands


Ктулху всех спасет
 
Ответить
Сообщение
В файле _2 на мой взгляд самое простое решение с доплистом.


Идеально подошло. Такой вариант и прост и удачно влился... hands hands hands hands hands hands hands hands hands hands hands

Автор - Leem
Дата добавления - 03.07.2019 в 17:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Три рандомных списка из общего с условиями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!