Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчёт максимальной разности при заданных условиях - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчёт максимальной разности при заданных условиях (Формулы/Formulas)
Расчёт максимальной разности при заданных условиях
SonyaMarshmellow Дата: Четверг, 04.07.2019, 23:40 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

2016
Здравствуйте! Помогите правильно написать формулу для расчёта Pmax, чтобы значения были как в примере. Спасибо.
К сообщению приложен файл: _05.xls(40.0 Kb)


Сообщение отредактировал SonyaMarshmellow - Четверг, 04.07.2019, 23:41
 
Ответить
СообщениеЗдравствуйте! Помогите правильно написать формулу для расчёта Pmax, чтобы значения были как в примере. Спасибо.

Автор - SonyaMarshmellow
Дата добавления - 04.07.2019 в 23:40
Светлый Дата: Пятница, 05.07.2019, 06:36 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1299
Репутация: 325 ±
Замечаний: 0% ±

Excel 2010
Могу предложить формулу, где меньше всего разногласий с Вашими данными:
Код
=ЕСЛИ(МАКС(A2:D2;G2)>-МИН(A2:D2;G2);МАКС(A2:D2;G2);МИН(A2:D2;G2))-H2
Можно > заменить на >= , но тогда ошибок ещё больше. Проверьте свои данные и вычисления.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеМогу предложить формулу, где меньше всего разногласий с Вашими данными:
Код
=ЕСЛИ(МАКС(A2:D2;G2)>-МИН(A2:D2;G2);МАКС(A2:D2;G2);МИН(A2:D2;G2))-H2
Можно > заменить на >= , но тогда ошибок ещё больше. Проверьте свои данные и вычисления.

Автор - Светлый
Дата добавления - 05.07.2019 в 06:36
SonyaMarshmellow Дата: Пятница, 05.07.2019, 07:04 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

2016
По мат. анализу дали задание составить таблицу эксель для расчёта максимальной разности между точками С, D, E, F, H и точкой Ocp, зависищая от параметра L (Рмах должно быть максимально отрицательным или максимально положительным).На выходе, в столбце Р2 при суммировании L и Pmax должно получится максимально отрицательное или максимально положительное число. Максимальные значения точек выделены красным (синим выделены точки с одинаковыми числовыми значениями), а в столбце Pmax то, что должно получиться.
 
Ответить
СообщениеПо мат. анализу дали задание составить таблицу эксель для расчёта максимальной разности между точками С, D, E, F, H и точкой Ocp, зависищая от параметра L (Рмах должно быть максимально отрицательным или максимально положительным).На выходе, в столбце Р2 при суммировании L и Pmax должно получится максимально отрицательное или максимально положительное число. Максимальные значения точек выделены красным (синим выделены точки с одинаковыми числовыми значениями), а в столбце Pmax то, что должно получиться.

Автор - SonyaMarshmellow
Дата добавления - 05.07.2019 в 07:04
_Boroda_ Дата: Пятница, 05.07.2019, 10:07 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6078 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Соня, Ваше объяснение "расчёта максимальной разности между точками С, D, E, F, H и точкой Ocp" не совпадает с формулой в файле
Формула сначала считает максимум из точек, а затем вычитает из него Оср.
А по объяснению получается, что сначала мы смотрим разности точек и Оср, а затем из них выбираем максимальное по модулю и определяемся со знаком. А вот как определиться со знаком - это не совсем ясно. Например, Оср=0, CDE=0, F=1, G=-1. Разность точек и Оср будет 0,0,0,1,-1. Есть значения 1 и -1, по модулю они одинаковы, а вот какой знак выбрать - не понятно
В Вашей таблице есть подобные строки. Например, строка 3 и строка 5. В строке 3 Вы хотите получить результат -0,1, а в пятой 0,2. Непонятен алгоритм простановки знака
К сообщению приложен файл: 4315213.gif(2.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСоня, Ваше объяснение "расчёта максимальной разности между точками С, D, E, F, H и точкой Ocp" не совпадает с формулой в файле
Формула сначала считает максимум из точек, а затем вычитает из него Оср.
А по объяснению получается, что сначала мы смотрим разности точек и Оср, а затем из них выбираем максимальное по модулю и определяемся со знаком. А вот как определиться со знаком - это не совсем ясно. Например, Оср=0, CDE=0, F=1, G=-1. Разность точек и Оср будет 0,0,0,1,-1. Есть значения 1 и -1, по модулю они одинаковы, а вот какой знак выбрать - не понятно
В Вашей таблице есть подобные строки. Например, строка 3 и строка 5. В строке 3 Вы хотите получить результат -0,1, а в пятой 0,2. Непонятен алгоритм простановки знака

Автор - _Boroda_
Дата добавления - 05.07.2019 в 10:07
SonyaMarshmellow Дата: Пятница, 05.07.2019, 12:49 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

2016
Я извиняюсь, но при полученных одинаковых результатах, если например С=-2 и например, F=+2, Ocp=0 тогда берём любое число (может быть абсолютным), а если Оср=+2,3, L=-1,2, тогда выбирается точка С=Pmax=-2, что в окончательном ответе P2=Pmax+L=-4,3+(-1,2)=-5,5 (правильный ответ), или Pmax = F = +2, тогда P2=-0,3+(-1,2) = -1,5. Тут надо выбрать такое значение Рmax, при котором Р2 в сумме будет давать максимальное число (положительное или отрицательное при разных знаках)
 
Ответить
СообщениеЯ извиняюсь, но при полученных одинаковых результатах, если например С=-2 и например, F=+2, Ocp=0 тогда берём любое число (может быть абсолютным), а если Оср=+2,3, L=-1,2, тогда выбирается точка С=Pmax=-2, что в окончательном ответе P2=Pmax+L=-4,3+(-1,2)=-5,5 (правильный ответ), или Pmax = F = +2, тогда P2=-0,3+(-1,2) = -1,5. Тут надо выбрать такое значение Рmax, при котором Р2 в сумме будет давать максимальное число (положительное или отрицательное при разных знаках)

Автор - SonyaMarshmellow
Дата добавления - 05.07.2019 в 12:49
Светлый Дата: Пятница, 05.07.2019, 18:52 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1299
Репутация: 325 ±
Замечаний: 0% ±

Excel 2010
Вот так ближе. Массивная (Ctrl+Shift+Enter) формула:
Код
=ЕСЛИ(МАКС(A2:D2-H2;G2-H2)>=-МИН(A2:D2-H2;G2-H2);МАКС(A2:D2-H2;G2-H2);МИН(A2:D2-H2;G2-H2))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеВот так ближе. Массивная (Ctrl+Shift+Enter) формула:
Код
=ЕСЛИ(МАКС(A2:D2-H2;G2-H2)>=-МИН(A2:D2-H2;G2-H2);МАКС(A2:D2-H2;G2-H2);МИН(A2:D2-H2;G2-H2))

Автор - Светлый
Дата добавления - 05.07.2019 в 18:52
SonyaMarshmellow Дата: Пятница, 05.07.2019, 23:18 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

2016
Считается почти все правильно, а как сделать так чтобы все считалось правильно, вот если эти две формулы объединить?
К сообщению приложен файл: _05--.xls(46.0 Kb)
 
Ответить
СообщениеСчитается почти все правильно, а как сделать так чтобы все считалось правильно, вот если эти две формулы объединить?

Автор - SonyaMarshmellow
Дата добавления - 05.07.2019 в 23:18
SonyaMarshmellow Дата: Суббота, 06.07.2019, 08:38 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

2016
Здравствуйте! Я разобралась с формулами, должно получиться так как в расчётах (т.е. Рmax будет таким числом, при котором Р2 при сложении будет давать максимальное число (положительное или отрицательное), а при появлении чисел одинаковыми значениями и разными знаками должно браться число по модулю).
К сообщению приложен файл: 7833116.xls(63.5 Kb)


Сообщение отредактировал SonyaMarshmellow - Суббота, 06.07.2019, 08:38
 
Ответить
СообщениеЗдравствуйте! Я разобралась с формулами, должно получиться так как в расчётах (т.е. Рmax будет таким числом, при котором Р2 при сложении будет давать максимальное число (положительное или отрицательное), а при появлении чисел одинаковыми значениями и разными знаками должно браться число по модулю).

Автор - SonyaMarshmellow
Дата добавления - 06.07.2019 в 08:38
SonyaMarshmellow Дата: Понедельник, 08.07.2019, 06:56 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

2016
Здравствуйте, форумчане. Я переделала расчет, вот только не могу формулу до логического завершения довести. Помогите пожалуйста
 
Ответить
СообщениеЗдравствуйте, форумчане. Я переделала расчет, вот только не могу формулу до логического завершения довести. Помогите пожалуйста

Автор - SonyaMarshmellow
Дата добавления - 08.07.2019 в 06:56
Светлый Дата: Понедельник, 08.07.2019, 09:35 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 1299
Репутация: 325 ±
Замечаний: 0% ±

Excel 2010
Может быть, тогда для P2 использовать массивную формулу:
Код
=ЕСЛИ(МАКС(A2:D2-H2+I2;G2-H2+I2)>=-МИН(A2:D2-H2+I2;G2-H2+I2);МАКС(A2:D2-H2+I2;G2-H2+I2);МИН(A2:D2-H2+I2;G2-H2+I2))
Она с Вашими значениями P2 полностью совпадает.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеМожет быть, тогда для P2 использовать массивную формулу:
Код
=ЕСЛИ(МАКС(A2:D2-H2+I2;G2-H2+I2)>=-МИН(A2:D2-H2+I2;G2-H2+I2);МАКС(A2:D2-H2+I2;G2-H2+I2);МИН(A2:D2-H2+I2;G2-H2+I2))
Она с Вашими значениями P2 полностью совпадает.

Автор - Светлый
Дата добавления - 08.07.2019 в 09:35
SonyaMarshmellow Дата: Понедельник, 08.07.2019, 22:46 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

2016
Еще раз здравствуйте! Хочу вам выразить благодарность, спасибо. Формулу надо было немного изменить, и Рмакс считается теперь правильно:

=ЕСЛИ(МАКС(I2+(A2-H2);I2+(B2-H2);I2+(C2-H2);I2+(D2-H2);I2+(G2-H2))>=-МИН(I2+(A2-H2);I2+(B2-H2);I2+(C2-H2);I2+(D2-H2);I2+(G2-H2));МАКС(A2-H2;B2-H2;C2-H2;D2-H2;G2-H2);МИН(A2-H2;B2-H2;C2-H2;D2-H2;G2-H2))
 
Ответить
СообщениеЕще раз здравствуйте! Хочу вам выразить благодарность, спасибо. Формулу надо было немного изменить, и Рмакс считается теперь правильно:

=ЕСЛИ(МАКС(I2+(A2-H2);I2+(B2-H2);I2+(C2-H2);I2+(D2-H2);I2+(G2-H2))>=-МИН(I2+(A2-H2);I2+(B2-H2);I2+(C2-H2);I2+(D2-H2);I2+(G2-H2));МАКС(A2-H2;B2-H2;C2-H2;D2-H2;G2-H2);МИН(A2-H2;B2-H2;C2-H2;D2-H2;G2-H2))

Автор - SonyaMarshmellow
Дата добавления - 08.07.2019 в 22:46
_Boroda_ Дата: Вторник, 09.07.2019, 09:15 | Сообщение № 12
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6078 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
- Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение- Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - _Boroda_
Дата добавления - 09.07.2019 в 09:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчёт максимальной разности при заданных условиях (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!