Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти каждое четвертое значение в столбце - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти каждое четвертое значение в столбце (Формулы/Formulas)
Найти каждое четвертое значение в столбце
pain2430 Дата: Четверг, 18.07.2019, 14:28 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 39
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте! Прошу помощи вот в таком вот задании:
Есть столбец в котором рандомно идут значения(иногда с пропусками)
Например:
A
B
A
A
A
B

Нужно найти четвертое значение после трех повторяющихся. В случае примера, после трех "A", четвертое идет "B". Отмечаем в соседней колонке "Нет". Если бы четвертое значение было "A", отметили бы "Да".
Аналогичная ситуация с "B".

Спасибо!
 
Ответить
СообщениеЗдравствуйте! Прошу помощи вот в таком вот задании:
Есть столбец в котором рандомно идут значения(иногда с пропусками)
Например:
A
B
A
A
A
B

Нужно найти четвертое значение после трех повторяющихся. В случае примера, после трех "A", четвертое идет "B". Отмечаем в соседней колонке "Нет". Если бы четвертое значение было "A", отметили бы "Да".
Аналогичная ситуация с "B".

Спасибо!

Автор - pain2430
Дата добавления - 18.07.2019 в 14:28
китин Дата: Четверг, 18.07.2019, 14:36 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5736
Репутация: 903 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
pain2430, - Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 100кб согласно п.3 Правил форума


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеpain2430, - Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 100кб согласно п.3 Правил форума

Автор - китин
Дата добавления - 18.07.2019 в 14:36
bmv98rus Дата: Четверг, 18.07.2019, 14:42 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 2456
Репутация: 421 ±
Замечаний: 0% ±

Excel 2013/2016
Приложите файл с исходными данными

особенно с
(иногда с пропусками)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Приложите файл с исходными данными

особенно с
(иногда с пропусками)

Автор - bmv98rus
Дата добавления - 18.07.2019 в 14:42
pain2430 Дата: Четверг, 18.07.2019, 20:01 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 39
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
.


Сообщение отредактировал pain2430 - Четверг, 18.07.2019, 20:02
 
Ответить
Сообщение.

Автор - pain2430
Дата добавления - 18.07.2019 в 20:01
pain2430 Дата: Четверг, 18.07.2019, 22:15 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 39
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
bmv98rus, китин, прикрепил файл с примером, спасибо!
К сообщению приложен файл: 6682407.xlsx(8.9 Kb)
 
Ответить
Сообщениеbmv98rus, китин, прикрепил файл с примером, спасибо!

Автор - pain2430
Дата добавления - 18.07.2019 в 22:15
bmv98rus Дата: Четверг, 18.07.2019, 23:08 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 2456
Репутация: 421 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=CHOOSE(IF(A2="";2;IFERROR(COUNTIF(INDEX(A:A;LARGE(IF($A$1:A2<>"";ROW($A$1:A2));4)):A1;A2)+1;2));"Нет";"";"";"Да")

Но результат несколько отличен от примера
К сообщению приложен файл: Copy_of_1033.xlsx(10.4 Kb)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Код
=CHOOSE(IF(A2="";2;IFERROR(COUNTIF(INDEX(A:A;LARGE(IF($A$1:A2<>"";ROW($A$1:A2));4)):A1;A2)+1;2));"Нет";"";"";"Да")

Но результат несколько отличен от примера

Автор - bmv98rus
Дата добавления - 18.07.2019 в 23:08
pain2430 Дата: Пятница, 19.07.2019, 00:03 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 39
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
bmv98rus, отличен от примера потому что Ваше решение правильнее чем мой пример...в спешке недосмотрел...
Спасибо Вам огромное!
 
Ответить
Сообщениеbmv98rus, отличен от примера потому что Ваше решение правильнее чем мой пример...в спешке недосмотрел...
Спасибо Вам огромное!

Автор - pain2430
Дата добавления - 19.07.2019 в 00:03
AlexM Дата: Пятница, 19.07.2019, 10:39 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3878
Репутация: 976 ±
Замечаний: 0% ±

Excel 2003
Еще вариант
Код
=ВПР(СЧЁТЕСЛИ(ИНДЕКС(A:A;НАИБОЛЬШИЙ(ЕСЛИ({1;0};($A$1:A2<>"")*СТРОКА($A$1:A2);{0;0});4)):A2;A2);{0;"":1;"Нет":2;"":4;"Да":5;""};2)
формула массива
К сообщению приложен файл: 6682407_01.xlsx(9.8 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Пятница, 19.07.2019, 10:39
 
Ответить
СообщениеЕще вариант
Код
=ВПР(СЧЁТЕСЛИ(ИНДЕКС(A:A;НАИБОЛЬШИЙ(ЕСЛИ({1;0};($A$1:A2<>"")*СТРОКА($A$1:A2);{0;0});4)):A2;A2);{0;"":1;"Нет":2;"":4;"Да":5;""};2)
формула массива

Автор - AlexM
Дата добавления - 19.07.2019 в 10:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти каждое четвертое значение в столбце (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!