Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вытянусть данные из массива, соблюдая два условия - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вытянусть данные из массива, соблюдая два условия (Формулы/Formulas)
Вытянусть данные из массива, соблюдая два условия
nnk Дата: Среда, 24.07.2019, 22:27 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте!

Нужно из листа "Массив" вытянуть показатель ROA на лист "Коэф.запаса".
Но нужно, чтобы ROA относился и к номенклатуре 01.01. Трубы э/с до 219 и к складу ЯКТ-Якутск.
С помощью ВПР я вытянула 3,81, но без привязки к складу ЯКТ-Якутск.
Как это можно сделать?
ПОдскажите знаюзие люди.

Заранее благодарю.
К сообщению приложен файл: ROA.xlsx(19.2 Kb)
 
Ответить
СообщениеЗдравствуйте!

Нужно из листа "Массив" вытянуть показатель ROA на лист "Коэф.запаса".
Но нужно, чтобы ROA относился и к номенклатуре 01.01. Трубы э/с до 219 и к складу ЯКТ-Якутск.
С помощью ВПР я вытянула 3,81, но без привязки к складу ЯКТ-Якутск.
Как это можно сделать?
ПОдскажите знаюзие люди.

Заранее благодарю.

Автор - nnk
Дата добавления - 24.07.2019 в 22:27
_Boroda_ Дата: Среда, 24.07.2019, 22:51 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15567
Репутация: 6074 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А какое из значений Вам нужно?
Вот последнее
Код
=-ПРОСМОТР(;-Массив!$C$2:$C$99/($A2=Массив!$A$2:$A$99)/(B$1=Массив!$B$2:$B$99))

Код
=ЕСЛИОШИБКА(-ПРОСМОТР(;-Массив!$C$2:$C$99/($A2=Массив!$A$2:$A$99)/(B$1=Массив!$B$2:$B$99));)

Вот первое (формула массива, вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ИНДЕКС(Массив!$C:$C;МИН(ЕСЛИ(($A2=Массив!$A$2:$A$99)*(B$1=Массив!$B$2:$B$99);СТРОКА(Массив!$B$2:$B$99));999))
К сообщению приложен файл: ROA_1.xlsx(12.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА какое из значений Вам нужно?
Вот последнее
Код
=-ПРОСМОТР(;-Массив!$C$2:$C$99/($A2=Массив!$A$2:$A$99)/(B$1=Массив!$B$2:$B$99))

Код
=ЕСЛИОШИБКА(-ПРОСМОТР(;-Массив!$C$2:$C$99/($A2=Массив!$A$2:$A$99)/(B$1=Массив!$B$2:$B$99));)

Вот первое (формула массива, вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ИНДЕКС(Массив!$C:$C;МИН(ЕСЛИ(($A2=Массив!$A$2:$A$99)*(B$1=Массив!$B$2:$B$99);СТРОКА(Массив!$B$2:$B$99));999))

Автор - _Boroda_
Дата добавления - 24.07.2019 в 22:51
bmv98rus Дата: Среда, 24.07.2019, 23:26 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 2453
Репутация: 421 ±
Замечаний: 0% ±

Excel 2013/2016
знатный кросс


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениезнатный кросс

Автор - bmv98rus
Дата добавления - 24.07.2019 в 23:26
nnk Дата: Четверг, 25.07.2019, 10:39 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_,
=ИНДЕКС(Массив!$C:$C;МИН(ЕСЛИ(($A2=Массив!$A$2:$A$99)*(B$1=Массив!$B$2:$B$99);СТРОКА(Массив!$B$2:$B$99));999))
скажите пожалуйста, что означает 999 в Вашей формуле?
 
Ответить
Сообщение_Boroda_,
=ИНДЕКС(Массив!$C:$C;МИН(ЕСЛИ(($A2=Массив!$A$2:$A$99)*(B$1=Массив!$B$2:$B$99);СТРОКА(Массив!$B$2:$B$99));999))
скажите пожалуйста, что означает 999 в Вашей формуле?

Автор - nnk
Дата добавления - 25.07.2019 в 10:39
_Boroda_ Дата: Четверг, 25.07.2019, 11:00 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15567
Репутация: 6074 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
- Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение- Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - _Boroda_
Дата добавления - 25.07.2019 в 11:00
bmv98rus Дата: Четверг, 25.07.2019, 12:45 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 2453
Репутация: 421 ±
Замечаний: 0% ±

Excel 2013/2016
_Boroda_, не вернется

видимо там тебе просили спасибо передать :-)
К сообщению приложен файл: 6115355.jpg(22.0 Kb)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение_Boroda_, не вернется

видимо там тебе просили спасибо передать :-)

Автор - bmv98rus
Дата добавления - 25.07.2019 в 12:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вытянусть данные из массива, соблюдая два условия (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!