Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти разные значение и выписать их в строчку в разные ячейк - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти разные значение и выписать их в строчку в разные ячейк (Формулы/Formulas)
Найти разные значение и выписать их в строчку в разные ячейк
Ivan28rus89 Дата: Вторник, 30.07.2019, 05:58 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день.
Подскажите можно ли сделать формулу в которой будет искать все разные значения и выписать в строчку в разный столбец:
Например: на одной машине работали

Петров Иванов Иванов Иванов Усов Петров Петров

Надо получить чтобы в строчку в разные ячейки выписывались фамилии и не повторялись:

Петров Иванов Усов

Спасибо.
К сообщению приложен файл: 8222378.xlsx(9.0 Kb)


Всем привет
 
Ответить
СообщениеДобрый день.
Подскажите можно ли сделать формулу в которой будет искать все разные значения и выписать в строчку в разный столбец:
Например: на одной машине работали

Петров Иванов Иванов Иванов Усов Петров Петров

Надо получить чтобы в строчку в разные ячейки выписывались фамилии и не повторялись:

Петров Иванов Усов

Спасибо.

Автор - Ivan28rus89
Дата добавления - 30.07.2019 в 05:58
Светлый Дата: Вторник, 30.07.2019, 06:18 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1202
Репутация: 309 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Массивная формула (Ctrl+Shift+Enter):
Код
=ЕСЛИОШИБКА(ИНДЕКС(5:5;;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ($A5:$S5;$A5:$S5;)=СТОЛБЕЦ($A:$S);СТОЛБЕЦ($A:$S));СТОЛБЕЦ()));"")
*А если без разницы в каком порядке, то начиная со второго столбца можно использовать формулу:
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(СЧЁТЕСЛИ($A10:A10;$A5:$S5)=0);5:5);"")
К сообщению приложен файл: 8222378-1.xlsx(9.8 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Вторник, 30.07.2019, 06:34
 
Ответить
СообщениеДобрый день!
Массивная формула (Ctrl+Shift+Enter):
Код
=ЕСЛИОШИБКА(ИНДЕКС(5:5;;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ($A5:$S5;$A5:$S5;)=СТОЛБЕЦ($A:$S);СТОЛБЕЦ($A:$S));СТОЛБЕЦ()));"")
*А если без разницы в каком порядке, то начиная со второго столбца можно использовать формулу:
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(СЧЁТЕСЛИ($A10:A10;$A5:$S5)=0);5:5);"")

Автор - Светлый
Дата добавления - 30.07.2019 в 06:18
_Boroda_ Дата: Вторник, 30.07.2019, 08:48 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15572
Репутация: 6075 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант формулы со второго столбца. В обычном порядке
Массивная
Код
=ИНДЕКС(5:5;ПОИСКПОЗ(;СЧЁТЕСЛИ($A8:A8;$A5:$Z5);))&""

Обычная
Код
=ИНДЕКС(5:5;ПОИСКПОЗ(;ИНДЕКС(СЧЁТЕСЛИ($A7:A7;$A5:$Z5););))&""
К сообщению приложен файл: 8222378_1.xlsx(9.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант формулы со второго столбца. В обычном порядке
Массивная
Код
=ИНДЕКС(5:5;ПОИСКПОЗ(;СЧЁТЕСЛИ($A8:A8;$A5:$Z5);))&""

Обычная
Код
=ИНДЕКС(5:5;ПОИСКПОЗ(;ИНДЕКС(СЧЁТЕСЛИ($A7:A7;$A5:$Z5););))&""

Автор - _Boroda_
Дата добавления - 30.07.2019 в 08:48
Ivan28rus89 Дата: Вторник, 30.07.2019, 09:24 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Все отлично..
возможен вариант чтобы поиск был в определенном диапозоне
К сообщению приложен файл: 4842757.xlsx(10.7 Kb)


Всем привет
 
Ответить
СообщениеВсе отлично..
возможен вариант чтобы поиск был в определенном диапозоне

Автор - Ivan28rus89
Дата добавления - 30.07.2019 в 09:24
Pelena Дата: Вторник, 30.07.2019, 20:32 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 14327
Репутация: 3132 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Как вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС($D3:$K3;ПОИСКПОЗ(;ИНДЕКС(СЧЁТЕСЛИ($P3:P3;$D3:$K3););));ИНДЕКС($D14:$K14;ПОИСКПОЗ(;ИНДЕКС(СЧЁТЕСЛИ($P3:P3;$D14:$K14););)))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеКак вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС($D3:$K3;ПОИСКПОЗ(;ИНДЕКС(СЧЁТЕСЛИ($P3:P3;$D3:$K3););));ИНДЕКС($D14:$K14;ПОИСКПОЗ(;ИНДЕКС(СЧЁТЕСЛИ($P3:P3;$D14:$K14););)))

Автор - Pelena
Дата добавления - 30.07.2019 в 20:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти разные значение и выписать их в строчку в разные ячейк (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!