Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Создание строк с заданным количеством и заполненный ясейкам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создание строк с заданным количеством и заполненный ясейкам
Создание строк с заданным количеством и заполненный ясейкам
Mahp_dn Дата: Понедельник, 05.08.2019, 10:15 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

10
Добрый день. Помогите решить задачу во вложении. Любым способом либо формулой либо макросов. Спасибо за ранее Всем!
К сообщению приложен файл: 8846041.xlsx(12.3 Kb)


Очень позитивный человек
 
Ответить
СообщениеДобрый день. Помогите решить задачу во вложении. Любым способом либо формулой либо макросов. Спасибо за ранее Всем!

Автор - Mahp_dn
Дата добавления - 05.08.2019 в 10:15
Nic70y Дата: Среда, 07.08.2019, 11:11 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5518
Репутация: 1202 ±
Замечаний: 0% ±

ru13;10;03
формулами по-приколу
со строки 5
номера, названия
Код
=ЕСЛИ((СТРОКА()-ПОИСКПОЗ(ВПР("我";A$1:A4;1);A$1:A4;)-2)<ВПР(ВПР("我";A$1:A4;1);Лист1!B:C;2;);СТРОКА()-ПОИСКПОЗ(ВПР("我";A$1:A4;1);A$1:A4;)-1;ЕСЛИ(И(A4=0;ЕЧИСЛО(A3));ИНДЕКС(Лист1!B:B;ПОИСКПОЗ(ВПР("我";A$1:A4;1);Лист1!B:B;)+1);))
данные
Код
=ЕСЛИ(ИЛИ(И($A5=0;ЕЧИСЛО($A4));ЕТЕКСТ(A5));"";ЕСЛИ(ЕТЕКСТ($A4);B$4;СЛУЧМЕЖДУ(ИНДЕКС(Лист1!D:D;ПОИСКПОЗ(ВПР("我";$A$1:$A4;1);Лист1!$B:$B;))*100;ИНДЕКС(Лист1!E:E;ПОИСКПОЗ(ВПР("我";$A$1:$A4;1);Лист1!$B:$B;))*100)/100))
A3
Код
=Лист1!B5
в строке 4 текст
К сообщению приложен файл: 0155252.xlsx(17.1 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениеформулами по-приколу
со строки 5
номера, названия
Код
=ЕСЛИ((СТРОКА()-ПОИСКПОЗ(ВПР("我";A$1:A4;1);A$1:A4;)-2)<ВПР(ВПР("我";A$1:A4;1);Лист1!B:C;2;);СТРОКА()-ПОИСКПОЗ(ВПР("我";A$1:A4;1);A$1:A4;)-1;ЕСЛИ(И(A4=0;ЕЧИСЛО(A3));ИНДЕКС(Лист1!B:B;ПОИСКПОЗ(ВПР("我";A$1:A4;1);Лист1!B:B;)+1);))
данные
Код
=ЕСЛИ(ИЛИ(И($A5=0;ЕЧИСЛО($A4));ЕТЕКСТ(A5));"";ЕСЛИ(ЕТЕКСТ($A4);B$4;СЛУЧМЕЖДУ(ИНДЕКС(Лист1!D:D;ПОИСКПОЗ(ВПР("我";$A$1:$A4;1);Лист1!$B:$B;))*100;ИНДЕКС(Лист1!E:E;ПОИСКПОЗ(ВПР("我";$A$1:$A4;1);Лист1!$B:$B;))*100)/100))
A3
Код
=Лист1!B5
в строке 4 текст

Автор - Nic70y
Дата добавления - 07.08.2019 в 11:11
Mahp_dn Дата: Среда, 07.08.2019, 13:56 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

10
Спасибо большое. Сейчас посмотрю


Очень позитивный человек
 
Ответить
СообщениеСпасибо большое. Сейчас посмотрю

Автор - Mahp_dn
Дата добавления - 07.08.2019 в 13:56
Mahp_dn Дата: Среда, 07.08.2019, 14:22 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

10
А в функции ВПР искомый Текст иероглиф. Что он означает
И еще как над данными посчитать среднее значение по стрлбцам если данные находятся ниже


Очень позитивный человек
 
Ответить
СообщениеА в функции ВПР искомый Текст иероглиф. Что он означает
И еще как над данными посчитать среднее значение по стрлбцам если данные находятся ниже

Автор - Mahp_dn
Дата добавления - 07.08.2019 в 14:22
Nic70y Дата: Среда, 07.08.2019, 14:36 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 5518
Репутация: 1202 ±
Замечаний: 0% ±

ru13;10;03
иероглиф

http://www.excelworld.ru/forum/2-21425-1
над данными посчитать среднее
я конечно не уверен, но скорей всего это вопрос новой темы (модераторы очень злые)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
иероглиф

http://www.excelworld.ru/forum/2-21425-1
над данными посчитать среднее
я конечно не уверен, но скорей всего это вопрос новой темы (модераторы очень злые)

Автор - Nic70y
Дата добавления - 07.08.2019 в 14:36
китин Дата: Четверг, 08.08.2019, 08:28 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 5743
Репутация: 904 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
(модераторы очень злые)

может быть, может быть
но скорей всего это вопрос новой темы

абсолютно точно
Mahp_dn, - п.4 Правил форума: один вопрос - одна тема


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
(модераторы очень злые)

может быть, может быть
но скорей всего это вопрос новой темы

абсолютно точно
Mahp_dn, - п.4 Правил форума: один вопрос - одна тема

Автор - китин
Дата добавления - 08.08.2019 в 08:28
Mahp_dn Дата: Понедельник, 19.08.2019, 16:39 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

10
Спасибо большое. Еще раз! Очень помогло


Очень позитивный человек
 
Ответить
СообщениеСпасибо большое. Еще раз! Очень помогло

Автор - Mahp_dn
Дата добавления - 19.08.2019 в 16:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создание строк с заданным количеством и заполненный ясейкам
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!