Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет кол-ва символов за исключением условия - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет кол-ва символов за исключением условия (Формулы/Formulas)
Подсчет кол-ва символов за исключением условия
TD_MElec Дата: Вторник, 13.08.2019, 10:08 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Был подобный вопрос здесь. Огромное спасибо всем ответившим. Пользуюсь вариантом:
Код
=СУММПРОИЗВ(--ЕОШ(ПОИСК("~"&ПСТР(C3;СТРОКА($1:$99);1);":;,.!?")))

Есть потребность еще не учитывать не только определенные символы, но и слова идущие после знаков “ -“ без пробела. Например: Ехал в Санкт-Петербург – считаем все символы; Ехал в Санкт - Петербург – считаем все символы; а вот Ехал в Санкт -Петербург – здесь необходимо посчитать только «Ехал в Санкт».
И вишенкой на торте будет не считать последний пробел (в примере, идущий после «Санкт»)
Все слова, которые необходимо не учитывать идут после "-" без пробела, и они все идут друг за другом, т.е. после первого появления сочетания знаков: “ -“ дальше можно ничего не считать.
К сообщению приложен файл: pr.xlsx(9.2 Kb)


Сообщение отредактировал TD_MElec - Вторник, 13.08.2019, 10:24
 
Ответить
СообщениеДобрый день.
Был подобный вопрос здесь. Огромное спасибо всем ответившим. Пользуюсь вариантом:
Код
=СУММПРОИЗВ(--ЕОШ(ПОИСК("~"&ПСТР(C3;СТРОКА($1:$99);1);":;,.!?")))

Есть потребность еще не учитывать не только определенные символы, но и слова идущие после знаков “ -“ без пробела. Например: Ехал в Санкт-Петербург – считаем все символы; Ехал в Санкт - Петербург – считаем все символы; а вот Ехал в Санкт -Петербург – здесь необходимо посчитать только «Ехал в Санкт».
И вишенкой на торте будет не считать последний пробел (в примере, идущий после «Санкт»)
Все слова, которые необходимо не учитывать идут после "-" без пробела, и они все идут друг за другом, т.е. после первого появления сочетания знаков: “ -“ дальше можно ничего не считать.

Автор - TD_MElec
Дата добавления - 13.08.2019 в 10:08
_Boroda_ Дата: Вторник, 13.08.2019, 10:28 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15567
Репутация: 6074 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ПОИСК(" -";ПОДСТАВИТЬ(C14;" - ";111)&" -")-1


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ПОИСК(" -";ПОДСТАВИТЬ(C14;" - ";111)&" -")-1

Автор - _Boroda_
Дата добавления - 13.08.2019 в 10:28
TD_MElec Дата: Вторник, 13.08.2019, 10:38 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Я не указал, что необходимо оставить и знаки препинания. Т.е. необходимо совместить эти две формулы.
Изменил файл примера.
К сообщению приложен файл: pr2.xlsx(9.3 Kb)
 
Ответить
СообщениеЯ не указал, что необходимо оставить и знаки препинания. Т.е. необходимо совместить эти две формулы.
Изменил файл примера.

Автор - TD_MElec
Дата добавления - 13.08.2019 в 10:38
_Boroda_ Дата: Вторник, 13.08.2019, 10:49 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15567
Репутация: 6074 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так?
Код
=СУММПРОИЗВ(--ЕОШ(ПОИСК("~"&ПСТР(ЛЕВБ(C14;ПОИСК(" -";ПОДСТАВИТЬ(C14;" - ";111)&" -")-1);СТРОКА($1:$99);1);H$2)))


* Думаю, что укоротить даже в немассивном варианте можно
К сообщению приложен файл: pr2_2.xlsx(9.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак?
Код
=СУММПРОИЗВ(--ЕОШ(ПОИСК("~"&ПСТР(ЛЕВБ(C14;ПОИСК(" -";ПОДСТАВИТЬ(C14;" - ";111)&" -")-1);СТРОКА($1:$99);1);H$2)))


* Думаю, что укоротить даже в немассивном варианте можно

Автор - _Boroda_
Дата добавления - 13.08.2019 в 10:49
TD_MElec Дата: Вторник, 13.08.2019, 11:26 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Да, отлично. Спасибо. Работает))
 
Ответить
СообщениеДа, отлично. Спасибо. Работает))

Автор - TD_MElec
Дата добавления - 13.08.2019 в 11:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет кол-ва символов за исключением условия (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!