Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка по полу в отдельные ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка по полу в отдельные ячейки (Формулы/Formulas)
Выборка по полу в отдельные ячейки
EvelRus Дата: Среда, 21.08.2019, 12:11 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем добры день!
Помогите, пожалуйста, решить проблему.
Есть таблица в которой указаны ФИО, Пол, Дата рождения детей
На втором листе таблицы необходимо сделать два столбика и автоматически разделить мальчиков и девочек.
Не понимаю можно ли это сделать формулами? Потому что если использовать IF то будут пропуски, а хотелось бы подряд.

Заранее большое спасибо!

PS: Excel для Mac 16.28 (19081202)
К сообщению приложен файл: 4184685.xlsx(9.8 Kb)


Сообщение отредактировал EvelRus - Среда, 21.08.2019, 12:14
 
Ответить
СообщениеВсем добры день!
Помогите, пожалуйста, решить проблему.
Есть таблица в которой указаны ФИО, Пол, Дата рождения детей
На втором листе таблицы необходимо сделать два столбика и автоматически разделить мальчиков и девочек.
Не понимаю можно ли это сделать формулами? Потому что если использовать IF то будут пропуски, а хотелось бы подряд.

Заранее большое спасибо!

PS: Excel для Mac 16.28 (19081202)

Автор - EvelRus
Дата добавления - 21.08.2019 в 12:11
Nic70y Дата: Среда, 21.08.2019, 12:22 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5605
Репутация: 1227 ±
Замечаний: 0% ±

ru13;10;03
1) дискриминация по половому признаку?
2) можно массивной, но это не прилично
3) решение с доп.столбцом
Код
=СЧЁТЕСЛИ($B$2:B2;B2)&B2
и соот.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A:A;ПОИСКПОЗ(СТРОКА(B1)&"м";Лист1!D:D;));"")
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A:A;ПОИСКПОЗ(СТРОКА(B1)&"ж";Лист1!D:D;));"")
К сообщению приложен файл: 9981552.xlsx(11.6 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщение1) дискриминация по половому признаку?
2) можно массивной, но это не прилично
3) решение с доп.столбцом
Код
=СЧЁТЕСЛИ($B$2:B2;B2)&B2
и соот.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A:A;ПОИСКПОЗ(СТРОКА(B1)&"м";Лист1!D:D;));"")
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A:A;ПОИСКПОЗ(СТРОКА(B1)&"ж";Лист1!D:D;));"")

Автор - Nic70y
Дата добавления - 21.08.2019 в 12:22
китин Дата: Среда, 21.08.2019, 12:48 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 5828
Репутация: 907 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
или так
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A$2:A$6;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!$B$2:$B$6="м";СТРОКА(Лист1!$A$2:$A$6)-1);СТРОКА(A1)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 0103711.xlsx(11.5 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеили так
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A$2:A$6;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!$B$2:$B$6="м";СТРОКА(Лист1!$A$2:$A$6)-1);СТРОКА(A1)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - китин
Дата добавления - 21.08.2019 в 12:48
EvelRus Дата: Среда, 21.08.2019, 14:17 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
дискриминация по половому признаку?

Ни в коем случае )) Просто надо развести мальчиков и девочек.

решение с доп.столбцом

Вполне подходит, спасибо большое!

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

К сожалению на MacOS не срабатывает (

Воспользовался вариантом уважаемого Nic70y
 
Ответить
Сообщение
дискриминация по половому признаку?

Ни в коем случае )) Просто надо развести мальчиков и девочек.

решение с доп.столбцом

Вполне подходит, спасибо большое!

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

К сожалению на MacOS не срабатывает (

Воспользовался вариантом уважаемого Nic70y

Автор - EvelRus
Дата добавления - 21.08.2019 в 14:17
Nic70y Дата: Среда, 21.08.2019, 14:24 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 5605
Репутация: 1227 ±
Замечаний: 0% ±

ru13;10;03
надо развести
[offtop]разрушаете семьи %) [/offtop]


ЯД(poison) 41001841029809
 
Ответить
Сообщение
надо развести
[offtop]разрушаете семьи %) [/offtop]

Автор - Nic70y
Дата добавления - 21.08.2019 в 14:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка по полу в отдельные ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!