Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подстановка последующих значений при совпадении - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка последующих значений при совпадении (Формулы/Formulas)
Подстановка последующих значений при совпадении
JuRaSS Дата: Понедельник, 26.08.2019, 10:22 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Помогите написать формулу по подстановке значений при повторении. Пример, как должно выглядеть во вложении.
К сообщению приложен файл: 7847596.xlsx(9.0 Kb)
 
Ответить
СообщениеПомогите написать формулу по подстановке значений при повторении. Пример, как должно выглядеть во вложении.

Автор - JuRaSS
Дата добавления - 26.08.2019 в 10:22
китин Дата: Понедельник, 26.08.2019, 10:28 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5828
Репутация: 907 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
вам надо оставить уникальные значения? я правильно пронял? выделить столбец А-вкладка Данные-уДАЛИТЬ ДУБЛИКАТЫ


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениевам надо оставить уникальные значения? я правильно пронял? выделить столбец А-вкладка Данные-уДАЛИТЬ ДУБЛИКАТЫ

Автор - китин
Дата добавления - 26.08.2019 в 10:28
JuRaSS Дата: Понедельник, 26.08.2019, 11:23 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Не совсем так... С дубликатами проблем не возникает... мне нужно, чтобы эта функция работала на весь столбец автоматически и при добавлении новых значений в столбце, сразу переносила уникальные значения в соседний столбец по порядку.


Сообщение отредактировал JuRaSS - Понедельник, 26.08.2019, 11:23
 
Ответить
СообщениеНе совсем так... С дубликатами проблем не возникает... мне нужно, чтобы эта функция работала на весь столбец автоматически и при добавлении новых значений в столбце, сразу переносила уникальные значения в соседний столбец по порядку.

Автор - JuRaSS
Дата добавления - 26.08.2019 в 11:23
Nic70y Дата: Понедельник, 26.08.2019, 11:29 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 5607
Репутация: 1227 ±
Замечаний: 0% ±

ru13;10;03
вариант с заумной таблицей,
Код
=ИНДЕКС(ПОИСКПОЗ(
и т.п.

переборщил, сократил формулу, файл перезалил
К сообщению приложен файл: 7847596-3-.xlsx(11.2 Kb)


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Понедельник, 26.08.2019, 11:35
 
Ответить
Сообщениевариант с заумной таблицей,
Код
=ИНДЕКС(ПОИСКПОЗ(
и т.п.

переборщил, сократил формулу, файл перезалил

Автор - Nic70y
Дата добавления - 26.08.2019 в 11:29
китин Дата: Понедельник, 26.08.2019, 11:34 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 5828
Репутация: 907 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
в ячейку D2 ми протянуть
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$41000;НАИМЕНЬШИЙ(ЕСЛИ(ЕСЛИОШИБКА(ПОИСКПОЗ($A$2:$A$1000;$A$2:$A$1000;0);0)=СТРОКА($A$2:$A$1000)-1;СТРОКА($A$2:$A$1000)-1);СТРОКА(A1)));"")

сделал на 1000 строка в столбце А
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
файл 2 вариант с Power Qeury
[vba]
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    #"Измененный тип" = Table.TransformColumnTypes(Источник,{{"Столбец1", type text}}),
    #"Удаленные дубликаты" = Table.Distinct(#"Измененный тип")
in
    #"Удаленные дубликаты"
[/vba]
К сообщению приложен файл: 8261752.xlsx(10.1 Kb) · PQ.xlsx(19.5 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениев ячейку D2 ми протянуть
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$41000;НАИМЕНЬШИЙ(ЕСЛИ(ЕСЛИОШИБКА(ПОИСКПОЗ($A$2:$A$1000;$A$2:$A$1000;0);0)=СТРОКА($A$2:$A$1000)-1;СТРОКА($A$2:$A$1000)-1);СТРОКА(A1)));"")

сделал на 1000 строка в столбце А
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
файл 2 вариант с Power Qeury
[vba]
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    #"Измененный тип" = Table.TransformColumnTypes(Источник,{{"Столбец1", type text}}),
    #"Удаленные дубликаты" = Table.Distinct(#"Измененный тип")
in
    #"Удаленные дубликаты"
[/vba]

Автор - китин
Дата добавления - 26.08.2019 в 11:34
JuRaSS Дата: Понедельник, 26.08.2019, 12:04 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Большущее спасибо! Очень помогло, сам уже дня 3 мучился )
 
Ответить
СообщениеБольшущее спасибо! Очень помогло, сам уже дня 3 мучился )

Автор - JuRaSS
Дата добавления - 26.08.2019 в 12:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка последующих значений при совпадении (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!