Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывести определённые данные, ориентир - левая часть слова - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести определённые данные, ориентир - левая часть слова (Формулы/Formulas)
Вывести определённые данные, ориентир - левая часть слова
stalber Дата: Суббота, 31.08.2019, 09:52 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 265
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте.

Необходимо из строки с данными, вывести только те, где определённая часть слова встречается.

Объяснить тяжело тут, поэтому файл прикрепил с пояснениями, посмотрите пожалуйста его.
К сообщению приложен файл: zadanie31082019.xlsx(8.5 Kb)
 
Ответить
СообщениеЗдравствуйте.

Необходимо из строки с данными, вывести только те, где определённая часть слова встречается.

Объяснить тяжело тут, поэтому файл прикрепил с пояснениями, посмотрите пожалуйста его.

Автор - stalber
Дата добавления - 31.08.2019 в 09:52
Светлый Дата: Суббота, 31.08.2019, 13:02 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1272
Репутация: 322 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!
Вот наскоро составленная массивная (вводится одновременным нажатием Ctrl+Shift+Enter) формула для одного образца:
Код
=ЕСЛИОШИБКА(ИНДЕКС($26:$26;;НАИМЕНЬШИЙ(ЕСЛИ(НАИМЕНЬШИЙ(ЕСЛИ((Т(+$F$26:$AG$26)>"")*ЕЧИСЛО(ПОИСК($F30&"_";$F$26:$AG$26));СТОЛБЕЦ($F:$AG);99);СТРОКА($1:$9))=ПРОСМОТР(СТОЛБЕЦ($F:$AG);ЕСЛИ(Т(+$F$26:$AG$26)>"";СТОЛБЕЦ($F:$AG)));СТОЛБЕЦ($F:$AG));СТОЛБЕЦ(A31)));"")
И для двух:
Код
=ЕСЛИОШИБКА(ИНДЕКС($26:$26;;НАИМЕНЬШИЙ(ЕСЛИ(НАИМЕНЬШИЙ(ЕСЛИ((Т(+$F$26:$AG$26)>"")*(ЕЧИСЛО(ПОИСК($F34&"_";$F$26:$AG$26))+ЕЧИСЛО(ПОИСК($G34&"_";$F$26:$AG$26)));СТОЛБЕЦ($F:$AG);99);СТРОКА($1:$9))=ПРОСМОТР(СТОЛБЕЦ($F:$AG);ЕСЛИ(Т(+$F$26:$AG$26)>"";СТОЛБЕЦ($F:$AG)));СТОЛБЕЦ($F:$AG));СТОЛБЕЦ(A35)));"")
*Или для двух можно попробовать так:
Код
=ЕСЛИОШИБКА(ИНДЕКС($26:$26;;НАИМЕНЬШИЙ(ЕСЛИ(НАИМЕНЬШИЙ(ЕСЛИ((Т(+$F$26:$AG$26)>"")*ЕЧИСЛО(ПОИСК(ТРАНСП($F34:$G34)&"_";$F$26:$AG$26));СТОЛБЕЦ($F:$AG);99);СТРОКА($1:$9))=ПРОСМОТР(СТОЛБЕЦ($F:$AG);ЕСЛИ(Т(+$F$26:$AG$26)>"";СТОЛБЕЦ($F:$AG)));СТОЛБЕЦ($F:$AG));СТОЛБЕЦ(A35)));"")


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Суббота, 31.08.2019, 13:11
 
Ответить
СообщениеЗдравствуйте!
Вот наскоро составленная массивная (вводится одновременным нажатием Ctrl+Shift+Enter) формула для одного образца:
Код
=ЕСЛИОШИБКА(ИНДЕКС($26:$26;;НАИМЕНЬШИЙ(ЕСЛИ(НАИМЕНЬШИЙ(ЕСЛИ((Т(+$F$26:$AG$26)>"")*ЕЧИСЛО(ПОИСК($F30&"_";$F$26:$AG$26));СТОЛБЕЦ($F:$AG);99);СТРОКА($1:$9))=ПРОСМОТР(СТОЛБЕЦ($F:$AG);ЕСЛИ(Т(+$F$26:$AG$26)>"";СТОЛБЕЦ($F:$AG)));СТОЛБЕЦ($F:$AG));СТОЛБЕЦ(A31)));"")
И для двух:
Код
=ЕСЛИОШИБКА(ИНДЕКС($26:$26;;НАИМЕНЬШИЙ(ЕСЛИ(НАИМЕНЬШИЙ(ЕСЛИ((Т(+$F$26:$AG$26)>"")*(ЕЧИСЛО(ПОИСК($F34&"_";$F$26:$AG$26))+ЕЧИСЛО(ПОИСК($G34&"_";$F$26:$AG$26)));СТОЛБЕЦ($F:$AG);99);СТРОКА($1:$9))=ПРОСМОТР(СТОЛБЕЦ($F:$AG);ЕСЛИ(Т(+$F$26:$AG$26)>"";СТОЛБЕЦ($F:$AG)));СТОЛБЕЦ($F:$AG));СТОЛБЕЦ(A35)));"")
*Или для двух можно попробовать так:
Код
=ЕСЛИОШИБКА(ИНДЕКС($26:$26;;НАИМЕНЬШИЙ(ЕСЛИ(НАИМЕНЬШИЙ(ЕСЛИ((Т(+$F$26:$AG$26)>"")*ЕЧИСЛО(ПОИСК(ТРАНСП($F34:$G34)&"_";$F$26:$AG$26));СТОЛБЕЦ($F:$AG);99);СТРОКА($1:$9))=ПРОСМОТР(СТОЛБЕЦ($F:$AG);ЕСЛИ(Т(+$F$26:$AG$26)>"";СТОЛБЕЦ($F:$AG)));СТОЛБЕЦ($F:$AG));СТОЛБЕЦ(A35)));"")

Автор - Светлый
Дата добавления - 31.08.2019 в 13:02
Светлый Дата: Суббота, 31.08.2019, 18:41 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1272
Репутация: 322 ±
Замечаний: 0% ±

Excel 2010
Немного причесал формулы:
Код
=ИНДЕКС($26:$26;;НАИМЕНЬШИЙ(ЕСЛИ(ПРОСМОТР(СТОЛБЕЦ($F:$AG);ЕСЛИ($F$26:$AG$26>"";СТОЛБЕЦ($F:$AG)))=НАИБОЛЬШИЙ(ЕЧИСЛО(ПОИСК($F30&"_";$F$26:$AG$26))*СТОЛБЕЦ($F:$AG);СТРОКА($1:$9));СТОЛБЕЦ($F:$AG);99);СТОЛБЕЦ(A31)))
Код
=ИНДЕКС($26:$26;;НАИМЕНЬШИЙ(ЕСЛИ(ПРОСМОТР(СТОЛБЕЦ($F:$AG);ЕСЛИ($F$26:$AG$26>"";СТОЛБЕЦ($F:$AG)))=НАИБОЛЬШИЙ(ЕЧИСЛО(ПОИСК(ТРАНСП($F34:$G34)&"_";$F$26:$AG$26))*СТОЛБЕЦ($F:$AG);СТРОКА($1:$9));СТОЛБЕЦ($F:$AG);99);СТОЛБЕЦ(A35)))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеНемного причесал формулы:
Код
=ИНДЕКС($26:$26;;НАИМЕНЬШИЙ(ЕСЛИ(ПРОСМОТР(СТОЛБЕЦ($F:$AG);ЕСЛИ($F$26:$AG$26>"";СТОЛБЕЦ($F:$AG)))=НАИБОЛЬШИЙ(ЕЧИСЛО(ПОИСК($F30&"_";$F$26:$AG$26))*СТОЛБЕЦ($F:$AG);СТРОКА($1:$9));СТОЛБЕЦ($F:$AG);99);СТОЛБЕЦ(A31)))
Код
=ИНДЕКС($26:$26;;НАИМЕНЬШИЙ(ЕСЛИ(ПРОСМОТР(СТОЛБЕЦ($F:$AG);ЕСЛИ($F$26:$AG$26>"";СТОЛБЕЦ($F:$AG)))=НАИБОЛЬШИЙ(ЕЧИСЛО(ПОИСК(ТРАНСП($F34:$G34)&"_";$F$26:$AG$26))*СТОЛБЕЦ($F:$AG);СТРОКА($1:$9));СТОЛБЕЦ($F:$AG);99);СТОЛБЕЦ(A35)))

Автор - Светлый
Дата добавления - 31.08.2019 в 18:41
stalber Дата: Воскресенье, 01.09.2019, 10:06 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 265
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Благодарю!
Вопрос:
Я убрал знаки доллара, чтобы можно было формулу вниз растягивать:
Код
=ИНДЕКС(26:26;;НАИМЕНЬШИЙ(ЕСЛИ(ПРОСМОТР(СТОЛБЕЦ($F:$IB);ЕСЛИ($F26:$IB26>"";СТОЛБЕЦ($F:$IB)))=НАИБОЛЬШИЙ(ЕЧИСЛО(ПОИСК(ТРАНСП($J$25:$K$25)&"_";$F26:$IB26))*СТОЛБЕЦ($F:$IB);СТРОКА($1:$9));СТОЛБЕЦ($F:$IB);99);СТОЛБЕЦ(A36)))

Насколько вниз её можно тянуть? в формуе есть какое то ограничение? (мне нужно будет вниз до 340 включительно строки растянуть)

И вопрос ещё: в листе "kniga" я нажал на ячейку F37 (ctrl+x) и хотел перенести на другой лист Лист1 и там вставить в ячейку F26 но не получается. Обьясните пожалуйста что я делаю не так.
К сообщению приложен файл: vopros01092019.xlsx(12.4 Kb)
 
Ответить
СообщениеБлагодарю!
Вопрос:
Я убрал знаки доллара, чтобы можно было формулу вниз растягивать:
Код
=ИНДЕКС(26:26;;НАИМЕНЬШИЙ(ЕСЛИ(ПРОСМОТР(СТОЛБЕЦ($F:$IB);ЕСЛИ($F26:$IB26>"";СТОЛБЕЦ($F:$IB)))=НАИБОЛЬШИЙ(ЕЧИСЛО(ПОИСК(ТРАНСП($J$25:$K$25)&"_";$F26:$IB26))*СТОЛБЕЦ($F:$IB);СТРОКА($1:$9));СТОЛБЕЦ($F:$IB);99);СТОЛБЕЦ(A36)))

Насколько вниз её можно тянуть? в формуе есть какое то ограничение? (мне нужно будет вниз до 340 включительно строки растянуть)

И вопрос ещё: в листе "kniga" я нажал на ячейку F37 (ctrl+x) и хотел перенести на другой лист Лист1 и там вставить в ячейку F26 но не получается. Обьясните пожалуйста что я делаю не так.

Автор - stalber
Дата добавления - 01.09.2019 в 10:06
Светлый Дата: Воскресенье, 01.09.2019, 10:43 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1272
Репутация: 322 ±
Замечаний: 0% ±

Excel 2010
Ограничение только справа, но можно 99 заменить на 999.
А копирование не удалось, потому что
Я убрал знаки доллара, чтобы можно было формулу вниз растягивать:
*Копируйте текст формулы, а не ячейку.
**Скопируйте ячейку, а потом исправьте все ссылки и массивы с учётом листа.
***Исправил. См. в файле. Можно использовать одну универсальную формулу, но во второй ячейке образца задать несуществующее значение.
К сообщению приложен файл: vopros01092019-.xlsx(14.7 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Воскресенье, 01.09.2019, 13:14
 
Ответить
СообщениеОграничение только справа, но можно 99 заменить на 999.
А копирование не удалось, потому что
Я убрал знаки доллара, чтобы можно было формулу вниз растягивать:
*Копируйте текст формулы, а не ячейку.
**Скопируйте ячейку, а потом исправьте все ссылки и массивы с учётом листа.
***Исправил. См. в файле. Можно использовать одну универсальную формулу, но во второй ячейке образца задать несуществующее значение.

Автор - Светлый
Дата добавления - 01.09.2019 в 10:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести определённые данные, ориентир - левая часть слова (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!