Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как найти предположительные дубли кодов формулой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как найти предположительные дубли кодов формулой (Формулы/Formulas)
Как найти предположительные дубли кодов формулой
serewka Дата: Понедельник, 09.09.2019, 10:55 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Сделана с базы выгрузка клиентов. Код клиента состоит из 14-ти уникальных символов. Найти дубли кодов клиентов возможно через "Сводную таблицу" или "Условное форматирование". В списке есть коды, в которых возможно допущены ошибки, в одном или двух символах.
Задача: Как найти такие коды формулой или как-то подсветить их. Т.е. нужно найти коды, которые возможно будут дублями, что бы перепроверить их. Список кодов может достигать до 10 тысяч. Возможно ли как-то это?
К сообщению приложен файл: 3130324.xlsx(9.7 Kb)
 
Ответить
СообщениеСделана с базы выгрузка клиентов. Код клиента состоит из 14-ти уникальных символов. Найти дубли кодов клиентов возможно через "Сводную таблицу" или "Условное форматирование". В списке есть коды, в которых возможно допущены ошибки, в одном или двух символах.
Задача: Как найти такие коды формулой или как-то подсветить их. Т.е. нужно найти коды, которые возможно будут дублями, что бы перепроверить их. Список кодов может достигать до 10 тысяч. Возможно ли как-то это?

Автор - serewka
Дата добавления - 09.09.2019 в 10:55
Nic70y Дата: Понедельник, 09.09.2019, 11:26 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5607
Репутация: 1227 ±
Замечаний: 0% ±

ru13;10;03
массивная
Код
=СУММ(--ЕЧИСЛО(ПОИСКПОЗ(ЗАМЕНИТЬ(C4;СТРОКА(A$1:A$14);1;"*");C5:C$11000;)))+СУММ(--ЕЧИСЛО(ПОИСКПОЗ(ЗАМЕНИТЬ(C4;СТРОКА(A$1:A$14);1;"*");C$1:C3;)))
немного переборщил, наскоряк написал, можно так
Код
=СУММ(ЕЧИСЛО(ПОИСКПОЗ(ЗАМЕНИТЬ(C4;СТРОКА(A$1:A$14);1;"*");C5:C$11000;))+ЕЧИСЛО(ПОИСКПОЗ(ЗАМЕНИТЬ(C4;СТРОКА(A$1:A$14);1;"*");C$1:C3;)))
К сообщению приложен файл: 6265708.xlsx(10.6 Kb)


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Понедельник, 09.09.2019, 12:36
 
Ответить
Сообщениемассивная
Код
=СУММ(--ЕЧИСЛО(ПОИСКПОЗ(ЗАМЕНИТЬ(C4;СТРОКА(A$1:A$14);1;"*");C5:C$11000;)))+СУММ(--ЕЧИСЛО(ПОИСКПОЗ(ЗАМЕНИТЬ(C4;СТРОКА(A$1:A$14);1;"*");C$1:C3;)))
немного переборщил, наскоряк написал, можно так
Код
=СУММ(ЕЧИСЛО(ПОИСКПОЗ(ЗАМЕНИТЬ(C4;СТРОКА(A$1:A$14);1;"*");C5:C$11000;))+ЕЧИСЛО(ПОИСКПОЗ(ЗАМЕНИТЬ(C4;СТРОКА(A$1:A$14);1;"*");C$1:C3;)))

Автор - Nic70y
Дата добавления - 09.09.2019 в 11:26
serewka Дата: Понедельник, 09.09.2019, 16:49 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Nic70y, спасибо большое за работу, но вот не пойму как работает и у меня не сработало, файл прикрепляю (например, первые три кода - возможна в одном ошибка и их нужно перепроверить), но формула не сработала
К сообщению приложен файл: 6265708-2-.xlsx(9.8 Kb)
 
Ответить
СообщениеNic70y, спасибо большое за работу, но вот не пойму как работает и у меня не сработало, файл прикрепляю (например, первые три кода - возможна в одном ошибка и их нужно перепроверить), но формула не сработала

Автор - serewka
Дата добавления - 09.09.2019 в 16:49
Nic70y Дата: Понедельник, 09.09.2019, 17:36 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 5607
Репутация: 1227 ±
Замечаний: 0% ±

ru13;10;03
держите
К сообщению приложен файл: 0219216.xlsx(9.9 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениедержите

Автор - Nic70y
Дата добавления - 09.09.2019 в 17:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как найти предположительные дубли кодов формулой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!