Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как разделить столбец на числа и числа с буквами - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как разделить столбец на числа и числа с буквами (Формулы/Formulas)
Как разделить столбец на числа и числа с буквами
Tort Дата: Вторник, 17.09.2019, 12:53 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
Здравствуйте, не могу догнать как переделать формулу в таблице. Есть столбец в ячейках которых прописаны числа с буквами и просто числа, вот мне надо чтобы в соседнем столбце вывелись ячейки только с числами и буквами
Код
=ЕСЛИ(ЕОШ(ПОИСК("ОЛ";$P2));P2;"")


Пример:

ЕСТЬ: НУЖНО:
1ОЛ1 1ОЛ1
2ОЛ1 2ОЛ1
1
3ОЛ2 3ОЛ2
2


Сообщение отредактировал Tort - Вторник, 17.09.2019, 14:07
 
Ответить
СообщениеЗдравствуйте, не могу догнать как переделать формулу в таблице. Есть столбец в ячейках которых прописаны числа с буквами и просто числа, вот мне надо чтобы в соседнем столбце вывелись ячейки только с числами и буквами
Код
=ЕСЛИ(ЕОШ(ПОИСК("ОЛ";$P2));P2;"")


Пример:

ЕСТЬ: НУЖНО:
1ОЛ1 1ОЛ1
2ОЛ1 2ОЛ1
1
3ОЛ2 3ОЛ2
2

Автор - Tort
Дата добавления - 17.09.2019 в 12:53
Tort Дата: Вторник, 17.09.2019, 14:08 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
Есть кто? :)
 
Ответить
СообщениеЕсть кто? :)

Автор - Tort
Дата добавления - 17.09.2019 в 14:08
Kostya_Ye Дата: Вторник, 17.09.2019, 14:17 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 16 ±
Замечаний: 0% ±

Excel 2016
По правилам нужен пример в Экселе, а не в сообщении. ;)

Ну здесь и так вроде понятно. поменяйте местами Р2 и "".
 
Ответить
СообщениеПо правилам нужен пример в Экселе, а не в сообщении. ;)

Ну здесь и так вроде понятно. поменяйте местами Р2 и "".

Автор - Kostya_Ye
Дата добавления - 17.09.2019 в 14:17
Kashimirush Дата: Вторник, 17.09.2019, 14:19 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 4 ±
Замечаний: 0% ±

Excel 2010
Ознакомьтесь с функцией тип. Если все числовые значения у вас имеют числовой формат. то сработает такая формула:
Код
=ЕСЛИ(ТИП(A1)=2;A1;"")

[offtop]Тип значения Функция ТИП возвращает

Число 1

Текст 2

Логическое значение 4

Значение ошибки 16

Массив 64[/offtop]


Работа, работа, перейди на Федота...
 
Ответить
СообщениеОзнакомьтесь с функцией тип. Если все числовые значения у вас имеют числовой формат. то сработает такая формула:
Код
=ЕСЛИ(ТИП(A1)=2;A1;"")

[offtop]Тип значения Функция ТИП возвращает

Число 1

Текст 2

Логическое значение 4

Значение ошибки 16

Массив 64[/offtop]

Автор - Kashimirush
Дата добавления - 17.09.2019 в 14:19
Tort Дата: Вторник, 17.09.2019, 14:26 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
Ну здесь и так вроде понятно. поменяйте местами Р2 и "".

неа, не работает
Ознакомьтесь с функцией тип. Если все числовые значения у вас имеют числовой формат. то сработает такая формула:

нет не числовой формат, там формулы и ссылки
К сообщению приложен файл: 4220116.xlsx(45.1 Kb)
 
Ответить
Сообщение
Ну здесь и так вроде понятно. поменяйте местами Р2 и "".

неа, не работает
Ознакомьтесь с функцией тип. Если все числовые значения у вас имеют числовой формат. то сработает такая формула:

нет не числовой формат, там формулы и ссылки

Автор - Tort
Дата добавления - 17.09.2019 в 14:26
Nic70y Дата: Вторник, 17.09.2019, 14:40 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 5681
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
так?
Код
=ЕСЛИ(ЕОШ(B2^1);B2&C2;"")


ЯД(poison) 41001841029809
 
Ответить
Сообщениетак?
Код
=ЕСЛИ(ЕОШ(B2^1);B2&C2;"")

Автор - Nic70y
Дата добавления - 17.09.2019 в 14:40
Tort Дата: Вторник, 17.09.2019, 14:50 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
Почти, а можно это все действие сделать через "P" столбец. Т.к если делать через "B" формула захватывает значения через точку( 4 1.1 и т.д), а они мне не нужны? Или исключить эти значения как то в формуле?


Сообщение отредактировал Tort - Вторник, 17.09.2019, 14:51
 
Ответить
СообщениеПочти, а можно это все действие сделать через "P" столбец. Т.к если делать через "B" формула захватывает значения через точку( 4 1.1 и т.д), а они мне не нужны? Или исключить эти значения как то в формуле?

Автор - Tort
Дата добавления - 17.09.2019 в 14:50
Nic70y Дата: Вторник, 17.09.2019, 15:00 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 5681
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
Код
=ЕСЛИ(ЕОШ(ПОДСТАВИТЬ(P2;".";ПСТР(7/8;2;1))^1);P2;"")


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕОШ(ПОДСТАВИТЬ(P2;".";ПСТР(7/8;2;1))^1);P2;"")

Автор - Nic70y
Дата добавления - 17.09.2019 в 15:00
Tort Дата: Вторник, 17.09.2019, 15:02 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
Огромное спасибо все получилось hands
 
Ответить
СообщениеОгромное спасибо все получилось hands

Автор - Tort
Дата добавления - 17.09.2019 в 15:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как разделить столбец на числа и числа с буквами (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!