Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как посчитать формулой в массиве несколько условий в диапозо - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать формулой в массиве несколько условий в диапозо (Формулы/Formulas)
Как посчитать формулой в массиве несколько условий в диапозо
Olga2007 Дата: Воскресенье, 22.09.2019, 23:55 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Прошу помочь посчитать формулой в массиве сумму значений в диапазоне, если в другом диапазоне больше чем одно условие.
К сообщению приложен файл: __.xlsx(13.4 Kb)
 
Ответить
СообщениеПрошу помочь посчитать формулой в массиве сумму значений в диапазоне, если в другом диапазоне больше чем одно условие.

Автор - Olga2007
Дата добавления - 22.09.2019 в 23:55
прохожий2019 Дата: Понедельник, 23.09.2019, 08:09 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 8 ±
Замечаний: 0% ±

Excel 2016
Код
=СУММПРОИЗВ(($C$3:$C$26=C3)*($E$3:$E$26=E3)*$K$3:$K$26*(1-ЕОШ(ПОИСК("Альфа";$H$3:$H$26))))
К сообщению приложен файл: 2953275.xlsx(14.1 Kb)


Сообщение отредактировал прохожий2019 - Понедельник, 23.09.2019, 08:21
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(($C$3:$C$26=C3)*($E$3:$E$26=E3)*$K$3:$K$26*(1-ЕОШ(ПОИСК("Альфа";$H$3:$H$26))))

Автор - прохожий2019
Дата добавления - 23.09.2019 в 08:09
Nic70y Дата: Понедельник, 23.09.2019, 08:58 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 5687
Репутация: 1248 ±
Замечаний: 0% ±

ru13;10;03
еще вариант
Код
=СУММЕСЛИМН(K$3:K$26;C$3:C$26;C3;E$3:E$26;E3;H$3:H$26;"*Золотая Альфа*")


ЯД(poison) 41001841029809
 
Ответить
Сообщениееще вариант
Код
=СУММЕСЛИМН(K$3:K$26;C$3:C$26;C3;E$3:E$26;E3;H$3:H$26;"*Золотая Альфа*")

Автор - Nic70y
Дата добавления - 23.09.2019 в 08:58
Olga2007 Дата: Понедельник, 23.09.2019, 12:34 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Цитата прохожий2019, 23.09.2019 в 08:09, в сообщении № 2 ()
=СУММПРОИЗВ(($C$3:$C$26=C3)*($E$3:$E$26=E3)*$K$3:$K$26*(1-ЕОШ(ПОИСК("Альфа";$H$3:$H$26))))

Спасибо, работает супер! А можно подобные формулы в сводные таблицы в вычисляемое поля применять?
К сообщению приложен файл: 0394808.xlsx(23.7 Kb)
 
Ответить
Сообщение
Цитата прохожий2019, 23.09.2019 в 08:09, в сообщении № 2 ()
=СУММПРОИЗВ(($C$3:$C$26=C3)*($E$3:$E$26=E3)*$K$3:$K$26*(1-ЕОШ(ПОИСК("Альфа";$H$3:$H$26))))

Спасибо, работает супер! А можно подобные формулы в сводные таблицы в вычисляемое поля применять?

Автор - Olga2007
Дата добавления - 23.09.2019 в 12:34
прохожий2019 Дата: Понедельник, 23.09.2019, 13:20 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 8 ±
Замечаний: 0% ±

Excel 2016
Olga2007 - можно много чего сделать - вопрос конкретной задачи - DAX позволяет фильтровать в том числе
 
Ответить
СообщениеOlga2007 - можно много чего сделать - вопрос конкретной задачи - DAX позволяет фильтровать в том числе

Автор - прохожий2019
Дата добавления - 23.09.2019 в 13:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать формулой в массиве несколько условий в диапозо (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!