Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/накопительные данные в массиве по группам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » накопительные данные в массиве по группам (Формулы/Formulas)
накопительные данные в массиве по группам
Andrey_svk Дата: Вторник, 24.09.2019, 15:13 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
необходимо чтоб накопительный процент работал в массиве но по каждой группе накапливался внутри данной группы
К сообщению приложен файл: ___.xlsx(12.6 Kb)
 
Ответить
Сообщениенеобходимо чтоб накопительный процент работал в массиве но по каждой группе накапливался внутри данной группы

Автор - Andrey_svk
Дата добавления - 24.09.2019 в 15:13
прохожий2019 Дата: Вторник, 24.09.2019, 15:23 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 8 ±
Замечаний: 0% ±

Excel 2016
если правильно понял
Код
=ЕСЛИ(D8=0;" ";СУММЕСЛИ($B$1:B8;B8;$D$1:D8)/СУММЕСЛИ($B:$B;B8;$D:$D))
К сообщению приложен файл: 9098477.xlsx(13.0 Kb)
 
Ответить
Сообщениеесли правильно понял
Код
=ЕСЛИ(D8=0;" ";СУММЕСЛИ($B$1:B8;B8;$D$1:D8)/СУММЕСЛИ($B:$B;B8;$D:$D))

Автор - прохожий2019
Дата добавления - 24.09.2019 в 15:23
Andrey_svk Дата: Вторник, 24.09.2019, 15:39 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
в принципе да, только забыл написать чтоб накапливает % от максимальной суммы к минимальной
Спасибо)

К сообщению приложен файл: 3078512.xlsx(12.0 Kb)
 
Ответить
Сообщениев принципе да, только забыл написать чтоб накапливает % от максимальной суммы к минимальной
Спасибо)


Автор - Andrey_svk
Дата добавления - 24.09.2019 в 15:39
Andrey_svk Дата: Вторник, 24.09.2019, 15:44 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
прохожий2019, спасибо большое, но чуток не так)))
 
Ответить
Сообщениепрохожий2019, спасибо большое, но чуток не так)))

Автор - Andrey_svk
Дата добавления - 24.09.2019 в 15:44
Pelena Дата: Вторник, 24.09.2019, 15:58 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 14579
Репутация: 3192 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Всё так, просто сделайте двухуровневую сортировку: первый уровень по группе, второй - по убыванию суммы
К сообщению приложен файл: 6241912.xlsx(13.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВсё так, просто сделайте двухуровневую сортировку: первый уровень по группе, второй - по убыванию суммы

Автор - Pelena
Дата добавления - 24.09.2019 в 15:58
прохожий2019 Дата: Вторник, 24.09.2019, 15:59 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 8 ±
Замечаний: 0% ±

Excel 2016
как-то так
Код
=ЕСЛИ(ЕЧИСЛО(D8);СУММЕСЛИМН($D$5:$D$48;$B$5:$B$48;B8;$D$5:$D$48;">="&D8)/СУММЕСЛИ($B$5:$B$48;B8;$D$5:$D$48);"")
К сообщению приложен файл: 1228486.xlsx(13.1 Kb)
 
Ответить
Сообщениекак-то так
Код
=ЕСЛИ(ЕЧИСЛО(D8);СУММЕСЛИМН($D$5:$D$48;$B$5:$B$48;B8;$D$5:$D$48;">="&D8)/СУММЕСЛИ($B$5:$B$48;B8;$D$5:$D$48);"")

Автор - прохожий2019
Дата добавления - 24.09.2019 в 15:59
Andrey_svk Дата: Вторник, 24.09.2019, 16:13 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
прохожий2019, Спасибо бро) огонь!!! Все работает)))
 
Ответить
Сообщениепрохожий2019, Спасибо бро) огонь!!! Все работает)))

Автор - Andrey_svk
Дата добавления - 24.09.2019 в 16:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » накопительные данные в массиве по группам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!