Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как в excel объединить повторяющиеся ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как в excel объединить повторяющиеся ячейки (Формулы/Formulas)
Как в excel объединить повторяющиеся ячейки
tarapyneshka Дата: Четверг, 03.10.2019, 20:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день. Подскажите как в excel объединить значения в повторяющихся ячейках. Например:
08/125 7250,01
08/125 123,54
08/125 84,21
10/651 1247
10/651 14569,8
13/520 12589,2
13/520 4921,6
Вот такие есть данные, нужно чтоб можно было объединить и получить вот так:
08/125 7457,76
10/651 15816,8
13/520 17510,8

Подскажите как это сделать? Спасибо.
 
Ответить
СообщениеДобрый день. Подскажите как в excel объединить значения в повторяющихся ячейках. Например:
08/125 7250,01
08/125 123,54
08/125 84,21
10/651 1247
10/651 14569,8
13/520 12589,2
13/520 4921,6
Вот такие есть данные, нужно чтоб можно было объединить и получить вот так:
08/125 7457,76
10/651 15816,8
13/520 17510,8

Подскажите как это сделать? Спасибо.

Автор - tarapyneshka
Дата добавления - 03.10.2019 в 20:39
Pelena Дата: Четверг, 03.10.2019, 20:43 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14579
Репутация: 3192 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Можно сводной таблицей.
Подробнее при наличии файла с примером


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Можно сводной таблицей.
Подробнее при наличии файла с примером

Автор - Pelena
Дата добавления - 03.10.2019 в 20:43
Светлый Дата: Четверг, 03.10.2019, 22:54 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1299
Репутация: 325 ±
Замечаний: 0% ±

Excel 2010
Можно массивной (Ctrl+Shift+Enter) формулой, если данные в одном столбце:
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(ДЛСТР(МУМНОЖ(Ч(ЛЕВБ(A$1:A$7;ПОИСК(" ";A$1:A$7))=ТРАНСП(ЛЕВБ(A$1:A$7;ПОИСК(" ";A$1:A$7))));10^СТРОКА($1:$7)))-1=СТРОКА($1:$7);СТРОКА($1:$7));СТРОКА(A1)));" ";ПОВТОР(" ";99));99))&" "&СУММ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(A$1:A$7;СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(ДЛСТР(МУМНОЖ(Ч(ЛЕВБ(A$1:A$7;ПОИСК(" ";A$1:A$7))=ТРАНСП(ЛЕВБ(A$1:A$7;ПОИСК(" ";A$1:A$7))));10^СТРОКА($1:$7)))-1=СТРОКА($1:$7);СТРОКА($1:$7));СТРОКА(A1)));" ";ПОВТОР(" ";99));99)););));"")
Если в двух столбцах, формулы будут попроще.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеМожно массивной (Ctrl+Shift+Enter) формулой, если данные в одном столбце:
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(ДЛСТР(МУМНОЖ(Ч(ЛЕВБ(A$1:A$7;ПОИСК(" ";A$1:A$7))=ТРАНСП(ЛЕВБ(A$1:A$7;ПОИСК(" ";A$1:A$7))));10^СТРОКА($1:$7)))-1=СТРОКА($1:$7);СТРОКА($1:$7));СТРОКА(A1)));" ";ПОВТОР(" ";99));99))&" "&СУММ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(A$1:A$7;СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(ДЛСТР(МУМНОЖ(Ч(ЛЕВБ(A$1:A$7;ПОИСК(" ";A$1:A$7))=ТРАНСП(ЛЕВБ(A$1:A$7;ПОИСК(" ";A$1:A$7))));10^СТРОКА($1:$7)))-1=СТРОКА($1:$7);СТРОКА($1:$7));СТРОКА(A1)));" ";ПОВТОР(" ";99));99)););));"")
Если в двух столбцах, формулы будут попроще.

Автор - Светлый
Дата добавления - 03.10.2019 в 22:54
Светлый Дата: Пятница, 04.10.2019, 07:33 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1299
Репутация: 325 ±
Замечаний: 0% ±

Excel 2010
Немного упростил формулу:
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ(ЛЕВБ(A$1:A$7;ПОИСК(" ";A$1:A$7))&"*";A$1:A$7;)=СТРОКА($1:$7);СТРОКА($1:$7));СТРОКА(A1)));" ";"        ");9))&" "&СУММ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(A$1:A$7;СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ(ЛЕВБ(A$1:A$7;ПОИСК(" ";A$1:A$7))&"*";A$1:A$7;)=СТРОКА($1:$7);СТРОКА($1:$7));СТРОКА(A1)));" ";"        ");9)););));"")
*Или ещё проще:
Код
=ЕСЛИОШИБКА(ИНДЕКС(ЛЕВБ(A$1:A$7;ПОИСК(" ";A$1:A$7))&МУМНОЖ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(ТРАНСП(A$1:A$7);ЛЕВБ(A$1:A$7;ПОИСК(" ";A$1:A$7));););1^СТРОКА($1:$7));НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ(ЛЕВБ(A$1:A$7;ПОИСК(" ";A$1:A$7))&"*";A$1:A$7;)=СТРОКА($1:$7);СТРОКА($1:$7));СТРОКА(A1)));"")
А если левая часть всегда 6 символов, то формула совсем простая:
Код
=ЕСЛИОШИБКА(ИНДЕКС(ЛЕВБ(A$1:A$7;7)&МУМНОЖ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(ТРАНСП(A$1:A$7);ЛЕВБ(A$1:A$7;7);););1^СТРОКА($1:$7));НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ(ЛЕВБ(A$1:A$7;7)&"*";A$1:A$7;)=СТРОКА($1:$7);СТРОКА($1:$7));СТРОКА(A1)));"")


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 04.10.2019, 08:05
 
Ответить
СообщениеНемного упростил формулу:
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ(ЛЕВБ(A$1:A$7;ПОИСК(" ";A$1:A$7))&"*";A$1:A$7;)=СТРОКА($1:$7);СТРОКА($1:$7));СТРОКА(A1)));" ";"        ");9))&" "&СУММ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(A$1:A$7;СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ(ЛЕВБ(A$1:A$7;ПОИСК(" ";A$1:A$7))&"*";A$1:A$7;)=СТРОКА($1:$7);СТРОКА($1:$7));СТРОКА(A1)));" ";"        ");9)););));"")
*Или ещё проще:
Код
=ЕСЛИОШИБКА(ИНДЕКС(ЛЕВБ(A$1:A$7;ПОИСК(" ";A$1:A$7))&МУМНОЖ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(ТРАНСП(A$1:A$7);ЛЕВБ(A$1:A$7;ПОИСК(" ";A$1:A$7));););1^СТРОКА($1:$7));НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ(ЛЕВБ(A$1:A$7;ПОИСК(" ";A$1:A$7))&"*";A$1:A$7;)=СТРОКА($1:$7);СТРОКА($1:$7));СТРОКА(A1)));"")
А если левая часть всегда 6 символов, то формула совсем простая:
Код
=ЕСЛИОШИБКА(ИНДЕКС(ЛЕВБ(A$1:A$7;7)&МУМНОЖ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(ТРАНСП(A$1:A$7);ЛЕВБ(A$1:A$7;7);););1^СТРОКА($1:$7));НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ(ЛЕВБ(A$1:A$7;7)&"*";A$1:A$7;)=СТРОКА($1:$7);СТРОКА($1:$7));СТРОКА(A1)));"")

Автор - Светлый
Дата добавления - 04.10.2019 в 07:33
tarapyneshka Дата: Пятница, 04.10.2019, 10:25 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо большое. А можно я скину файл, это для меня просто что-то непостижимое((
К сообщению приложен файл: 1985230.xlsx(11.2 Kb)
 
Ответить
СообщениеСпасибо большое. А можно я скину файл, это для меня просто что-то непостижимое((

Автор - tarapyneshka
Дата добавления - 04.10.2019 в 10:25
Nic70y Дата: Пятница, 04.10.2019, 11:09 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 5681
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
в файле варианты:
- сводной
- доп.столбец + ВПР +СУММЕСЛИ
К сообщению приложен файл: 7702211.xlsx(22.2 Kb)


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Пятница, 04.10.2019, 11:10
 
Ответить
Сообщениев файле варианты:
- сводной
- доп.столбец + ВПР +СУММЕСЛИ

Автор - Nic70y
Дата добавления - 04.10.2019 в 11:09
Светлый Дата: Пятница, 04.10.2019, 20:04 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1299
Репутация: 325 ±
Замечаний: 0% ±

Excel 2010
И мой файлик.
К сообщению приложен файл: 1985230-1.xlsx(14.4 Kb)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеИ мой файлик.

Автор - Светлый
Дата добавления - 04.10.2019 в 20:04
tarapyneshka Дата: Пятница, 04.10.2019, 21:18 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Вы волшебники))) hands hands hands hands Спасибо огромное))) Теперь бы понять как это самой сделать на другом примере)))
 
Ответить
СообщениеВы волшебники))) hands hands hands hands Спасибо огромное))) Теперь бы понять как это самой сделать на другом примере)))

Автор - tarapyneshka
Дата добавления - 04.10.2019 в 21:18
bmv98rus Дата: Суббота, 05.10.2019, 09:03 | Сообщение № 9
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2627
Репутация: 451 ±
Замечаний: 0% ±

Excel 2013/2016
Светлый, Избушку недовключили :-)
Код
=IFERROR(INDEX(A:A;MATCH(1=1;COUNTIF(G$1:G1;A$1:A$106)=0;));"")


Но исходя из формата данных и задачи - конечно сводная.
К сообщению приложен файл: Copy_of_1169.xlsx(16.6 Kb)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеСветлый, Избушку недовключили :-)
Код
=IFERROR(INDEX(A:A;MATCH(1=1;COUNTIF(G$1:G1;A$1:A$106)=0;));"")


Но исходя из формата данных и задачи - конечно сводная.

Автор - bmv98rus
Дата добавления - 05.10.2019 в 09:03
китин Дата: Суббота, 05.10.2019, 09:23 | Сообщение № 10
Группа: Модераторы
Ранг: Экселист
Сообщений: 5882
Репутация: 914 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Но исходя из формата данных и задачи - конечно

Power Query
К сообщению приложен файл: 8801156.xlsx(22.8 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Но исходя из формата данных и задачи - конечно

Power Query

Автор - китин
Дата добавления - 05.10.2019 в 09:23
bmv98rus Дата: Суббота, 05.10.2019, 10:11 | Сообщение № 11
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2627
Репутация: 451 ±
Замечаний: 0% ±

Excel 2013/2016
Ну что , волшебники, все отметились. И Модераторы, и медвежаторы, и " его Светлость" , название темы то, так себе. :D


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Суббота, 05.10.2019, 10:12
 
Ответить
СообщениеНу что , волшебники, все отметились. И Модераторы, и медвежаторы, и " его Светлость" , название темы то, так себе. :D

Автор - bmv98rus
Дата добавления - 05.10.2019 в 10:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как в excel объединить повторяющиеся ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!