Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Есть ли хотя бы 1 непустая ячейка в диапазоне? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Есть ли хотя бы 1 непустая ячейка в диапазоне? (Формулы/Formulas)
Есть ли хотя бы 1 непустая ячейка в диапазоне?
arxon Дата: Вторник, 08.10.2019, 10:51 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Господа, здравствуйте!
хотел написать многосоставную формулу, но ничего не вышло. Может тут сможете помочь.
Имеется список категорий: например категория1, категория2, категория3
Есть также диапазоны, которые связаны (соответсвенно) с данными категориями. например А1:С1, потом D1:F1, потом G1:I1.

Что нужно:
Написать 1 формулу, которая проверяет диапазоны, и если в нем имеется ХОТЯ БЫ ОДНА НЕпустая ячейка, то формула возвращает Наименование категории.

Например: A1 пусто, B1 НЕпусто, С1 пусто. Значит Категория1
или
D1 пусто, E1 НЕпусто, F1 НЕ пусто. Значит Категория2

файл-пример прикладываю
К сообщению приложен файл: ____.xlsx(11.1 Kb)
 
Ответить
СообщениеГоспода, здравствуйте!
хотел написать многосоставную формулу, но ничего не вышло. Может тут сможете помочь.
Имеется список категорий: например категория1, категория2, категория3
Есть также диапазоны, которые связаны (соответсвенно) с данными категориями. например А1:С1, потом D1:F1, потом G1:I1.

Что нужно:
Написать 1 формулу, которая проверяет диапазоны, и если в нем имеется ХОТЯ БЫ ОДНА НЕпустая ячейка, то формула возвращает Наименование категории.

Например: A1 пусто, B1 НЕпусто, С1 пусто. Значит Категория1
или
D1 пусто, E1 НЕпусто, F1 НЕ пусто. Значит Категория2

файл-пример прикладываю

Автор - arxon
Дата добавления - 08.10.2019 в 10:51
Pelena Дата: Вторник, 08.10.2019, 11:01 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14585
Репутация: 3196 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте. У Вас там не пустые ячейки, а с пробелами.
Пробелы можно удалить или они имеют какое-то значение?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте. У Вас там не пустые ячейки, а с пробелами.
Пробелы можно удалить или они имеют какое-то значение?

Автор - Pelena
Дата добавления - 08.10.2019 в 11:01
arxon Дата: Вторник, 08.10.2019, 11:14 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
пробелы случайно проставил, извините. нужно пустые, конечно
 
Ответить
Сообщениепробелы случайно проставил, извините. нужно пустые, конечно

Автор - arxon
Дата добавления - 08.10.2019 в 11:14
Nic70y Дата: Вторник, 08.10.2019, 11:38 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 5687
Репутация: 1248 ±
Замечаний: 0% ±

ru13;10;03
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ИНДЕКС(A$1:I$1;ПОИСКПОЗ("*";A2:I2;));".";ПОВТОР(" ";97));97));"")
К сообщению приложен файл: 6658539.xlsx(10.0 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ИНДЕКС(A$1:I$1;ПОИСКПОЗ("*";A2:I2;));".";ПОВТОР(" ";97));97));"")

Автор - Nic70y
Дата добавления - 08.10.2019 в 11:38
arxon Дата: Вторник, 08.10.2019, 12:08 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ИНДЕКС(A$1:I$1;ПОИСКПОЗ("*";A2:I2;));".";ПОВТОР(" ";97));97));"")

Спасибо, но в формуле нет отсылки к другому листу, где перечисляются категории. Категория 1, Категория 2, Категория 3. Откуда формула их видит?
Поэтому я не понимаю, как мне подставить свой список категорий.
А что такое число 97 в формуле?

Надо понимать, что мой файл-пример это упрощение.
вообще у меня сейчас 11 категорий и 11 диапазонов разной длины.
 
Ответить
Сообщение
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ИНДЕКС(A$1:I$1;ПОИСКПОЗ("*";A2:I2;));".";ПОВТОР(" ";97));97));"")

Спасибо, но в формуле нет отсылки к другому листу, где перечисляются категории. Категория 1, Категория 2, Категория 3. Откуда формула их видит?
Поэтому я не понимаю, как мне подставить свой список категорий.
А что такое число 97 в формуле?

Надо понимать, что мой файл-пример это упрощение.
вообще у меня сейчас 11 категорий и 11 диапазонов разной длины.

Автор - arxon
Дата добавления - 08.10.2019 в 12:08
Nic70y Дата: Вторник, 08.10.2019, 12:14 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 5687
Репутация: 1248 ±
Замечаний: 0% ±

ru13;10;03
Откуда формула их видит?
из первой строки.
как мне подставить свой список
"нарисуйте" пример максимально похожий на реальный.
ну 99 не красиво.
просто заменяем точку 97 пробелами, что бы в дальнейшем убрать подкатегорию.


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Откуда формула их видит?
из первой строки.
как мне подставить свой список
"нарисуйте" пример максимально похожий на реальный.
ну 99 не красиво.
просто заменяем точку 97 пробелами, что бы в дальнейшем убрать подкатегорию.

Автор - Nic70y
Дата добавления - 08.10.2019 в 12:14
arxon Дата: Вторник, 08.10.2019, 12:57 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
"нарисуйте" пример максимально похожий на реальный.

прикладываю вырезку без лишней информации
см файл
в желтой колонке планировал формулу, сейчас там пример того, что должно быть.
поясняю файл-пример: категории DJ оборудование соответсвует диапазон AR:BD. Так как в этом диапазоне(в строке) есть хоть одно значение, то Категория=DJ оборудование
К сообщению приложен файл: ____-2.xlsx(24.9 Kb)
 
Ответить
Сообщение
"нарисуйте" пример максимально похожий на реальный.

прикладываю вырезку без лишней информации
см файл
в желтой колонке планировал формулу, сейчас там пример того, что должно быть.
поясняю файл-пример: категории DJ оборудование соответсвует диапазон AR:BD. Так как в этом диапазоне(в строке) есть хоть одно значение, то Категория=DJ оборудование

Автор - arxon
Дата добавления - 08.10.2019 в 12:57
Nic70y Дата: Вторник, 08.10.2019, 13:09 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 5687
Репутация: 1248 ±
Замечаний: 0% ±

ru13;10;03
Код
=ИНДЕКС(Лист3!A:A;ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ИНДЕКС(B$1:EQ$1;ПОИСКПОЗ("*";B2:EQ2;));"Параметр: ";);".";" ");2))
К сообщению приложен файл: -2.xlsx(25.3 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Код
=ИНДЕКС(Лист3!A:A;ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ИНДЕКС(B$1:EQ$1;ПОИСКПОЗ("*";B2:EQ2;));"Параметр: ";);".";" ");2))

Автор - Nic70y
Дата добавления - 08.10.2019 в 13:09
arxon Дата: Вторник, 08.10.2019, 14:18 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
=ИНДЕКС(Лист3!A:A;ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ИНДЕКС(B$1:EQ$1;ПОИСКПОЗ("*";B2:EQ2;));"Параметр: ";);".";" ");2))

Это чудо работает)
как Вы дали понять формуле, к какой категории какой диапазон относиться? Просто не понимаю как она работает.
и еще, я протестировал: если существует непустая ячейка в двух разных диапазонах, то формула опирается только на первую слева ячейку, что не очень верно. Можно ли сделать так, чтобы в таких случаях формула возвращала "ОШИБКА" или типа того.
 
Ответить
Сообщение
=ИНДЕКС(Лист3!A:A;ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ИНДЕКС(B$1:EQ$1;ПОИСКПОЗ("*";B2:EQ2;));"Параметр: ";);".";" ");2))

Это чудо работает)
как Вы дали понять формуле, к какой категории какой диапазон относиться? Просто не понимаю как она работает.
и еще, я протестировал: если существует непустая ячейка в двух разных диапазонах, то формула опирается только на первую слева ячейку, что не очень верно. Можно ли сделать так, чтобы в таких случаях формула возвращала "ОШИБКА" или типа того.

Автор - arxon
Дата добавления - 08.10.2019 в 14:18
Nic70y Дата: Вторник, 08.10.2019, 14:30 | Сообщение № 10
Группа: Друзья
Ранг: Экселист
Сообщений: 5687
Репутация: 1248 ±
Замечаний: 0% ±

ru13;10;03
к какой категории какой диапазон относиться?
вот эта часть формулы
Код
ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ИНДЕКС(B$1:EQ$1;ПОИСКПОЗ("*";B2:EQ2;));"Параметр: ";);".";" ");2)
определят строку, извлекая ее из первой строки таблицы.
только на первую
так
Код
=ЕСЛИ(ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ИНДЕКС(B$1:EQ$1;ПОИСКПОЗ("*";B2:EQ2;));"Параметр: ";);".";" ");2)=ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ИНДЕКС(B$1:EQ$1;ПОИСКПОЗ("яяя";B2:EQ2));"Параметр: ";);".";" ");2);ИНДЕКС(Лист3!A:A;ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ИНДЕКС(B$1:EQ$1;ПОИСКПОЗ("*";B2:EQ2;));"Параметр: ";);".";" ");2));"ошибка")
будет опираться и на последнюю


ЯД(poison) 41001841029809
 
Ответить
Сообщение
к какой категории какой диапазон относиться?
вот эта часть формулы
Код
ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ИНДЕКС(B$1:EQ$1;ПОИСКПОЗ("*";B2:EQ2;));"Параметр: ";);".";" ");2)
определят строку, извлекая ее из первой строки таблицы.
только на первую
так
Код
=ЕСЛИ(ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ИНДЕКС(B$1:EQ$1;ПОИСКПОЗ("*";B2:EQ2;));"Параметр: ";);".";" ");2)=ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ИНДЕКС(B$1:EQ$1;ПОИСКПОЗ("яяя";B2:EQ2));"Параметр: ";);".";" ");2);ИНДЕКС(Лист3!A:A;ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ИНДЕКС(B$1:EQ$1;ПОИСКПОЗ("*";B2:EQ2;));"Параметр: ";);".";" ");2));"ошибка")
будет опираться и на последнюю

Автор - Nic70y
Дата добавления - 08.10.2019 в 14:30
arxon Дата: Вторник, 08.10.2019, 15:35 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума
формула работает, но мне непонятно как) в первой строке таблицы нет ключевых слов , за которые можно уцепиться при соотнесении категорий. Например название подкатегории из первой строки "Параметр: 2.Цифровые пианино" не имеет ничего общего с названием категории "Клавишные инструменты". В чем же магия? Единственное за что можно зацепиться, это число в названии "Параметр: 2.Цифровые пианино". цифра "2" - это Клавишные, цифра "3" - Микшерные пульты.
 
Ответить
СообщениеИзлишнее цитирование удалено администрацией - это нарушение п.5j Правил форума
формула работает, но мне непонятно как) в первой строке таблицы нет ключевых слов , за которые можно уцепиться при соотнесении категорий. Например название подкатегории из первой строки "Параметр: 2.Цифровые пианино" не имеет ничего общего с названием категории "Клавишные инструменты". В чем же магия? Единственное за что можно зацепиться, это число в названии "Параметр: 2.Цифровые пианино". цифра "2" - это Клавишные, цифра "3" - Микшерные пульты.

Автор - arxon
Дата добавления - 08.10.2019 в 15:35
Nic70y Дата: Вторник, 08.10.2019, 16:06 | Сообщение № 12
Группа: Друзья
Ранг: Экселист
Сообщений: 5687
Репутация: 1248 ±
Замечаний: 0% ±

ru13;10;03
эта не работает
см. файл
это число в названии
за это и цепляется
К сообщению приложен файл: 2020009.xlsx(25.8 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
эта не работает
см. файл
это число в названии
за это и цепляется

Автор - Nic70y
Дата добавления - 08.10.2019 в 16:06
arxon Дата: Вторник, 08.10.2019, 16:12 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо большое, очень помогли!
 
Ответить
СообщениеСпасибо большое, очень помогли!

Автор - arxon
Дата добавления - 08.10.2019 в 16:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Есть ли хотя бы 1 непустая ячейка в диапазоне? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!