Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/подсчёт ячейкой данных находящихся в разных диапазонах - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчёт ячейкой данных находящихся в разных диапазонах (Формулы/Formulas)
подсчёт ячейкой данных находящихся в разных диапазонах
ROM@RIO Дата: Пятница, 01.11.2019, 13:08 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день великие люди, гуру ЭКСЕЛЬ.
Обращаюсь опять к Вам за помощью.
В приложенном файле есть лист ЗП, в нем напротив ФИО сотрудников идёт подсчёт рабочих дней. проблема в том что информация собирается с другого листа, со строк не подряд и с разных диапазонов.
Помощь нужна в формуле которую можно протащить вниз по столбцу в листе ЗП и которая подстроиться под нужные диапазоны, т.к. вручную вбивать это будет очень долго, много сотрудников.
Помогите пожалуйста.
К сообщению приложен файл: 9793742.xlsx(43.7 Kb)


Сообщение отредактировал ROM@RIO - Пятница, 01.11.2019, 13:19
 
Ответить
СообщениеДобрый день великие люди, гуру ЭКСЕЛЬ.
Обращаюсь опять к Вам за помощью.
В приложенном файле есть лист ЗП, в нем напротив ФИО сотрудников идёт подсчёт рабочих дней. проблема в том что информация собирается с другого листа, со строк не подряд и с разных диапазонов.
Помощь нужна в формуле которую можно протащить вниз по столбцу в листе ЗП и которая подстроиться под нужные диапазоны, т.к. вручную вбивать это будет очень долго, много сотрудников.
Помогите пожалуйста.

Автор - ROM@RIO
Дата добавления - 01.11.2019 в 13:08
bmv98rus Дата: Пятница, 01.11.2019, 14:38 | Сообщение № 2
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2737
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=COUNTIFS(ВОДИТЕЛИ!$G$2:$AJ$2;">0";ВОДИТЕЛИ!$G$2:$AJ$2;"<11";INDEX(ВОДИТЕЛИ!$G$5:$AJ$101;MATCH(LEFT($B4;FIND(" ";$B4)-1)&"*";ВОДИТЕЛИ!$B$4:$B$1000;););">""")
но правильнее
Код
=COUNTIFS(ВОДИТЕЛИ!$G$2:$AJ$2;">0";ВОДИТЕЛИ!$G$2:$AJ$2;"<11";INDEX(ВОДИТЕЛИ!$G$5:$AJ$101;(ROW()-4)*3+1;);">""")
А с учетом того что и столбцы фиксированы, то и их можно просто три раза указать,
Код
=COUNTIF(INDEX(ВОДИТЕЛИ!$G$5:$P$101;(ROW()-4)*3+1;);">""")


В разных строках разные варианты
К сообщению приложен файл: Copy_of_1241.xlsx(46.7 Kb)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Код
=COUNTIFS(ВОДИТЕЛИ!$G$2:$AJ$2;">0";ВОДИТЕЛИ!$G$2:$AJ$2;"<11";INDEX(ВОДИТЕЛИ!$G$5:$AJ$101;MATCH(LEFT($B4;FIND(" ";$B4)-1)&"*";ВОДИТЕЛИ!$B$4:$B$1000;););">""")
но правильнее
Код
=COUNTIFS(ВОДИТЕЛИ!$G$2:$AJ$2;">0";ВОДИТЕЛИ!$G$2:$AJ$2;"<11";INDEX(ВОДИТЕЛИ!$G$5:$AJ$101;(ROW()-4)*3+1;);">""")
А с учетом того что и столбцы фиксированы, то и их можно просто три раза указать,
Код
=COUNTIF(INDEX(ВОДИТЕЛИ!$G$5:$P$101;(ROW()-4)*3+1;);">""")


В разных строках разные варианты

Автор - bmv98rus
Дата добавления - 01.11.2019 в 14:38
ROM@RIO Дата: Пятница, 01.11.2019, 16:27 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
bmv98rus, Спасибо тебе ещё раз Михаил!!!! Выручил.


Сообщение отредактировал ROM@RIO - Пятница, 01.11.2019, 16:28
 
Ответить
Сообщениеbmv98rus, Спасибо тебе ещё раз Михаил!!!! Выручил.

Автор - ROM@RIO
Дата добавления - 01.11.2019 в 16:27
ROM@RIO Дата: Пятница, 01.11.2019, 17:30 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
А с учетом того что и столбцы фиксированы, то и их можно просто три раза указать,

=СЧЁТЕСЛИ(ИНДЕКС(ВОДИТЕЛИ!$G$5:$P$101;(СТРОКА()-4)*3+1;);">""")


перенес на декабрь, указал другие столбцы , перестало работать.
К сообщению приложен файл: 5020532.xlsx(49.3 Kb)
 
Ответить
Сообщение
А с учетом того что и столбцы фиксированы, то и их можно просто три раза указать,

=СЧЁТЕСЛИ(ИНДЕКС(ВОДИТЕЛИ!$G$5:$P$101;(СТРОКА()-4)*3+1;);">""")


перенес на декабрь, указал другие столбцы , перестало работать.

Автор - ROM@RIO
Дата добавления - 01.11.2019 в 17:30
bmv98rus Дата: Пятница, 01.11.2019, 19:00 | Сообщение № 5
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2737
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
не вижу проблем. Если вы хотите универсальную формулу, которую можно просто множить, то естевенно нужно мудрить.


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениене вижу проблем. Если вы хотите универсальную формулу, которую можно просто множить, то естевенно нужно мудрить.

Автор - bmv98rus
Дата добавления - 01.11.2019 в 19:00
ROM@RIO Дата: Пятница, 01.11.2019, 19:02 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
bmv98rus, не сильно в этом разбираюсь, к сожалению, думал поменяю столбцы и заработает, АН нет.
 
Ответить
Сообщениеbmv98rus, не сильно в этом разбираюсь, к сожалению, думал поменяю столбцы и заработает, АН нет.

Автор - ROM@RIO
Дата добавления - 01.11.2019 в 19:02
bmv98rus Дата: Пятница, 01.11.2019, 19:17 | Сообщение № 7
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2737
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
так для декабря данных нет, а две соседние формулы по прежнему на ноябрь ссылаются.


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениетак для декабря данных нет, а две соседние формулы по прежнему на ноябрь ссылаются.

Автор - bmv98rus
Дата добавления - 01.11.2019 в 19:17
ROM@RIO Дата: Пятница, 01.11.2019, 19:28 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
bmv98rus, Заработался, извините, графики уже рябят в глазах.
Данные внес, всё заработало, формула работает.
Спасибо. Был у меня ещё вопрос, но как говорилось мне ранее, в новой теме.
Спасибо Михаил.
 
Ответить
Сообщениеbmv98rus, Заработался, извините, графики уже рябят в глазах.
Данные внес, всё заработало, формула работает.
Спасибо. Был у меня ещё вопрос, но как говорилось мне ранее, в новой теме.
Спасибо Михаил.

Автор - ROM@RIO
Дата добавления - 01.11.2019 в 19:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчёт ячейкой данных находящихся в разных диапазонах (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!