Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Распределение мест относительно набранных очков - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Распределение мест относительно набранных очков (Формулы/Formulas)
Распределение мест относительно набранных очков
vellyur Дата: Пятница, 08.11.2019, 20:19 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Уважаемые! Использовал формулу "ИНДЕКС" для выведения итогового места по набранным очкам.
Код
=ИНДЕКС(ЧАСТОТА($C$31:$Q$31+$C$29:$Q$29/100;G31+G31/100);2)+1

Все красяво... было, пока разница в очках была большая. разница же от 1го до 3-х очков выводит одинаковое ИТОГОВОЕ МЕСТО. Подскажите, где @ "порылась", пожалуйста. файл прилагаю
К сообщению приложен файл: _3_.xlsx(18.5 Kb)


Сообщение отредактировал vellyur - Пятница, 08.11.2019, 20:19
 
Ответить
СообщениеУважаемые! Использовал формулу "ИНДЕКС" для выведения итогового места по набранным очкам.
Код
=ИНДЕКС(ЧАСТОТА($C$31:$Q$31+$C$29:$Q$29/100;G31+G31/100);2)+1

Все красяво... было, пока разница в очках была большая. разница же от 1го до 3-х очков выводит одинаковое ИТОГОВОЕ МЕСТО. Подскажите, где @ "порылась", пожалуйста. файл прилагаю

Автор - vellyur
Дата добавления - 08.11.2019 в 20:19
Светлый Дата: Пятница, 08.11.2019, 21:43 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1340
Репутация: 333 ±
Замечаний: 0% ±

Excel 2010
Добрый вечер!
Можно так:
Код
=СУММПРОИЗВ(Ч($C31:$S31-СТОЛБЕЦ($C31:$S31)%>=C31-СТОЛБЕЦ(C31)%))
*Или так:
Код
=СУММПРОИЗВ(Ч($C31:$S31+$C30:$S30%%-СТОЛБЕЦ($C31:$S31)%%%>=C31+C30%%-СТОЛБЕЦ(C31)%%%))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 08.11.2019, 21:49
 
Ответить
СообщениеДобрый вечер!
Можно так:
Код
=СУММПРОИЗВ(Ч($C31:$S31-СТОЛБЕЦ($C31:$S31)%>=C31-СТОЛБЕЦ(C31)%))
*Или так:
Код
=СУММПРОИЗВ(Ч($C31:$S31+$C30:$S30%%-СТОЛБЕЦ($C31:$S31)%%%>=C31+C30%%-СТОЛБЕЦ(C31)%%%))

Автор - Светлый
Дата добавления - 08.11.2019 в 21:43
Gustav Дата: Суббота, 09.11.2019, 00:28 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1708
Репутация: 689 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Стесняюсь спросить, чем вам функция РАНГ не угодила, которая напрямую для подобных задач предназначена?
Код
=РАНГ(C31;$C$31:$S$31)


Мой tip box - яд 41001663842605
 
Ответить
СообщениеСтесняюсь спросить, чем вам функция РАНГ не угодила, которая напрямую для подобных задач предназначена?
Код
=РАНГ(C31;$C$31:$S$31)

Автор - Gustav
Дата добавления - 09.11.2019 в 00:28
Светлый Дата: Суббота, 09.11.2019, 01:09 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1340
Репутация: 333 ±
Замечаний: 0% ±

Excel 2010
Стесняюсь спросить
Если с имеющимися данными устраивает два первых места и отсутствие второго, то РАНГ вполне угождает, но
выводит одинаковое ИТОГОВОЕ МЕСТО


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
Стесняюсь спросить
Если с имеющимися данными устраивает два первых места и отсутствие второго, то РАНГ вполне угождает, но
выводит одинаковое ИТОГОВОЕ МЕСТО

Автор - Светлый
Дата добавления - 09.11.2019 в 01:09
Rav2601 Дата: Суббота, 09.11.2019, 19:08 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

1809
Светлый, сможете подсказать как быть есть колонка неповторяющихся имен и колонка их очков они они берутся и здруих таблиц.......
суть в чем делаем топ 8
и имена поаторяются нахожу через впр но не могу понять как сделать что бы не повторялись.
К сообщению приложен файл: 3027725.xlsx(71.5 Kb)


Сообщение отредактировал Rav2601 - Суббота, 09.11.2019, 20:16
 
Ответить
СообщениеСветлый, сможете подсказать как быть есть колонка неповторяющихся имен и колонка их очков они они берутся и здруих таблиц.......
суть в чем делаем топ 8
и имена поаторяются нахожу через впр но не могу понять как сделать что бы не повторялись.

Автор - Rav2601
Дата добавления - 09.11.2019 в 19:08
Pelena Дата: Суббота, 09.11.2019, 20:16 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14764
Репутация: 3229 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Rav2601, Ваш вопрос не относится к данной теме. Прочитайте Правила форума и создайте свою тему


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеRav2601, Ваш вопрос не относится к данной теме. Прочитайте Правила форума и создайте свою тему

Автор - Pelena
Дата добавления - 09.11.2019 в 20:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Распределение мест относительно набранных очков (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!