Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск по нескольким условиям и подставление значений. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск по нескольким условиям и подставление значений. (Формулы/Formulas)
Поиск по нескольким условиям и подставление значений.
QuasarSpb Дата: Вторник, 26.11.2019, 13:40 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день уважаемые обитатели форума.
Случилось так что появилась необходимость быстро решить задачу в Exel, опыта написания в нем формул как и опыта работы в нем не было, за пару часов немного разобравшись с синтаксисом формул удалось добиться нужного результата, за исключением одного момента.

Код
=ВПР(B3;Лист2!$A$1:$E$300;3;ЛОЖЬ)
- это формула которая подставляет мне данные из соответствующей ячейки значение опираясь на значение в B3 выбранного из всплывающего списка.
Помогите пожалуйста изменить эту формулу добавив несколько условий :

Если значение в ячейке D3>5 то нужно подставить значение из Лист2!$A$1:$E$300;4 , а если значение в ячейке D3>10 то подставить значение из Лист2!$A$1:$E$300;5

Понимаю что задача не очень сложная и поверьте если бы не поджимало время и не было других задач , я бы может и разобрался, но уповаю на опыт местных обитателей в расчете на то что у человека с опытом это не займет и 2х минут.

Буду очень признателен если поможете с этой формулой.
С уважением , Петр.
К сообщению приложен файл: test.2.7.xlsm(16.8 Kb)


Сообщение отредактировал QuasarSpb - Вторник, 26.11.2019, 14:08
 
Ответить
СообщениеДобрый день уважаемые обитатели форума.
Случилось так что появилась необходимость быстро решить задачу в Exel, опыта написания в нем формул как и опыта работы в нем не было, за пару часов немного разобравшись с синтаксисом формул удалось добиться нужного результата, за исключением одного момента.

Код
=ВПР(B3;Лист2!$A$1:$E$300;3;ЛОЖЬ)
- это формула которая подставляет мне данные из соответствующей ячейки значение опираясь на значение в B3 выбранного из всплывающего списка.
Помогите пожалуйста изменить эту формулу добавив несколько условий :

Если значение в ячейке D3>5 то нужно подставить значение из Лист2!$A$1:$E$300;4 , а если значение в ячейке D3>10 то подставить значение из Лист2!$A$1:$E$300;5

Понимаю что задача не очень сложная и поверьте если бы не поджимало время и не было других задач , я бы может и разобрался, но уповаю на опыт местных обитателей в расчете на то что у человека с опытом это не займет и 2х минут.

Буду очень признателен если поможете с этой формулой.
С уважением , Петр.

Автор - QuasarSpb
Дата добавления - 26.11.2019 в 13:40
китин Дата: Вторник, 26.11.2019, 13:46 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5977
Репутация: 928 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
QuasarSpb, - Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 100кб согласно п.3 Правил форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеQuasarSpb, - Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 100кб согласно п.3 Правил форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - китин
Дата добавления - 26.11.2019 в 13:46
QuasarSpb Дата: Вторник, 26.11.2019, 13:51 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума

- К сожалению готовый документ выложить не могу т.к часть информации может содержать коммерческую тайну. Разве что удалять все со второго листа а это порядка 300 строк.


Сообщение отредактировал китин - Вторник, 26.11.2019, 14:00
 
Ответить
СообщениеИзлишнее цитирование удалено администрацией - это нарушение п.5j Правил форума

- К сожалению готовый документ выложить не могу т.к часть информации может содержать коммерческую тайну. Разве что удалять все со второго листа а это порядка 300 строк.

Автор - QuasarSpb
Дата добавления - 26.11.2019 в 13:51
китин Дата: Вторник, 26.11.2019, 14:03 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 5977
Репутация: 928 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
дык у вас уже решение в условии прописано
Код
=ЕСЛИ(И(D3>5;D3<=10);ВПР(B3;Лист2!$A$1:$E$300;4;ЛОЖЬ);ВПР(B3;Лист2!$A$1:$E$300;5;ЛОЖЬ))

это без файла на коленке


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениедык у вас уже решение в условии прописано
Код
=ЕСЛИ(И(D3>5;D3<=10);ВПР(B3;Лист2!$A$1:$E$300;4;ЛОЖЬ);ВПР(B3;Лист2!$A$1:$E$300;5;ЛОЖЬ))

это без файла на коленке

Автор - китин
Дата добавления - 26.11.2019 в 14:03
QuasarSpb Дата: Вторник, 26.11.2019, 14:13 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
это без файла на коленке


Спасибо Вам огромное! Все именно так как и должно быть, но я не совсем верно видимо описал условие тк при значении от 1-5 в D3 он все равно использует те данные которые выводятся при D3 > 10

зы: мне бы как Вы уметь так на коленке :)

Тоесть условия конечные должны быть такие:
D3=1-5 берем данные из Лист2!$A$1:$E$300;3
D3>5 берем данные из Лист2!$A$1:$E$300;4
D3>10 берем данные из Лист2!$A$1:$E$300;5

Если возможно и не очень трудно поправьте пожалуйста

Сейчас опираясь на Вашу формулу попробую сам подправить, вроде понял как должно это все выглядеть :)


Сообщение отредактировал QuasarSpb - Вторник, 26.11.2019, 14:16
 
Ответить
Сообщение
это без файла на коленке


Спасибо Вам огромное! Все именно так как и должно быть, но я не совсем верно видимо описал условие тк при значении от 1-5 в D3 он все равно использует те данные которые выводятся при D3 > 10

зы: мне бы как Вы уметь так на коленке :)

Тоесть условия конечные должны быть такие:
D3=1-5 берем данные из Лист2!$A$1:$E$300;3
D3>5 берем данные из Лист2!$A$1:$E$300;4
D3>10 берем данные из Лист2!$A$1:$E$300;5

Если возможно и не очень трудно поправьте пожалуйста

Сейчас опираясь на Вашу формулу попробую сам подправить, вроде понял как должно это все выглядеть :)

Автор - QuasarSpb
Дата добавления - 26.11.2019 в 14:13
китин Дата: Вторник, 26.11.2019, 14:26 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 5977
Репутация: 928 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
не проверял скобки, мог ошибиться
Код
=ЕСЛИ(И(D3>5;D3<=10);ВПР(B3;Лист2!$A$1:$E$300;4;ЛОЖЬ);ЕСЛИ(D3<=5;ВПР(B3;Лист2!$A$1:$E$300;3;ЛОЖЬ);ВПР(B3;Лист2!$A$1:$E$300;5;ЛОЖЬ)))


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениене проверял скобки, мог ошибиться
Код
=ЕСЛИ(И(D3>5;D3<=10);ВПР(B3;Лист2!$A$1:$E$300;4;ЛОЖЬ);ЕСЛИ(D3<=5;ВПР(B3;Лист2!$A$1:$E$300;3;ЛОЖЬ);ВПР(B3;Лист2!$A$1:$E$300;5;ЛОЖЬ)))

Автор - китин
Дата добавления - 26.11.2019 в 14:26
QuasarSpb Дата: Вторник, 26.11.2019, 14:44 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
не проверял скобки, мог ошибиться


Огромное Вам спасибо, очень признателен!
+ Вам в карму и всех благ!:)

зы: я благодаря Вашей формуле понял наконец как это делается спустя 2 часа попыток скомпилировать поток новой информации у себя в голове))
 
Ответить
Сообщение
не проверял скобки, мог ошибиться


Огромное Вам спасибо, очень признателен!
+ Вам в карму и всех благ!:)

зы: я благодаря Вашей формуле понял наконец как это делается спустя 2 часа попыток скомпилировать поток новой информации у себя в голове))

Автор - QuasarSpb
Дата добавления - 26.11.2019 в 14:44
Pelena Дата: Вторник, 26.11.2019, 16:18 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 14887
Репутация: 3251 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Почти то же самое, что у китина
Код
=ВПР(B3;Лист2!$A$1:$E$300;3+(D3>5)+(D3>10);ЛОЖЬ)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПочти то же самое, что у китина
Код
=ВПР(B3;Лист2!$A$1:$E$300;3+(D3>5)+(D3>10);ЛОЖЬ)

Автор - Pelena
Дата добавления - 26.11.2019 в 16:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск по нескольким условиям и подставление значений. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!