Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как добавить условие соблюдения даты - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как добавить условие соблюдения даты (Формулы/Formulas)
Как добавить условие соблюдения даты
momo Дата: Среда, 27.11.2019, 00:42 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день! Подскажите кто знает. Как в формулу
Код
=СУММЕСЛИ(База!A:A;"двк";База!D:D)
добавить условие соблюдения даты. то есть сумма считается только если в Лист "База" стобец F стот несколько дат но они все ноябрь 2019, и чтобы в лист "отчёт" ячейка В2 считалась сумма только за ноябрь 2019.

Всем спасибо за ответы.
К сообщению приложен файл: 2362993.xlsx(10.1 Kb)


Сообщение отредактировал momo - Среда, 27.11.2019, 09:49
 
Ответить
СообщениеДобрый день! Подскажите кто знает. Как в формулу
Код
=СУММЕСЛИ(База!A:A;"двк";База!D:D)
добавить условие соблюдения даты. то есть сумма считается только если в Лист "База" стобец F стот несколько дат но они все ноябрь 2019, и чтобы в лист "отчёт" ячейка В2 считалась сумма только за ноябрь 2019.

Всем спасибо за ответы.

Автор - momo
Дата добавления - 27.11.2019 в 00:42
китин Дата: Среда, 27.11.2019, 07:01 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5968
Репутация: 927 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
momo, - Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеmomo, - Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - китин
Дата добавления - 27.11.2019 в 07:01
alexa1965 Дата: Среда, 27.11.2019, 07:55 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 152
Репутация: 8 ±
Замечаний: 0% ±

2003, 2010
А где в листе база даты?


Главное не быть балабастиком
 
Ответить
СообщениеА где в листе база даты?

Автор - alexa1965
Дата добавления - 27.11.2019 в 07:55
momo Дата: Среда, 27.11.2019, 09:50 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
(в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

готово!
 
Ответить
Сообщение
(в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

готово!

Автор - momo
Дата добавления - 27.11.2019 в 09:50
momo Дата: Среда, 27.11.2019, 09:50 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
А где в листе база даты?

перезалил файл.
 
Ответить
Сообщение
А где в листе база даты?

перезалил файл.

Автор - momo
Дата добавления - 27.11.2019 в 09:50
Kostya_Ye Дата: Среда, 27.11.2019, 10:09 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 112
Репутация: 46 ±
Замечаний: 0% ±

Excel 2016
momo, добрый день,
при условии, что на листе "База" значения в колонке D будут переведены из текстовых в числовые
Код
=SUMPRODUCT(База!$D$2:$D$5*(База!$A$2:$A$5="двк")*(MONTH(База!$F$2:$F$5)=MONTH(Отчёт!A2)))
 
Ответить
Сообщениеmomo, добрый день,
при условии, что на листе "База" значения в колонке D будут переведены из текстовых в числовые
Код
=SUMPRODUCT(База!$D$2:$D$5*(База!$A$2:$A$5="двк")*(MONTH(База!$F$2:$F$5)=MONTH(Отчёт!A2)))

Автор - Kostya_Ye
Дата добавления - 27.11.2019 в 10:09
китин Дата: Среда, 27.11.2019, 10:17 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 5968
Репутация: 927 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
так?
Код
=СУММПРОИЗВ(--ПОДСТАВИТЬ(ЛЕВБ(База!$D$2:$D$5;ПОИСК("р.";База!$D$2:$D$5)-1);СИМВОЛ(160);"")*(ТЕКСТ(База!$F$2:$F$5;"ММММ ГГГГ")=ТЕКСТ(Отчёт!$A2;"ММММ ГГГГ")))

если нужен критерий "двк" тогда так. и цены переделывать в Лист База не надо
Код
=СУММПРОИЗВ(--ПОДСТАВИТЬ(ЛЕВБ(База!$D$2:$D$5;ПОИСК("р.";База!$D$2:$D$5)-1);СИМВОЛ(160);"")*(ТЕКСТ(База!$F$2:$F$5;"ММММ ГГГГ")=ТЕКСТ(Отчёт!$A2;"ММММ ГГГГ"))*(База!$A$2:$A$5="двк"))
К сообщению приложен файл: 5452813.xlsx(11.1 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениетак?
Код
=СУММПРОИЗВ(--ПОДСТАВИТЬ(ЛЕВБ(База!$D$2:$D$5;ПОИСК("р.";База!$D$2:$D$5)-1);СИМВОЛ(160);"")*(ТЕКСТ(База!$F$2:$F$5;"ММММ ГГГГ")=ТЕКСТ(Отчёт!$A2;"ММММ ГГГГ")))

если нужен критерий "двк" тогда так. и цены переделывать в Лист База не надо
Код
=СУММПРОИЗВ(--ПОДСТАВИТЬ(ЛЕВБ(База!$D$2:$D$5;ПОИСК("р.";База!$D$2:$D$5)-1);СИМВОЛ(160);"")*(ТЕКСТ(База!$F$2:$F$5;"ММММ ГГГГ")=ТЕКСТ(Отчёт!$A2;"ММММ ГГГГ"))*(База!$A$2:$A$5="двк"))

Автор - китин
Дата добавления - 27.11.2019 в 10:17
_Boroda_ Дата: Среда, 27.11.2019, 11:13 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15640
Репутация: 6114 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант для сумм, сделанных нормальными числами и с учетом того, что может быть база за несколько лет (в ней будет несколько ноябрей за разные года)
Код
=СУММЕСЛИМН(База!D:D;База!A:A;"двк";База!F:F;">="&A2;База!F:F;"<"&ДАТАМЕС(A2;1))


Или ничего не меняя
Код
=СУММПРОИЗВ((База!A$2:A$5="двк")*(ТЕКСТ(Отчёт!A2;"МГ")=ТЕКСТ(База!F$2:F$5;"МГ"))*ПОДСТАВИТЬ(ПОДСТАВИТЬ(База!D$2:D$5;" р.";);СИМВОЛ(160);))
К сообщению приложен файл: 2362993_1.xlsx(10.6 Kb) · 2362993_2.xlsx(10.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант для сумм, сделанных нормальными числами и с учетом того, что может быть база за несколько лет (в ней будет несколько ноябрей за разные года)
Код
=СУММЕСЛИМН(База!D:D;База!A:A;"двк";База!F:F;">="&A2;База!F:F;"<"&ДАТАМЕС(A2;1))


Или ничего не меняя
Код
=СУММПРОИЗВ((База!A$2:A$5="двк")*(ТЕКСТ(Отчёт!A2;"МГ")=ТЕКСТ(База!F$2:F$5;"МГ"))*ПОДСТАВИТЬ(ПОДСТАВИТЬ(База!D$2:D$5;" р.";);СИМВОЛ(160);))

Автор - _Boroda_
Дата добавления - 27.11.2019 в 11:13
momo Дата: Среда, 27.11.2019, 11:54 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем спасибо за ответы, поковырялся сам и сделал так:
Код
=SUMIFS('Основная база'!$D:$D;'Основная база'!$A:$A;"двк";'Основная база'!$L:$L;">=1.10.2019";'Основная база'!$L:$L;"<=31.10.2019")
 
Ответить
СообщениеВсем спасибо за ответы, поковырялся сам и сделал так:
Код
=SUMIFS('Основная база'!$D:$D;'Основная база'!$A:$A;"двк";'Основная база'!$L:$L;">=1.10.2019";'Основная база'!$L:$L;"<=31.10.2019")

Автор - momo
Дата добавления - 27.11.2019 в 11:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как добавить условие соблюдения даты (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!