Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Убрать ошибку деления на 0 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Убрать ошибку деления на 0 (Формулы/Formulas)
Убрать ошибку деления на 0
kisunz Дата: Понедельник, 02.12.2019, 11:58 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!

Подскажите пожалуйста, какое задать условие(если), чтобы при расчете формулы расчет отклонения по месяцам в ячейке отображалось не #ДЕЛ/0! (т.к. январь был 0, февраль стал 5), а 100%? При этом я уже использую формулу Если, чтобы не показывал мне больше 100% (никаких 2000%). При этом, в пустых ячейках за оба месяца должен оставаться 0. В общем, не знаю, как совместить эти условия.
К сообщению приложен файл: 9808298.xlsx(10.2 Kb)


Сообщение отредактировал kisunz - Понедельник, 02.12.2019, 12:27
 
Ответить
СообщениеДобрый день!

Подскажите пожалуйста, какое задать условие(если), чтобы при расчете формулы расчет отклонения по месяцам в ячейке отображалось не #ДЕЛ/0! (т.к. январь был 0, февраль стал 5), а 100%? При этом я уже использую формулу Если, чтобы не показывал мне больше 100% (никаких 2000%). При этом, в пустых ячейках за оба месяца должен оставаться 0. В общем, не знаю, как совместить эти условия.

Автор - kisunz
Дата добавления - 02.12.2019 в 11:58
amfor Дата: Понедельник, 02.12.2019, 12:07 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 188
Репутация: 53 ±
Замечаний: 0% ±

Excel 2016
Добрый. Как понял.
Код
=ЕСЛИ(B3="";1;ЕСЛИ((F3/B3-1)>1;1;F3/B3-1))
К сообщению приложен файл: 1744339.xlsx(10.3 Kb)


Семь бед - один RESET.
 
Ответить
СообщениеДобрый. Как понял.
Код
=ЕСЛИ(B3="";1;ЕСЛИ((F3/B3-1)>1;1;F3/B3-1))

Автор - amfor
Дата добавления - 02.12.2019 в 12:07
_Boroda_ Дата: Понедельник, 02.12.2019, 12:10 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15673
Репутация: 6119 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=ЕСЛИ(B3;МИН(1;F3/B3-1);1*(F3>0))

Код
=ЕСЛИ(B3;МИН(1;F3/B3-1);-(F3<0))

Код
=ЕСЛИ(B3;МИН(1;F3/B3-1);ЕСЛИ(F3;1;))
К сообщению приложен файл: 6844598_1.xlsx(10.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=ЕСЛИ(B3;МИН(1;F3/B3-1);1*(F3>0))

Код
=ЕСЛИ(B3;МИН(1;F3/B3-1);-(F3<0))

Код
=ЕСЛИ(B3;МИН(1;F3/B3-1);ЕСЛИ(F3;1;))

Автор - _Boroda_
Дата добавления - 02.12.2019 в 12:10
kisunz Дата: Понедельник, 02.12.2019, 12:30 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо за быстрый ответ @amfor и @_Boroda_, но не подошло решение. Я исправила прикрепленный файл, добавила пустую строку. При использовании ваших формул в таких пустых строках получается 100%. Хотелось бы, чтоб в них оставалось пусто или 0%. Но ваши работают при отсутствии пустых строк
 
Ответить
СообщениеСпасибо за быстрый ответ @amfor и @_Boroda_, но не подошло решение. Я исправила прикрепленный файл, добавила пустую строку. При использовании ваших формул в таких пустых строках получается 100%. Хотелось бы, чтоб в них оставалось пусто или 0%. Но ваши работают при отсутствии пустых строк

Автор - kisunz
Дата добавления - 02.12.2019 в 12:30
_Boroda_ Дата: Понедельник, 02.12.2019, 12:47 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15673
Репутация: 6119 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
При использовании ваших формул в таких пустых строках получается 100%

Покажите в файле с любой из трех моих формул


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
При использовании ваших формул в таких пустых строках получается 100%

Покажите в файле с любой из трех моих формул

Автор - _Boroda_
Дата добавления - 02.12.2019 в 12:47
kisunz Дата: Понедельник, 02.12.2019, 13:57 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
все получилось, спасибо!
 
Ответить
Сообщениевсе получилось, спасибо!

Автор - kisunz
Дата добавления - 02.12.2019 в 13:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Убрать ошибку деления на 0 (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!