Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/автоматизировать заполнение графика - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » автоматизировать заполнение графика (Формулы/Formulas)
автоматизировать заполнение графика
Himiak Дата: Среда, 11.12.2019, 13:17 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Имеем график выхода на работу вахтовиков. Вахта по умолчанию 45 рабочих смен. В процессе работы у сотрудников могут быть выходные, прогулы, больничные. Эти дни в график заношу в ручную так как предугадать их не возможно. Как сделать заливку красным ячейки, которая соответствует дате окончания вахты из столбца В, в соответствующей строке в автоматическом режиме и вслучае изменения даты окончания заливка перемещалась на нужную ячейку. И второе, если возможно, что бы в ячейках на которые проливается вахта, автоматически проставлялась единица.
К сообщению приложен файл: 6771961.xls(30.0 Kb)
 
Ответить
СообщениеИмеем график выхода на работу вахтовиков. Вахта по умолчанию 45 рабочих смен. В процессе работы у сотрудников могут быть выходные, прогулы, больничные. Эти дни в график заношу в ручную так как предугадать их не возможно. Как сделать заливку красным ячейки, которая соответствует дате окончания вахты из столбца В, в соответствующей строке в автоматическом режиме и вслучае изменения даты окончания заливка перемещалась на нужную ячейку. И второе, если возможно, что бы в ячейках на которые проливается вахта, автоматически проставлялась единица.

Автор - Himiak
Дата добавления - 11.12.2019 в 13:17
_Boroda_ Дата: Среда, 11.12.2019, 14:10 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16364
Репутация: 6353 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ((F$1>=$A2)*$A2;ЕСЛИ(СУММ($E2:E2)<45;1;" ");" ")

Сделал Вам строку 2 полностью с формулой, оттуда можно копировать диапазон F2:CA2 и вставлять в новые строки вниз
Первая дата (в F1) определяется минимальной датой в столбце А
Остальные даты по порядку (у Вас неверно были написаны даты 2020 года)
Пустые ячейки красятся
Окончание смены красится
К сообщению приложен файл: 6771961_1.xlsx(18.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ((F$1>=$A2)*$A2;ЕСЛИ(СУММ($E2:E2)<45;1;" ");" ")

Сделал Вам строку 2 полностью с формулой, оттуда можно копировать диапазон F2:CA2 и вставлять в новые строки вниз
Первая дата (в F1) определяется минимальной датой в столбце А
Остальные даты по порядку (у Вас неверно были написаны даты 2020 года)
Пустые ячейки красятся
Окончание смены красится

Автор - _Boroda_
Дата добавления - 11.12.2019 в 14:10
Himiak Дата: Суббота, 14.12.2019, 15:39 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо большое, что отозвались и помогли, но осталось множество вопросов и хотелок именно по графику.
 
Ответить
СообщениеСпасибо большое, что отозвались и помогли, но осталось множество вопросов и хотелок именно по графику.

Автор - Himiak
Дата добавления - 14.12.2019 в 15:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » автоматизировать заполнение графика (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!