Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как сделать больше условий для фильтрации, несколько более 2 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сделать больше условий для фильтрации, несколько более 2 (Формулы/Formulas)
Как сделать больше условий для фильтрации, несколько более 2
jura-tolstich Дата: Среда, 25.12.2019, 11:14 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Столкнулся с проблемой, что работаю по фильтрации только с одним столбцом.
Но условий по фильру больше 2х. Нужно отфильтровать условия так, что не должен содержать "слово1" и "слово2", но содержать "слово3".
Как можно так фильтровать?
К сообщению приложен файл: 3511398.jpg(35.3 Kb)
 
Ответить
СообщениеСтолкнулся с проблемой, что работаю по фильтрации только с одним столбцом.
Но условий по фильру больше 2х. Нужно отфильтровать условия так, что не должен содержать "слово1" и "слово2", но содержать "слово3".
Как можно так фильтровать?

Автор - jura-tolstich
Дата добавления - 25.12.2019 в 11:14
Pelena Дата: Среда, 25.12.2019, 11:41 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15018
Репутация: 3283 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Расширенный фильтр или доп. столбец с формулой для выборки нужных строк.
Подробнее при наличии файла с примером


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеРасширенный фильтр или доп. столбец с формулой для выборки нужных строк.
Подробнее при наличии файла с примером

Автор - Pelena
Дата добавления - 25.12.2019 в 11:41
jura-tolstich Дата: Четверг, 26.12.2019, 07:44 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Как можно в данном столбце "Название продукта" отсортировать так, чтобы:
Остались название, которые содержат "Stone" и ''NEW"
В списке, который остался, были исключены название, которые содержат "26", "Corner", "DS"
К сообщению приложен файл: 3351873.xlsx(28.4 Kb)
 
Ответить
СообщениеКак можно в данном столбце "Название продукта" отсортировать так, чтобы:
Остались название, которые содержат "Stone" и ''NEW"
В списке, который остался, были исключены название, которые содержат "26", "Corner", "DS"

Автор - jura-tolstich
Дата добавления - 26.12.2019 в 07:44
Pelena Дата: Четверг, 26.12.2019, 08:38 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 15018
Репутация: 3283 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Формула для доп. столбца
Код
=И(ИЛИ(ЕЧИСЛО(ПОИСК("stone";B2));ЕЧИСЛО(ПОИСК("new";B2)));ЕОШ(ПОИСК("26";B2));ЕОШ(ПОИСК("Corner";B2));ЕОШ(ПОИСК("DS";B2)))

или если слов много, можно вынести их в отдельные списки, и тогда формула массива (см. второй лист в файле)
Код
=И(СЧЁТ(ПОИСК($T$2:$T$3;B2))>0;СЧЁТ(ПОИСК($U$2:$U$4;B2))=0)
К сообщению приложен файл: 0154854.xlsx(49.9 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФормула для доп. столбца
Код
=И(ИЛИ(ЕЧИСЛО(ПОИСК("stone";B2));ЕЧИСЛО(ПОИСК("new";B2)));ЕОШ(ПОИСК("26";B2));ЕОШ(ПОИСК("Corner";B2));ЕОШ(ПОИСК("DS";B2)))

или если слов много, можно вынести их в отдельные списки, и тогда формула массива (см. второй лист в файле)
Код
=И(СЧЁТ(ПОИСК($T$2:$T$3;B2))>0;СЧЁТ(ПОИСК($U$2:$U$4;B2))=0)

Автор - Pelena
Дата добавления - 26.12.2019 в 08:38
_Boroda_ Дата: Четверг, 26.12.2019, 09:34 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15747
Репутация: 6143 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант формулы
Код
=СУММПРОИЗВ(СЧЁТЕСЛИ(B2;{"*Stone*":"*NEW*":"<>*26*":"<>*Corner*":"<>*DS*"})*{1:1:3:3:3})>9

Или для большего количества
Код
=СУММПРОИЗВ(СЧЁТЕСЛИ(B2;{"*Stone*":"*NEW*":"<>*26*":"<>*Corner*":"<>*DS*"})*{1:1:99:99:99})>99*3
, где 3 - кол-во "не равно"
К сообщению приложен файл: 3351873_1.xlsx(38.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант формулы
Код
=СУММПРОИЗВ(СЧЁТЕСЛИ(B2;{"*Stone*":"*NEW*":"<>*26*":"<>*Corner*":"<>*DS*"})*{1:1:3:3:3})>9

Или для большего количества
Код
=СУММПРОИЗВ(СЧЁТЕСЛИ(B2;{"*Stone*":"*NEW*":"<>*26*":"<>*Corner*":"<>*DS*"})*{1:1:99:99:99})>99*3
, где 3 - кол-во "не равно"

Автор - _Boroda_
Дата добавления - 26.12.2019 в 09:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сделать больше условий для фильтрации, несколько более 2 (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!