Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчёт суммы при условии и повторение, при невыполнении - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчёт суммы при условии и повторение, при невыполнении (Формулы/Formulas)
Расчёт суммы при условии и повторение, при невыполнении
Coldneel Дата: Пятница, 27.12.2019, 11:09 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Не могу додуматься как решить вопрос, прошу помощи. Есть пример (бюджетная роспись), если в столбце B пусто, то это итоговая сумма расписанных далее видов расходов. В общем, надо как-то проверить, правильно ли там всё было подсчитано (вдруг какую-то строку не подсчитали, документ предоставляют исключительно со значениями), вот только не могу додуматься - как сделать, чтоб одна формула считала итог у всех пустых столбцов B. Просто где-то роспись идёт из 1 строки, где-то из 5, некоторые вообще скрыты. Просто я бы эту 1 формулы применил ко всему документу, а потом через промежуточные итоги проверил - правильно внутри всё или неправильно. Прошу помочь, может у кого-то будут альтернативные идеи.
К сообщению приложен файл: 2567369.xlsx(10.6 Kb)
 
Ответить
СообщениеНе могу додуматься как решить вопрос, прошу помощи. Есть пример (бюджетная роспись), если в столбце B пусто, то это итоговая сумма расписанных далее видов расходов. В общем, надо как-то проверить, правильно ли там всё было подсчитано (вдруг какую-то строку не подсчитали, документ предоставляют исключительно со значениями), вот только не могу додуматься - как сделать, чтоб одна формула считала итог у всех пустых столбцов B. Просто где-то роспись идёт из 1 строки, где-то из 5, некоторые вообще скрыты. Просто я бы эту 1 формулы применил ко всему документу, а потом через промежуточные итоги проверил - правильно внутри всё или неправильно. Прошу помочь, может у кого-то будут альтернативные идеи.

Автор - Coldneel
Дата добавления - 27.12.2019 в 11:09
китин Дата: Пятница, 27.12.2019, 11:21 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6059
Репутация: 938 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
как понял
Код
=СУММЕСЛИ($A$2:$A$20;"="&"";$B$2:$B$20)

[p.s.] у вас в файле в ячейке D15 д.б. 132188,1 ??? так?
К сообщению приложен файл: 9074878.xlsx(10.7 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениекак понял
Код
=СУММЕСЛИ($A$2:$A$20;"="&"";$B$2:$B$20)

[p.s.] у вас в файле в ячейке D15 д.б. 132188,1 ??? так?

Автор - китин
Дата добавления - 27.12.2019 в 11:21
_Boroda_ Дата: Пятница, 27.12.2019, 11:29 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15747
Репутация: 6143 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
а потом через промежуточные итоги проверил

Не нужно. Можно сразу вот так
Код
=СУММЕСЛИ(A:A;"<>";B:B)=СУММ(B:B)/2

Но в любом случае есть вариант косяка, когда будет двойная ошибка на одинаковую сумму, типа вот так
Вид Сумма
.........480,0
610 0,0
.........0,0
240 480,0

китин, ;"="; достаточно

Не равно, а неравно - "<>"
К сообщению приложен файл: 2567369_1.xlsx(10.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
а потом через промежуточные итоги проверил

Не нужно. Можно сразу вот так
Код
=СУММЕСЛИ(A:A;"<>";B:B)=СУММ(B:B)/2

Но в любом случае есть вариант косяка, когда будет двойная ошибка на одинаковую сумму, типа вот так
Вид Сумма
.........480,0
610 0,0
.........0,0
240 480,0

китин, ;"="; достаточно

Не равно, а неравно - "<>"

Автор - _Boroda_
Дата добавления - 27.12.2019 в 11:29
bmv98rus Дата: Пятница, 27.12.2019, 11:33 | Сообщение № 4
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2895
Репутация: 501 ±
Замечаний: 0% ±

Excel 2013/2016
китин, ;"="; достаточно


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениекитин, ;"="; достаточно

Автор - bmv98rus
Дата добавления - 27.12.2019 в 11:33
Coldneel Дата: Пятница, 27.12.2019, 11:48 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
китин,_Boroda_, спасибо, в принципе простые и рабочие варианты. Но надо, чтобы какая то формула проверяла корректность расчетов. В-принципе моя формула рабочая, просто диапазон увеличить =ЕСЛИ(A2="";СУММЕСЛИ(A:A;"*";B:B);""), но как сделать, чтобы она считала только заполненный столбец B после пустого значения, а на новом пустом значении повторяла это действия только для следующих заполненных. Просто с помощью этого можно будет легко найти ошибки итд. в большом диапазоне данных.
 
Ответить
Сообщениекитин,_Boroda_, спасибо, в принципе простые и рабочие варианты. Но надо, чтобы какая то формула проверяла корректность расчетов. В-принципе моя формула рабочая, просто диапазон увеличить =ЕСЛИ(A2="";СУММЕСЛИ(A:A;"*";B:B);""), но как сделать, чтобы она считала только заполненный столбец B после пустого значения, а на новом пустом значении повторяла это действия только для следующих заполненных. Просто с помощью этого можно будет легко найти ошибки итд. в большом диапазоне данных.

Автор - Coldneel
Дата добавления - 27.12.2019 в 11:48
_Boroda_ Дата: Пятница, 27.12.2019, 12:56 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15747
Репутация: 6143 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
- Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение- Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - _Boroda_
Дата добавления - 27.12.2019 в 12:56
YouGreed Дата: Пятница, 27.12.2019, 13:21 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 469
Репутация: 100 ±
Замечаний: 0% ±

Excel 2010
Удалено администрацией, не исправлено замечание модератора


Сообщение отредактировал _Boroda_ - Пятница, 27.12.2019, 13:30
 
Ответить
СообщениеУдалено администрацией, не исправлено замечание модератора

Автор - YouGreed
Дата добавления - 27.12.2019 в 13:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчёт суммы при условии и повторение, при невыполнении (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!